Alexa Certified Site Metrics – AlexaBot 403 Error, Alexa Certify

Home Forums BulletProof Security Free Alexa Certified Site Metrics – AlexaBot 403 Error, Alexa Certify

Viewing 7 posts - 31 through 37 (of 37 total)
  • Author
  • #10613
    Akhil K A

    Followed these steps. Still not working. Also, now I can’t verify my domain fot accocunt.



    Here is my root .htaccess code, please take a look:
    [older bps security code removed to avoid confusion]

    AITpro Admin

    Your root .htaccess code looks good so it should be working.  Try clearing your Browser cache and plugin cache if you are using a caching plugin.  I don’t think that the new Brute Force Login Protection code would be blocking the Alexabot, but just to be sure comment out or delete the new Brute Force Login Protection code.  Maybe the Request is being made with Server Protocol HTTP/1.0?

    Alexa’s “Alexabot” crawler identifies itself in the User Agent as
    “Mozilla/5.0 (compatible; alexa Alexabot/1.0; +;”.


    Christoforos On.

    [Topic has been merged into this relevant Topic]

    I am using latest version of bps and latest of wp on my site Lately i wanted to certify my site’s metrics to alexa and faced the classic problem with error 403. I searched and came to this solution

    But new problem came up. I go step by step on this: Go to bps htaccess, turn auto lock off and then press to unlock. I get this message “Your Root .htaccess file has been Unlocked.”  I make the edits i need to htacess file but then i press to save and i get message that my .htaccess is locked and i have to unlock. I tried many times, deactivate & reactivate plugin but no luck.

    PS: I don’t use any other security plugins

    AITpro Admin

    When you do the Custom Code steps for Alexa metrics (or anytime you use Custom Code): your root htaccess file is unlocked and locked again during the Custom Code steps so you do not need to click the unlock button.  Anytime you are adding additional htaccess code or new custom htaccess code to your htaccess files you want to use Custom Code instead of adding your htaccess code directly into the htaccess files so that your custom htaccess code is saved permanently.  In other words, you can let BPS handle locking and unlocking and do not need to do that by clicking the unlock/lock buttons or manually.

    Do these steps to determine if your root htaccess file is being unlocked/locked successfully:
    1. Click the Turn Off AutoLock button.
    2. Click the Unlock htaccess File button.
    3. Click the WordPress Dashboard link.
    4. Go back to BPS and click the htaccess Core menu link and go to the htaccess File Editor tab page.

    Is your root htaccess file showing unlocked or locked?

    Christoforos On.

    hi, such a fast reply, thank you! Yes it was showing locked after going to dashboard and then to bps. Also tried to add the code you mention on earlier post on htacess custom code (specific place you mentioned) but still alexa was not able to scan. After some tries with no luck, i ended up checking permissions on .htaccess and they were 404 and i was not able to change it. I deleted it and reupload it (with corrections on |scan ) and it worked, alexa is crawling normal my site.

    AITpro Admin

    It sounds like either another plugin (not very likely) you have installed (may not necessarily be a security plugin) on your site may be doing something with htaccess file permissions (locking/unlocking) or your web host is automating (more likely) locking/unlocking htaccess files or not allowing locking/unlocking of htaccess files from your WordPress Dashboard.  Or you have an open_basedir problem or a file/folder permission problem or a file/folder Ownership problem. You would need to contact your host and ask them about that.


    [We do allow spam/spam links as long as they are relevant to: website security, WordPress or WordPress Plugins or Themes. Your spam comments and spam link have been deleted since they are not relevant to any of these things]

Viewing 7 posts - 31 through 37 (of 37 total)
  • You must be logged in to reply to this topic.