BPS 403 forbidden blocking saving Litespeed cache page settings

Home Forums BulletProof Security Free BPS 403 forbidden blocking saving Litespeed cache page settings

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #41613


    I am hoping you can help resolve an issue which recently started with BPS and LiteSpeed Cache plugin <span class=”litespeed-desc”>v4.5.0.1 </span>.

    BPS is blocking saving changes in the ‘Page Optimization’ tabs of LiteSpeed Cache Plugin.  It returns a “403 Forbidden Error, BPS Plugin 403 Error Page”. Code from the Log below.  Curiously I don’t see this problem with other Litespeed settings.

    I tried adding a skip rule (advised under WPADMIN-SBR) in Box 3, WP-ADMIN, but this has not worked, maybe I haven’t done that properly.  My IP is whitelisted in CC Box 14. I tried to whitelist the REQUEST URL below but that didn’t work, again I may have done it wrong.  I am not a coder and your advice would be greatly appreciated.

    [403 POST Request: 17 Mar 2022 ]
    BPS: 5.9
    WP: 5.9.2
    Event Code: WPADMIN-SBR
    Solution: https://forum.ait-pro.com/forums/topic/security-log-event-codes/
    Host Name: 
    HTTP_REFERER: https://mysitename/wp-admin/admin.php?page=litespeed-page_optm
    REQUEST_URI: /wp-admin/admin.php?page=litespeed-page_optm
    QUERY_STRING: page=litespeed-page_optm
    REQUEST BODY: BPS Security Log option set to: Do Not Log POST Request Body Data


    Thank you in advance for your time,


    AITpro Admin

    Most likely what is blocking your POST Form options save is ModSecurity.  Do these steps below to confirm that.

    Go to the BPS Security Log page > click the Turn Off Logging button.
    Then try and save your LiteSpeed Cache plugin settings.  If you see a generic server 403 error or a ModSecurity 403 error page then you will need to contact your web host to have them create a ModSecurity whitelist rule for you.


    Thanks so much for your prompt reply, greatly appreciated.

    As suggested I turned off logging.  On saving Litespeed Cache Plugin settings I get:

    my ip xxx.xxx.xx/wp-admin/admin.php?page=litespeed-page_optmwillshub.com.auMozilla/5.0 (Windows NT 10.0; Win64; x64; rv:98.0) Gecko/20100101 Firefox/98.0

    My apologies, I am a novice and unsure of what generic 403/ModSecurity errors look like, but it seems to me not the above?

    Any additional suggestions would be appreciated, and can paste htaccess code if thought.  Meantime I can contact my host.

    Thanks again!

    AITpro Admin

    Ok now completely eliminate BPS by doing troubleshooting steps #1 and #2 below and try to resave your LiteSpeed settings. Let me know what happens.


    1. On the Security Modes page, click the Root Folder BulletProof Mode Deactivate button. See Custom Code Note if doing this step works.
    2. On the Security Modes page, click the wp-admin Folder BulletProof Mode Deactivate button. See Custom Code Note if doing this step works.


    Hi, thank you again.

    I can’t see my reply posted yesterday.  However neither troubleshooting steps 1 and 2 allowed me to save LiteSpeed settings.

    Deactivating the Root Folder BulletProof Mode led to my ip/wp-admin/admin.php?page=litespeed-page_optmwillshub.com.auMozilla/5…

    Deactivating the wp-admin Folder led to 403 Forbidden message, BPS Plugin 403 Error Page.

    Even so I went through removing sections of custom code but same result.   I only have BPS code and LiteSpeed Cache in Custom Code as far as I am aware.

    Anything further would be appreciated, thank you.

    AITpro Admin

    The only possibilities for the cause of this problem are:
    ModSecurity installed on your web host is blocking saving LiteSpeed plugin option settings.
    You have another htaccess file somewhere under your hosting account that is causing this problem.
    A cPanel tool is causing this problem.

    At this point contact your web host and ask them to help you with the possible causes I have listed above.  When you deactivate BPS Root and wp-admin htaccess files you have eliminated that BPS is causing this problem.


    Thank you, will do.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.