BPS Pro is blocking my search

Home Forums BulletProof Security Pro BPS Pro is blocking my search

This topic contains 4 replies, has 2 voices, and was last updated by  webstar 1 month ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #37697

    webstar
    Participant

    Hi,

    I noticed this error in my security log:

    [403 GET Request: July 20, 2019 7:22 pm]
    BPS Pro: 14
    WP: 5.2.2
    Event Code: BFHS - Blocked/Forbidden Hacker or Spammer
    Solution: N/A - Hacker/Spammer Blocked/Forbidden
    REMOTE_ADDR: <deleted>
    Host Name:
    SERVER_PROTOCOL: HTTP/1.1
    HTTP_CLIENT_IP:
    HTTP_FORWARDED: <deleted>
    HTTP_X_FORWARDED_FOR:
    HTTP_X_CLUSTER_CLIENT_IP: <deleted>
    REQUEST_METHOD: GET
    HTTP_REFERER: <deleted>
    REQUEST_URI: /?select=Women%27s&lp_s_loc=861&lp_s_tag=&lp_s_cat=842&s=home&post_type=listing
    QUERY_STRING: select=Women%27s&lp_s_loc=861&lp_s_tag=&lp_s_cat=842&s=home&post_type=listing
    HTTP_USER_AGENT: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0
    

    This is me, though, making the search.

    And I get this error:
    “403 Forbidden Error Page
    If you arrived here due to a search or clicking on a link click your Browser’s back button to return to the previous page. Thank you.”
    How can I fix this?

    Thanks.

    #37698

    AITpro Admin
    Keymaster

    The apostrophe/single quote code character is being blocked.

    Solution for allowing apostrophe’s/single quote code characters in search forms on the frontend of your website:  http://forum.ait-pro.com/forums/topic/apostrophe-single-quote-code-character/#post-6939

    Solution for allowing apostrophe’s/single quote code characters in search forms on the backend of your website:  http://forum.ait-pro.com/forums/topic/search-string-403-error/#post-14372

    #37699

    webstar
    Participant

    Thanks. But, I already copied that into my Custom Code.

    #37700

    AITpro Admin
    Keymaster

    Did you do the rest of the Custom Code steps?  ie Save your custom code and activate Root folder BulletProof Mode again?

    #37701

    webstar
    Participant

    Sorry, I copied the wrong code. It works now.

    Thanks!

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.