Cannot redeclare bulletproof_security_load_plugin_textdomain

Home Forums BulletProof Security Pro Cannot redeclare bulletproof_security_load_plugin_textdomain

This topic contains 1 reply, has 2 voices, and was last updated by  AITpro Admin 5 years, 1 month ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #2930

    Jeff M
    Participant

    this is probably answered here, but i tried searching and it doesn’t come up. The free version works great. never an error when activating. the first time i try to activate the pro version, i get error. I deactivated and deleted the free version and tried activating the pro version. i deactivated all of my plugins. i switched themes. and I still get errors when trying to activate the pro version.
    This one:

    Fatal error: Cannot redeclare bulletproof_security_load_plugin_textdomain() (previously declared in /home/computer/public_html/lpnbsn.net/wp-content/plugins/bulletproof-security/bulletproof-security.php:40) in /home/computer/public_html/lpnbsn.net/wp-content/plugins/bulletproof-security1/bulletproof-security.php on line 82

    But when i reinstall the free version and activate it and deactivate it. then activate the pro version, it activates, but the options panel Why Upgrade to BulletProof Security Pro?

    It seems as though once the free version is loaded up the pro version won’t work.
    jeff
    ______________________________
    Really super frustrating. To continue with the above. Even though free version was deactivated and the pro version was activated. the plugin though it was still the free version. Tried to delete the free version but got an error. Deactivated the pro version. delete the free version, then tried to activate the pro version and i get this error:

    Warning: require_once(/home/computer/public_html/lpnbsn.net/wp-content/plugins/bulletproof-security/includes/class.php) [function.require-once]: failed to open stream: No such file or directory in /home/computer/public_html/lpnbsn.net/wp-content/plugins/bulletproof-security1/bulletproof-security.php on line 75

    What seems like a really big problem to me is that I tired the free version on a dozen sites and it work, so i bought the pro version. Is this going to happen on each of my dozen sites???
    ______________________________
    so I’m trying the pro version on another host and site, a site where there hasn’t been a free version install. and i get this error:

    Warning: require_once(/home/rewardso/public_html/accreditedonlinemba.org/wp-content/plugins/bulletproof-security/includes/class.php) [function.require-once]: failed to open stream: No such file or directory in /home/rewardso/public_html/accreditedonlinemba.org/wp-content/plugins/bulletproof-security1/bulletproof-security.php on line 75

    really not a great first impression of pro. so to say it but i’m pretty irritated.
    ______________________________
    Another update. I tried extracting the zip file and downloading via ftp program. then activating it on yet another site. i get this error:

    Warning: require_once(/home/computer/public_html/brain-games/wp-content/plugins/bulletproof-security/includes/class.php) [function.require-once]: failed to open stream: No such file or directory in /home/computer/public_html/brain-games/wp-content/plugins/BulletProof Pro/bulletproof-security.php on line 75
    #2938

    AITpro Admin
    Keymaster

    You need to uninstall the BPS free version before installing the Pro version.  Also sometimes the WordPress Upload Zip installer (PCLZIP) will append a number onto the end of a plugin folder during the WordPress upload zip installation whether or not the plugin folder already exists and even when the plugin folder never existed. Please see this Forum Topic on the cause and solution for this issue/problem:  http://forum.ait-pro.com/forums/topic/error-installing-bp-pro-after-using-bp-free/ After the one-time first time installation of BPS Pro you will never need to use the WordPress upload zip installer to install BPS Pro.  Upgrades are one-click in the Dashboard.  BPS Pro has a built-in Upload Zip installer.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.