Cannot run Backupbuddy

Home Forums BulletProof Security Pro Cannot run Backupbuddy

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #16793
    Chris Casalena

    Since adding Bulletproof-security Pro I cannot run my Backupbuddy – what should I do?

    AITpro Admin

    BPS Pro and Backupbuddy work fine together.  What type of Backup are you doing?  Are you using a Cron?  Do you see any errors?  Check your BPS Pro Security Log and post any security log entries that are related to Backupbuddy.

    Chris Casalena

    Hi – no logs re Backupbuddy. What is happening is I want to make a full backup. Page hangs awhile and the backupbuddy loging screen that used to open is not there so i don’t know if anything is happening. Then a couple of minutes later i get taken out of this page to a page on my website that says page cannot be found.

    Later on I went back to backupbuddy – backups to find it did make a full backup (not sure about the integrity of this backup though) I have tried to run with and without ‘Cron’ – also tried a few different Backupbuddy configurations – makes no difference – Memory is set at max 523MB

    is this normal?

    AITpro Admin

    Hi this is Ed,

    No, this is not normal and this is the same / very similar issue/problem that I saw on your website/Server when I ran the BPS Pro Setup Wizard.  The Setup Wizard appeared to hang, but it did complete successfully.  The Setup Wizard did not display all the Setup Wizard verification checking messages and instead appeared to stall/hang and displayed a 500 Error.

    523M is more than enough PHP memory and is actually too much memory.  I do not think that is the root cause of these problems.  WordPress needs a bare minimum of 64M of memory to run ok.  256M is the optimum PHP memory setting because it is not too much memory and not too little memory.  I think 523M is ok to use and is not the root problem.  What you need to do at this point is look at your Server logs to see what errors are occurring when performing a Backupbuddy backup.  The Server log errors should provide clues to what root problem is occurring.  I believe there is either a Server configuration problem or some additional configuration settings (constants) in your wp-config.php file that could be the root cause of this problem.  My hunch is this is a Server buffer or script execution type of problem.


    ModSecurity in my server was causing issues. BPS Pro was not  able to save custom htaccess. and several other features were not working.

    ModSecurity was seeing some features as an injection and I was getting 500 & 403 errors.  I had to whitelist several rules.

    And presently still have to whitelist rules because of updates to modsec rules.

    I also have Backup Buddy working. It works by using CPanels Backup utilities.  Yes, you just paid for the convenience of doing a backup from wordpress that can be done in cpanel. =)

    Anyhow, its worth having a look at the logs for ModSec. In putty/cmd line run the following:

    grep /usr/local/apache/logs/error_log | grep ModSecurity

    Look at the Putty command above, replace your domain name and verify that the path to your error log is the same, or else change it to your path. The command “grep” will display modsecurity logs. Its like a filter.

    So now run a Backup Buddy Backup and then run the command and see if you notice a time match, the same day and time. If you find something then post the error.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.