failed to open stream: No such file or directory function require-once

Home Forums BulletProof Security Pro failed to open stream: No such file or directory function require-once

  • This topic has 5 replies, 3 voices, and was last updated 7 years ago by MMG.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #7076
    Jeff M
    Participant

    I FTP and I get an error. I clear out all free version of the plugin and try uploading using word press upload plugin and i get the same error.

    I’ve been opting to use Better WordPress Security over this one, even though I bought this one. It causes errors when upgrading or just starting anew.

    Warning: require_once(/home/computer/public_html/xxxxx/wp-content/plugins/bulletproof-security/includes/class.php) [function.require-once]: failed to open stream: No such file or directory in /home/computer/public_html/xxxxxx/wp-content/plugins/bulletproof-security2/bulletproof-security.php on line 75

    I would like to use what I bought here, but each time I try and go through all the steps to get my paid version and then try to just active it , I get errors.

    Am I the only one.

    #7077
    Jeff M
    Participant

    Nevermind i figure this out. It has to be the exact name.

    #7080
    AITpro Admin
    Keymaster

    Thanks for confirming that you got this figured out.  This issue/problem happens when using the WordPress Upload Zip installer.

    http://forum.ait-pro.com/forums/topic/error-installing-bp-pro-after-using-bp-free/#post-117

    #11055
    MMG
    Participant
    Warning: require_once(/home/xxxxx/public_html/wp-content/plugins/bulletproof-security/includes/class.php) [function.require-once]: failed to open stream: No such file or directory in /home/xxxxx/public_html/wp-content/plugins/bulletproof-security1/bulletproof-security.php on line 76

    That was the message when I re-uploaded and attempted to activate. The reason i am reactivating is because the plugin automatically removed itself when I removed the directory “themes” from the dynamically exclude section. It all started when I noticed wp-content was not saving in auto restore, so I started by removing the “themes” exclusion.

    Appreciate your advice and how to get up and running again.

    Murray

    #11060
    AITpro Admin
    Keymaster

    Your post has been merged into this relevant Topic.

    The php error shows that the BPS plugin folder is named:  /bulletproof-security1 instead of just /bulletproof-security.  Rename the /bulletproof-security1 folder to /bulletproof-security.

    I assume the original problem was caused by either invalid AutoRestore exclude paths or maybe not turning Off AutoRestore while adding or removing exclude rules.  Turn Off ARQ and double check that all of your exclude rules are valid, then click the 3 exclude rules buttons on the Exclude Dynamic Folders – Temp/Cache page.

    #11064
    MMG
    Participant

    Back to 100%. Thank you.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.