The BPS version: BULLETPROOF .xx.x >>>>>>> SECURE .HTACCESS line of code was not found at the top of your Root htaccess file.

Home Forums BulletProof Security Free The BPS version: BULLETPROOF .xx.x >>>>>>> SECURE .HTACCESS line of code was not found at the top of your Root htaccess file.

This topic contains 9 replies, has 2 voices, and was last updated by  AITpro Admin 1 year, 9 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #30867

    Bruce
    Participant

    I have the error:

    The BPS version: BULLETPROOF .xx.x >>>>>>> SECURE .HTACCESS line of code was not found at the top of your Root htaccess file.

    So I went to the Htaccess file editor tab and it says the file is locked with Read Only.  I click the unlock and copy this line:

    #   BULLETPROOF .54 >>>>>>> SECURE .HTACCESS

    from the secure.htaccess tab to the current root file tab where it didn’t exist and click update.   The locked error goes away and the version line is there on the current root file tab…but at the very top of the page I click “reload BPS status display” then it goes back to the way it was with those errors!  And the version line is gone again from the current root file.  What am I doing wrong?

    #30876

    AITpro Admin
    Keymaster

    The error message is pretty accurate so it literally means that “The BPS version: BULLETPROOF .xx.x >>>>>>> SECURE .HTACCESS line of code was not found at the top of your Root htaccess file.”  In other words, BPS checks the BPS root htaccess file to ensure that things are ok.  it’s a literal check and has a literal meaning.  So do this below.

    Go to the BPS htaccess File Editor page and copy and paste your root htaccess file so I can see what the issue is.

    #30899

    Bruce
    Participant

    This is a very frustrating error for me.  I am getting the BPS Alert message:  BULLETPROOF .xx.x >>>>>>> SECURE .HTACCESS line of code was not found at the top of your Root htaccess file

    And I cannot put it in.  It says to go to the Setup wizard, but I run that and nothing changes.  I go to the Htaccess editor, unlock the file, when I click the tab for current root file that line of code is not there.  If I add it in the editor,  when I click update and then view again it is still not there.  And I have unlocked the file for editing.  How do I fix this?

    #30903

    AITpro Admin
    Keymaster

    It sounds like your web host does not allow htaccess files if you are unable to add or create an htaccess file on your website.  Check with your web host and see if they allow htaccess files or maybe they are blocking something on your website.

    #30938

    Bruce
    Participant

    This is what is in my root htaccess file:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress
    #30939

    AITpro Admin
    Keymaster

    Ok so what it sounds like is happening is one of these 2 things:

    1. Either your host is not allowing BPS htaccess code/files and is automatically replacing the BPS root htaccess file with a generic WP default htaccess file/code.

    2. Another plugin you have installed is automatically replacing the BPS root htaccess file with a generic WP default htaccess file/code.

    Try doing these steps and let me know what happens:
    1. Go to the htaccess File Editor page > click the Lock htaccess File button > click the Turn on AutoLock button.
    2. Go to the Security Modes page > click the Root Folder BulletProof Mode Activate button.

    #30940

    Bruce
    Participant

    Well what’s happening is I do that, then I add that line and click “update file”.  But then if I refresh the page, it goes back to locked and that line I added disappears so it is the same as before.

    As far as plugins, all I have is Askimet, Obfuscate Email, Quick Page Redirect, Search & Replace, Sociable, and Yoast SEO.  So I went and deactivated all of them, and then tried editing the htaccess again and there is no change.  So it probably isn’t a plugin.

    #30941

    AITpro Admin
    Keymaster

    Ok I just need for you to do ONLY these steps below and nothing else.  Do not try to do this:  “add that line and click “update file”. ”  When you click the Root Folder BulletProof Mode Activate button a new BPS root htaccess file should be created with everything that needs to be/should be in it.

    1. Go to Custom Code > click the Delete button next to the Import button to delete any existing code in Custom Code.
    2. Go to the htaccess File Editor page > click the Lock htaccess File button > click the Turn on AutoLock button.
    3. Go to the Security Modes page > click the Root Folder BulletProof Mode Activate button.

    #30942

    Bruce
    Participant

    Ok.  Done.  It says root folder mode “activated”.  As soon as I refresh the page and go to the editor to view it, it is back to basic code and the error message about the missing code up top.

    #30943

    AITpro Admin
    Keymaster

    Ok so these are the only 2 possibilities for why the problem is occurring then that I can think of:

    1. Either your host is not allowing BPS htaccess code/files and is automatically replacing the BPS root htaccess file with a generic WP default htaccess file/code.  So you will need to contact your host and ask them if they are doing that. Something like a security measure on the server thats is rejecting/blocking or replacing the BPS root htacces file/code.

    2. There is some code in your wp-config.php file that is automatically replacing or rejecting the BPS root htacces file/code.  So you will need to contact your host and ask them to take a look at your wp-config.php file to see if there is any code in that file that could do something like this.

    It may just be that your host does not allow BPS htaccess files at all and you can choose to disable all htaccess files on the Setup Wizard Options page >  Enable|Disable htaccess Files option.  You would then not see the error anymore, but of course you would not be able to use BPS htaccess files.  It’s worth asking your host if this is something that they can fix on your server/website.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.