Class ZipArchive not found in installation.php on line 259

Home Forums BulletProof Security Pro Class ZipArchive not found in installation.php on line 259


This topic contains 15 replies, has 3 voices, and was last updated by  rafaelmagic 2 years, 11 months ago.

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
  • #21889


    [Topic has been split into a new Topic]

    Went through process many times (according to php error log).

    [07-Apr-2015 19:23:15 UTC] PHP Fatal error:  Class 'ZipArchive' not found in /home/yeslinco/public_html/wp-content/plugins/bulletproof-security/admin/install/installation.php on line 259

    Upload went fine of 1.14MB zip new BPSP zip file and then appeared the normal:
    Zip File Upload Successful.
    Click the Install Zip Now button to install BulletProof Security Pro.

    Peak Memory Usage: 42.39MB|43,402KB
    Initial Memory in Use: 41.79MB|42,793KB
    Total Memory Used: 0.60MB|610KB
    Completion Time: 0.01 Seconds

    I just looked in the wp-content/plugins folder and the latest zip folder is there.
    Then hit the Install Zip Now button:
    It pauses/working for a moment and then I get a screen that is not completed (each time)
    The blue tab bars are stacked at the top then a short white title Upload Zip Installer in its gray-lined box and nothing more.

    Is it not able to overwrite? Autorestore is off. An .htaccess problem on this one? I see an .htaccess in plugins folder – my IP address is allowed there.


    Re-downloaded new BPSP file. All looks the same. Uploaded, attempted install, all the same. Newest file is in the plugins folder.

    [07-Apr-2015 19:48:31 UTC] PHP Fatal error:  Class 'ZipArchive' not found in /home/yeslinco/public_html/wp-content/plugins/bulletproof-security/admin/install/installation.php on line 259

    AITpro Admin

    The php error means that your server is not using/enabling the ZipArchive class so that leaves you with having to do a manual FTP upload then.



    What do I have to do on the server to change that?


    AITpro Admin

    You would ask your host to do that, but it is very doubtful that they will do something like on your server.  They may have other servers that already have the ZipArchive class enabled.  If so they would migrate your site to that other server.  I believe some hosts think that disabling the ZipArchive class adds some security, but of course that is not true.  The ZipArchive class has been available since PHP5 (released 11 years ago):



    I run the vps server, they don’t help a lot even when asked and remind people that support is not included. I will find the enabler and do so.


    AITpro Admin

    If zip is installed/compiled then you would just need to add this in your php.ini file to load the zip extension:



    Thank you, that helps. I’m going over the Apache PHP Configuration Editor now.



    May I add it to the WHM: PHP Configuration Editor under Core extension:,,

    –Making it,,,

    Then I’ll save and see if it works…. ?


    AITpro Admin

    Maybe.  Not really sure.  Typically you would just edit your php.ini file and add this directive in it:



    That area always overrides any php.ini file on the sites.

    No, it didn’t work. I got a flood of error_log files dumped in several folders, which were all immediately quarantined, and appears to not be installed yet. I only found one thing on the exhaustive list of php setting in Easy Apache compiling… and am reading that.

    “ cannot open shared object file: No such file or directory in Unknown on line 0”

    So I viewed them and it was:

    [07-Apr-2015 22:16:04 America/Denver] PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20121212/' - /usr/local/lib/php/extensions/no-debug-non-zts-20121212/ cannot open shared object file: No such file or directory in Unknown on line 0

    Now I’m resetting all my BPS Pro sites quarantines… 🙂



    Are you using WinSCP? How about Putty?

    did you manually look in the extensions folder for the file? It might be located in another directory.



    No I didn’t, I thought it would be loaded when I added it to the php.ini on the server and in the root directory of the install. I’ll attempt to go do that.

    …. No it is not there. Only folders w/files of the others mentioned above.

    Finally hit a search string and got this:

    Lists under available extensions for PHP

    zip     Zip    Docs    Read/Write zip Archives

    I believe that is it.



    Installed “Zip” extension via Easy Apache and then installed BPSP new zip folder and I get normal messages (but is still not in the above server folder, and ‘–enable-zip’ is in top of phpinfo Conf Command—all less stringent):
    BPS Pro Zip Installation Successful.
    The uploaded file has been deleted automatically. To reinstall BPS Pro again please upload another file and click the Install Zip Now button.  etc.

    Unfortunately, you were right, still get exact same error message of “Cannot redeclare bpspro_ap_check” – so let me know if I can do and learn more… 🙂

    All other installs on the same server are fine. Plugin test next.



    php -m

    should list the modules. Have you manually found the

    Sometimes it dosnt have to be loaded in the Php.ini if it’s compiled, it’s automatic. You might be double loading it.

    Now another question is if the other sites are working, why isn’t this one.

    Did you Chown/permission the WordPress plugins directory?

    Maybe another plugin is interfering. Sometimes bad programming from 3rd party plugins messes up the SQL. Some occasions you have to reset the WordPress plugins folder.

    I would check the owner/permissions manually, deactivate all your plugins and try BPS activation. If that dosnt work. Then do a plugins folder reset. Also check your SQL tables.



    Thank you rafaelmagic, appreciate your feedback.

    I believe the is on automatic now. Haven’t looked elsewhere and there was a php.ini in root to load it already as AIT suggested. I’ll play with that to see if it truly is double loading. BPSP has always activated and worked except for the php error topic. (once the mail system would deliver the activation keys to some email client somewhere–only gmail would work and AIT knows about this problem)

    Yes, we have always asked “why just this site” but I never tried to use the BPSP internal install, so I’m glad this forced me to learn that process. Compiling with Zip dropped the vps out of Ruid2 configuration I discovered. But that’s fine.

    Plugins: the only thing left. Two sites are almost identical except for some plugins and I disabled all these I no longer need for this site (goal achieved).  Didn’t want to take the time to figure out which one, so here for posterity: bbPress Admin Bar Addition, bbPress Moderation, Genesis Toolbar Extras, Register IPs, TablePress, WP Edit. (I have TablePress on other sites.)
    NO ERRORS IN 10 HOURS. Considered solved.

    I am not sure what chown (ch own) permission. BPSP is not checking plugins folder. For a discussion elsewhere.

Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.