Contact Form 7 not working

Home Forums BulletProof Security Pro Contact Form 7 not working

This topic contains 3 replies, has 2 voices, and was last updated by  AITpro Admin 9 months, 2 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #34228

    Mike
    Participant

    I seem to have two issues.

    During the last update BPS completely disabled my contact forms.   I was using WPForms and then tried Contact Form 7.   I have tried auto whitelists on both forms, and reviewed the security log.   Neither plugin shows any blocking on the security log, however the forms will not process any data.   If I disable the BPS plugin they work.    I would copy and past the code I would normally see in the security log I would forward it with this question, but nothing is appearing in the log showing these functions are blocked.  Usually when something is blocked it shows in the security log.

    I have removed these plugins completely and reinstalled with no success.   Security logs remain blank and the plugins do not function.

    When I try to manually whitelist the plugins the entire BPS screen completely becomes deformed – and I have to completely reinstall use the installation wizards and start from scratch.

    The other thing I notice is it wipes out my https:  site and I have to manually enter this file back into the root htacess file.  On any update or fix this files is overwritten and my website will load without the https function unless I manually edit the htaccess file.   Any reason this is happening?

    # WP REWRITE LOOP START
    RewriteEngine On
    RewriteBase /
    RewriteCond %{HTTPS} !=on
    RewriteCond %{SERVER_PORT} ^80
    RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R,L]
    RewriteRule ^index\.php$ - [L]

    If you have an idea on what to add to the whitelist to get either of these plugins to properly function, please respond to this post.   I will reinstall either plugin and try again.

    Best Regards –  and no hurry for the response –  its not the end of the world!

    Mike

    #34230

    AITpro Admin
    Keymaster

    What does this mean? – “If I disable the BPS plugin they work”.  How exactly are you disabling BPS?  Normally you would want to do BPS Pro troubleshooting steps to figure out what is causing the problem > https://forum.ait-pro.com/forums/topic/read-me-first-pro/#bps-pro-general-troubleshooting Are you saving your SSL code and any other custom htaccess code in BPS Custom Code? If you completely uninstalled the BPS Pro plugin then that would mean that all plugin settings would be deleted, which would include any custom code that you previously saved to BPS Custom Code. The BPS and BPS Pro plugins are designed in a way that you should never need to deactivate or delete them and you would instead use the BPS or BPS Pro troubleshooting steps.

    #34252

    Mike
    Participant

    Good evening –

    Alright – Here is what I need help, Thank you in Advance.

    I installed WPForms to set up my contact form.   I installed the plugin, built the page and entered the short-code.    I tried using the contact form and did not get an error message through the security log saying the plugin was blocked.   It did not work.  So after reading the whitelist rules and how to set up – I ran the pre-installation wizard with no errors and then ran the set up wizard.   Everything completed as it should.  I went into the contact form again and submitted the form hoping that I would see an error message in the security scan so I could whitelist this plugin.   Nothing showed up outside of a hacker trying to login.   See below.

    [Internal Usage: AJAX Shiny Plugin Install: post_var: arq_auto_plugin_shiny_install | September 29, 2017 - 6:48 pm]
    [Internal Usage: AJAX Shiny Plugin Install: bps_arq_upgrade value: arq_auto_plugin_shiny_install | September 29, 2017 - 6:48 pm]
    [Internal Usage: AJAX Shiny Plugin Update|Install: Prior ARQ Cron Status: On | September 29, 2017 - 6:48 pm]
    [Internal Usage: AJAX Shiny Plugin Update|Install: ARQ Cron was turned Off | September 29, 2017 - 6:48 pm]
    
    [Internal Usage: upgrader_pre_install Filter: Triggered | September 29, 2017 - 6:48 pm]
    [Internal Usage: upgrader_pre_install Filter: Prior ARQ Cron Status: On | September 29, 2017 - 6:48 pm]
    [Internal Usage: upgrader_pre_install Filter: ARQ Cron was turned Off | September 29, 2017 - 6:48 pm]
    [Internal Usage: upgrader_post_install Filter: Triggered | September 29, 2017 - 6:48 pm]
    [Internal Usage: upgrader_post_install Filter: Backup performed | September 29, 2017 - 6:48 pm]
    [Internal Usage: AFS Cron: Prior ARQ Cron Status: On | September 29, 2017 - 6:51 pm]
    [Internal Usage: AFS Cron: WP /languages/ folder backup | September 29, 2017 - 6:51 pm]
    [Internal Usage: AFS Cron: ARQ Cron was turned On | September 29, 2017 - 6:51 pm]
    
    [Login Form - POST Request Logged: September 29, 2017 - 6:57 pm]
    BPS Pro: 13.3.3
    WP: 4.8.2
    CAPTCHA Entered:
    BOT/HUMAN: Most Likely a SpamBot
    REMOTE_ADDR: 109.252.91.226
    Host Name: ppp109-252-91-226.pppoe.spdop.ru
    SERVER_PROTOCOL: HTTP/1.1
    HTTP_CLIENT_IP:
    HTTP_FORWARDED:
    HTTP_X_FORWARDED_FOR:
    HTTP_X_CLUSTER_CLIENT_IP:
    REQUEST_METHOD: POST
    HTTP_REFERER: https://nimaway.com/wp-login.php
    REQUEST_URI: /wp-login.php
    QUERY_STRING:
    HTTP_USER_AGENT: Mozilla/5.0 (Windows NT 6.0; rv:34.0) Gecko/20100101 Firefox/34.0
    
    [AutoRestore Turned Off Cron Check: September 29, 2017 - 7:04 pm]
    This Security Log entry is created when AutoRestore is turned Off on your website. To change or turn Off this setting go to the BPS Pro S-Monitor page, under Email Alerting & Log File Options change the ARQ: When AutoRestore|Quarantine is Turned Off option setting to whatever setting you would like to use instead.
    
    I see nothing in the whitelist settings either for WPForms.   Here is a copy of that.
    
    /akismet/_inc/form.js, /authy-two-factor-authentication/assets/authy-profile.js, /all-in-one-seo-pack-pro/js/quickedit_functions.js, /jetpack/modules/widgets/eu-cookie-law/eu-cookie-law.js, /jetpack/modules/photon/photon.js, /jetpack/modules/wpgroho.js, /jetpack/modules/related-posts/related-posts.js, /authy-two-factor-authentication/assets/authy-onetouch.js, /jetpack/modules/widgets/milestone/milestone.js, /jetpack/modules/widgets/google-translate/google-translate.js, /jetpack/modules/custom-css/custom-css/js/core-customizer-css.js, /jetpack/modules/custom-css/custom-css/js/codemirror.min.js, /jetpack/modules/widgets/customizer-utils.js, /jetpack/_inc/twitter-timeline.js, /jetpack/modules/custom-css/custom-css/js/core-customizer-css-preview.js, /jetpack/_inc/facebook-embed.js, /all-in-one-seo-pack-pro/js/modules/aioseop_module.js, /jetpack/modules/after-the-deadline/tinymce/plugin.js, /jetpack/_inc/jetpack-jitm.js, /jetpack/_inc/lib/tracks/tracks-ajax.js, /jetpack/_inc/gallery-settings.js, /jetpack/modules/theme-tools/responsive-videos/responsive-videos.min.js, /jetpack/modules/after-the-deadline/atd-nonvis-editor-plugin.js, /jetpack/modules/after-the-deadline/atd.core.js, /jetpack/modules/after-the-deadline/atd-autoproofread.js, /jetpack/modules/after-the-deadline/jquery.atd.js, /jetpack/modules/widgets/google-plus/js/admin.js, /jetpack/modules/widgets/twitter-timeline-admin.js, /jetpack/modules/widgets/contact-info/contact-info-admin.js, /jetpack/modules/widget-visibility/widget-conditions/widget-conditions.js, /updraftplus/includes/updraft-admin.min.js, /updraftplus/includes/jquery.blockUI.min.js, /updraftplus/includes/jquery.serializeJSON/jquery.serializejson.min.js

    What would you suggest I try as the next step as I am not sure exactly how to whitelist this plugin.
    Thanks
    Mike

    #34253

    AITpro Admin
    Keymaster

    That is a lot of information but none of it is relevant to whatever the problem is.  Thanks for posting that info anyway.  Do BPS Pro troubleshooting steps and let me know the results of doing BPS Pro troubleshooting steps.  I think you might be going too deep here.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.