ERROR: Deny All protection NOT activated for BPS Master /htaccess folder

Home Forums BulletProof Security Pro ERROR: Deny All protection NOT activated for BPS Master /htaccess folder

Tagged: 

This topic contains 20 replies, has 3 voices, and was last updated by  AITpro Admin 4 years, 2 months ago.

Viewing 15 posts - 1 through 15 (of 21 total)
  • Author
    Posts
  • #25045

    Paul
    Participant

    I had auto_.htaccess quarantined now restored but not sure if related but i see in security status i have ERROR: Deny All protection NOT activated for BPS Master /htaccess folder. Tried to create secure .htaccess again but still has this error? In htaccess editor Turn Off Autolock has off next to it same on other sites but turn on autolock is on and no quarantined files I notice you say [deleted old information and link that is now obsolete] So should i be doing this, not noticed before but to be honest not checked status for a while

    #25052

    AITpro Admin
    Keymaster

    The Master htaccess file BulletProof Mode should be activated automatically.  To manually activate Master htaccess BulletProof Mode go to the B-Core|htaccess Code > Security Modes tab page and click the BulletProof Mode Activate button.

    #25053

    Paul
    Participant

    Thank You. Why then on all my sites, all on different servers is this not being done automatically?

    #25054

    AITpro Admin
    Keymaster

    Did you run the Setup Wizards when you installed BPS Pro on these sites?  If so and Master htaccess BulletProof Mode was not automatically activated then send me an Administrator login to one of these sites so I can see what the problem is.  Send the login information to info at ait-pro dot com.

    #25055

    Paul
    Participant

    Yes i did. I know this issue was not there in the past ( some time back) as i always check the status after install. I have now activated them, so probably too late for you to look?

    #25057

    AITpro Admin
    Keymaster

    We will double check the BPS Pro code that creates the Master htaccess BulletProof Mode file and see if we find anything that could cause this type of problem.  There were a lot of htaccess file changes in BPS Pro 11 so it is possible that there is a bug somewhere.

    #25058

    Paul
    Participant

    For your information yesterday i updated several plugins, but the only one unique to all sites was Seo Yoast https://wordpress.org/plugins/wordpress-seo/ Not saying this was the reason as i never checked before updating and this issue may have been there for some time.

    #25059

    Zsolt Edelényi
    Participant

    I am testing BPS PRo. I changed style.css in the theme folder via FTP. I did it two of my sites. One of them put the file to quarantine, but other not. Autorestore is active in both websites. Do you have any idea why not?

    #25063

    AITpro Admin
    Keymaster

    @ Zsolt Edelényi – If you would like for me to login and check the site then send a WordPress Administrator login to info at ait-pro dot com.

    #25070

    AITpro Admin
    Keymaster

    @ Paul – We have seen a couple of cases where the Master htaccess file is not being created because the new Apache Module checking code in BPS Pro 11 cannot get the correct URL path to the /mod-test/ folder due to invalid code in the wp-config.php file. http://forum.ait-pro.com/forums/topic/error-wp_remote_get-function-in-system-info/#post-24912

    Go to the BPS System Info page and copy and paste the Apache Module information for your website:
    Apache Modules|Directives|Backward Compatibility(Yes|No)|IfModule(Yes|No): View Visual Test
    mod_access_compat is Loaded|Order, Allow, Deny directives are supported|IfModule: Yes
    mod_authz_core is Loaded|Order, Allow, Deny directives are supported|BC: Yes|IfModule: Yes
    mod_authz_host is Loaded|Order, Allow, Deny directives are supported|BC: Yes|IfModule: Yes

    #25072

    Paul
    Participant

    Hi, this is one of my sites,

    Apache Modules|Directives|Backward Compatibility(Yes|No)|IfModule(Yes|No): View Visual Test
    mod_access_compat is NOT Loaded|Order, Allow, Deny directives are NOT supported
    mod_authz_core is NOT Loaded
    mod_authz_host is NOT Loaded

    This one on another server

    Apache Modules|Directives|Backward Compatibility(Yes|No)|IfModule(Yes|No): View Visual Test
    mod_access_compat is NOT Loaded|Order, Allow, Deny directives are NOT supported
    mod_authz_core is NOT Loaded
    mod_authz_host is NOT Loaded
    #25073

    AITpro Admin
    Keymaster

    Yep, that is the problem.  Basically your server is not seeing something or something is breaking the Apache Module test or the Apache Module test is not working on your site for some reason.  Send me an Administrator login to one of these sites so I can find out what the problem is.  Send the login information to edward at ait-pro dot com.

    #25074

    AITpro Admin
    Keymaster

    Send the login information to edward at ait-pro dot com

    #25077

    Paul
    Participant

    On its way titled “Login re Forum Paul”

    #25084

    AITpro Admin
    Keymaster

    Ok got the hotmail email you just sent.  Logging in now.  Thanks.

Viewing 15 posts - 1 through 15 (of 21 total)

You must be logged in to reply to this topic.