login security ip address problem(shown as localhost)

Home Forums BulletProof Security Pro login security ip address problem(shown as localhost)

This topic contains 7 replies, has 2 voices, and was last updated by  AITpro Admin 1 year, 1 month ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #33168

    Ash F
    Participant

    Login security shows all login user as localhost(127.0.0.0)

    How do I fix this?

    #33170

    AITpro Admin
    Keymaster

    Sounds like you are using a Proxy/Reverse Proxy server and it is not configured correctly.  Go to the BPS System Info page and copy and paste this information:  Note:  use x’s to hide your ISP IP address. 😉

    Server|Website IP Address: 173.201.92.22
    Host by Address: ip-173-201-92-22.ip.secureserver.net
    DNS Name Server: ns26.domaincontrol.com
    Public Internet IP Address (ISP): xxx.xxx.xxx.xxx
    Server Type: Apache
    Operating System: Linux
    WP Filesystem API Method: direct
    Server API: cgi-fcgi CGI Host Server Type
    Apache Modules|Directives|Backward Compatibility(Yes|No)|IfModule(Yes|No): View Visual Test
    403: mod_access_compat is Loaded|Order, Allow, Deny directives are supported|IfModule: Yes
    403: mod_authz_core is Loaded|Order, Allow, Deny directives are supported|BC: Yes|IfModule: Yes
    403: mod_authz_host is Loaded|Order, Allow, Deny directives are supported|BC: Yes|IfModule: Yes
    200: mod_rewrite Module is Loaded

    #33172

    Ash F
    Participant

    yeah, I see proxy info. Is this because of our server is using Nginx and Varnish?

    Server|Website IP Address: 127.0.0.1
    Host by Address: localhost
    DNS Name Server: ns41.domaincontrol.com
    Proxy X-Forwarded-For IP Address: ***.***.***.***, 127.0.0.1
    Server Type: Apache/2.4.10 (Debian)
    Operating System: Linux
    WP Filesystem API Method: direct
    Server API: fpm-fcgi CGI Host Server Type
    Apache Modules|Directives|Backward Compatibility(Yes|No)|IfModule(Yes|No):
    200: mod_access_compat is Loaded
    200: mod_rewrite Module is Loaded

    #33173

    AITpro Admin
    Keymaster

    Yep, definitely a Proxy configuration problem. 😉   Typically you should only see 1 IP address here:  Proxy X-Forwarded-For IP Address and I see 2 IP addresses.  This is outside of the support we offer for the BPS Pro plugin.  So at least you know what/where the problem is and will need to work with your host support folks to figure out the Proxy config problem.

    #33176

    Ash F
    Participant

    Thank you.
    That was caused by server’s security related setting.
    adding this to wp-config solved the problem.

    $_SERVER['REMOTE_ADDR'] =$_SERVER['HTTP_X_REAL_IP'];
    #33177

    AITpro Admin
    Keymaster

    Great!  Glad you got it figured out.

    #33178

    Ash F
    Participant

    I received updated code from tech support

    if(isset($_SERVER['HTTP_X_FORWARDED_FOR'])){
      $xffaddrs = explode(',',$_SERVER['HTTP_X_FORWARDED_FOR']);
      $_SERVER['REMOTE_ADDR'] = $xffaddrs[0];
    }
    #33179

    AITpro Admin
    Keymaster

    Cool!   Thanks for sharing this solution.  ie in case someone else runs into this same problem. 😉

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.