Security Log page blank – unable to view

Home Forums BulletProof Security Pro Security Log page blank – unable to view

Tagged: 

This topic contains 3 replies, has 2 voices, and was last updated by  AITpro Admin 3 months, 1 week ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #35350

    Max
    Participant

    In the dashboard I see “A New Security Log Entry Has Been Logged. Click Here to go to your Security Log.”

    When I click on the link it will lead to /wp-admin/admin.php?page=bulletproof-security/admin/security-log/security-log.php there is just an empty page.

    #35351

    AITpro Admin
    Keymaster

    Is the Security Log page the only BPS plugin page that is blank?

    If so, then these are the possible causes for the problem:

    The automated WP Cron zip, email and delete function is not working due to another plugin or WP Crons have been disabled or your web host has disabled WP Crons.  The Security Log file is extremely large.
    Use FTP or your web host control panel file manager to check the size of the Security Log file:  /wp-content/bps-backup/logs/http_error_log.txt.  The normal average max size of the Security Log file is between 500KB and 1MB.  If your Security Log file is larger than 1MB you can either save a copy of it and delete it or just delete it.  If the same problem occurs again at a later time and your Security Log file is not automatically being zipped, emailed to you and replaced with a new blank Security Log file then let us know that.

    Mod Security is enabled or some other web host security measure that is blocking the Security Log text file contents from being viewed.
    Use FTP or your web host control panel file manager to either save a copy of your Security Log file and delete it or just delete it:  /wp-content/bps-backup/logs/http_error_log.txt.  If the same problem occurs again at a later time and your Security Log file is not automatically being zipped, emailed to you and replaced with a new blank Security Log file then let us know that.

    #35352

    Max
    Participant

    The problem lied in the recently activated HTTPS that forced HTTPS. Then the empty site appeared and no logs were accessible.

    When I then tried to run the pre-setup check, it told me that I need a new key for HTTPS. I then request and download a new key, and now it’s fine again.

    #35353

    AITpro Admin
    Keymaster

    Great!  Thanks for confirming the problem is resolved.  Also see this forum topic on adding HTTPS/SSL htaccess code for your website > https://forum.ait-pro.com/forums/topic/wordpress-ssl-htaccess-code-rewrite-ssl-rewritecond-server_port/#post-7233

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.