Maintenance Mode not working

Home Forums BulletProof Security Free Maintenance Mode not working

This topic contains 16 replies, has 5 voices, and was last updated by  AITpro Admin 1 year, 8 months ago.

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #3548

    Greg
    Member

    Site Title: set
    Message 1: set
    Background Image: Set
    Clicked “Save Form Settings”
    Clicked “Create Form”
    Previewed Form: Fine
    Clicked “Create htaccess file”
    Selected “Maintenance Mode”
    Clicked “Activate Maintenance Mode”
    Cleared Browser cache of Chrome & Firefox
    Browsed to website which didn’t display maintenance mode
    Everything else appears to be working fine
    Any ideas or should I delete and reinstall?

    Thanks

    #3549

    AITpro Admin
    Keymaster

    Did you check your website from another IP Address?  Your website will display as it normally would to you.  Visitors will see a Maintenance Mode page.  Use a Proxy to check your website with another IP Address.

    #3550

    Greg
    Member

    Works for me thanks!

     

    #20513

    Markus
    Participant

    [Topic has been merged into this relevant Topic]

    Hello everybody,

    I have successfully installed the BPS and configurated it and it works like a charm. The only thing that doesn’t work is the Maintenance Mode. I configured it just to show up on the FrontEnd, but it doesn’t work. I tried everything but I can’t see the solution to that problem.

    Maybe anyone can help me. Thanks in advance.

    best regards,
    Markus

    #20518

    AITpro Admin
    Keymaster

    @ Markus – Did you check your website from another IP Address? Your website will display as it normally would to you. Visitors will see a Maintenance Mode page. Use a Proxy to check your website with another IP Address.

    #20523

    Markus
    Participant

    Wow, first of all big respect that freaking fast reply! 🙂

    I really have checked it with proxy and have let a lot of other peopls check it! The plugin tells me that the Maintenance Mode has been switched on but it doesnt work!

    best

    #20524

    AITpro Admin
    Keymaster

    What type of WordPress site/installation is this?  Standard single installation or Giving WordPress Its Own Directory (GWIOD) WordPress site/installation?  Network/Multisite subdirectory/subdomain or Network/Multisite GWIOD?

    #20526

    Markus
    Participant

    Wordpress 4.1. / Single installation using WPML / WordPress running on a subfolder / URL: synolon.de/dev/

    #20527

    AITpro Admin
    Keymaster

    Do these troubleshooting steps:

    MMode Option Settings:
    Check checkbox Enable Countdown Timer
    Enter 15 in the Maintenance Mode Time & the Header Retry-After text boxes.
    Check checkbox Enable FrontEnd Maintenance Mode
    Enter Your Current IP Address: or the Recommended IP Address:
    Check checkbox Display Visitor IP Address
    Click the Save Options button.
    Click the Preview button.

    Do you see the Maintenance Mode page in Preview mode?
    If so, then click the Turn On button.
    Check your website with Boom Proxy to see if the Maintenance Mode page is displaying correctly.
    If it is not then use FTP or your web host control panel file manager and check that these 2 files have been created in your WordPress site installation folder: bps-maintenance.php and bps-maintenance-values.php. Check the contents of this file: /index.php in your WordPress site installation folder. You should see code that looks like this below in your index.php file:

    #############################################################
    # If you manually edit this file make a backup of this file #
    # this file will be replaced when you upgrade BPS Pro #
    #############################################################
    define('WP_USE_THEMES', true);
    
    # BEGIN BPS MAINTENANCE MODE IP
    $bps_maintenance_ip = array('127.0.0.1');
    # END BPS MAINTENANCE MODE IP
    
    $one_octet = preg_match( "/\d{1,3}\./", $_SERVER['REMOTE_ADDR'], $matches_one );
    $two_octets = preg_match( "/\d{1,3}\.\d{1,3}\./", $_SERVER['REMOTE_ADDR'], $matches_two );
    $three_octets = preg_match( "/\d{1,3}\.\d{1,3}\.\d{1,3}\./", $_SERVER['REMOTE_ADDR'], $matches_three );
    
    if ( in_array( $_SERVER['REMOTE_ADDR'], $bps_maintenance_ip ) || in_array( $matches_three[0], $bps_maintenance_ip ) || in_array( $matches_two[0], $bps_maintenance_ip ) || in_array( $matches_one[0], $bps_maintenance_ip )) {
    require( dirname( __FILE__ ) . '/wp-blog-header.php' );
    } else {
    require( dirname( __FILE__ ) . '/bps-maintenance.php' );
    }
    #20538

    Markus
    Participant

    Hi AITpro Admin,

    i have made the steps you told me but it didn’t work. The preview shows me everything just working fine, but it does not. When i checked my root folder I have noticed that the two files your talking about havent been created and the index.php doesn’t show the code you posted.

    best regards,
    Markus

    #20543

    AITpro Admin
    Keymaster

    If the Preview is working correctly and showing your Maintenance Mode page then the BPS Maintenance Mode code is working correctly to create the Maintenance Mode template files.  Since you are not see the files in your website folder and the MMode index.php file code in the index.php file then this means that something on your server is preventing the MMode files from being copied from this folder:  /bulletproof-security/admin/htaccess/ to your website root folder.  Check your php error log and your server log for clues or ask your host to assist you to find out what on your server is preventing the files from being copied to your website root folder.  My guess it is either an open_basedir issue or a folder Owner issue.

    #20544

    Markus
    Participant

    Thank you very much! I will check it out! Is it possible to manually copy the files to the root folder?

    #20547

    AITpro Admin
    Keymaster

    Yes.  You could try that for additional testing, but that would be considered a workaround solution since the files should be copied automatically when clicking the MMode Turn On button.  Also the default WordPress index.php file is backed up first before the MMode index.php file is copied so that when you click the MMode Turn Off button the default WordPress index.php file replaces the BPS MMode index.php file.

    Copy these 3 files:  bps-maintenance.php, bps-maintenance-values.php and maintenance-mode-index.php  from this folder:  /bulletproof-security/admin/htaccess/  to your website root folder.  Rename your default WordPress index.php file to:  index-backup.php.  Rename the maintenance-mode-index.php that you copied to your website root folder to:  index.php.  To take your site out of MMode you will need to rename the BPS MMode index.php file to:  index-mmode.php and the default WordPress index-backup.php file back to index.php.

    #28060

    Lisa
    Participant

    [Topic has been merged into this relevant Topic]

    Hello,

    After having updated the free version of BPS today, the whole site turned automatically on maintenance mode and I couldn’t find a way to log into it anymore afterwards. Eventually I deleted the .htaccess file in the root and in the wp-admin folder, and the maintenance plugin I had installed. I think that’s all I did and I didn’t touch anything else.

    Now I can see the page, and I get 403 & 404 messages. Please urgently help me with this issue. What should I do now?
    Can I uninstal BPS in the server??? Will I be able to access the page afterwards??? I am worried of having broken the page and don’t now how to solve this 🙁 Thanks for you urgent help with this issue.

    #28063

    AITpro Admin
    Keymaster

    @ Lisa – use FTP or your web host control panel file manager and delete the .htaccess file in the wp-admin folder.  this will allow to login and correct whatever settings you need to corrrect in Maintenenace Mode.

Viewing 15 posts - 1 through 15 (of 17 total)

You must be logged in to reply to this topic.