Multisite missing uploaded files images, PDFs, etc

Home Forums BulletProof Security Free Multisite missing uploaded files images, PDFs, etc

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #11803

    Topic was Split into a new Topic:  Additional problem information from original post:

    I got a big problem when we activated BPS. We are on a multi-site WP install with domain mapping.
    the main site worked flawlessly but all other domains and subdomains were missing the uploaded files like images, PDFs etc.


    we are not using Better WordPress Security anymore.. Same with Cachify. But obviously everything is in htaccess
    What do you suggest to do in this case?


    AITpro Admin

    Do you have a DSO Server?  You will find that information on the BPS System Info page.  Post this system info about your website below.

    Server Type:
    Operating System:
    WP Filesystem API Method:
    Server API:

    Website Root URL:
    Document Root Path: /var/www/.../production
    WP ABSPATH: /var/www/.../production/
    Parent Directory: /var/www/xxxxx
    Server / Website IP Address: xxx.xx.123.179
    Host by Address:
    DNS Name Server:
    Public ISP IP / Your Computer IP Address: 23.102.772.36
    Server Type: Apache/2.2.22 (Ubuntu)
    Operating System: Linux
    WP Filesystem API Method: direct
    Server API: apache2handler - Your Host Server is using DSO
    cURL: cURL Extension is Loaded
    Zend Engine Version: 2.3.0
    Zend Guard/Optimizer: A Zend Extension is Not Loaded
    ionCube Loader: ionCube Loader Extension is Not Loaded
    Suhosin: The Suhosin-Patch is installed
    APC: APC Extension is Not Loaded
    eAccelerator: eAccelerator Extension is Not Loaded
    XCache: XCache Extension is Loaded but Not Enabled
    Varnish: Varnish Extension is Not Loaded
    Memcache: Memcache Extension is Not Loaded
    Memcached: Memcached Extension is Not Loaded
    AITpro Admin

    Ok your WP Filesystem API Method is direct so file writing should work without any problems.  Which type of Network / Multisite site do you have?  subdirectory or subdomain?

    Click the activate Root Folder BulletProof Mode button.  If you see any error messages then post those error messages.  If the problem is still occurring then go to the htaccess File Editor tab, click the Your Current Root htaccess File tab and post your root .htaccess file code.



    When we did that the problems (mentioned above links to uploads got lost on all sites except the main network) occured

    We’ll try it again and report back here … (will take some time though since it’s late Friday over here)


    one thing I found permission set to 2775 for wp-content etc, instead of 775, does this matter?

    AITpro Admin

    Either the issue is as simple as the wrong .htaccess file type was used for your Network / Multisite subdomain site…

    …or this could have something to do with the new BPS .htaccess code that will write .htaccess code based on your WordPress version.

    ie first installation of WordPress was WordPress 3.0 through 3.4.2 or WordPress 3.5+…

    …or the other possibility is that there is some sort of issue with Domain mapping itself, but if the old htaccess file you used worked then this indicates that your WordPress installation was pre-3.5 and you are using WordPress 3.0 through 3.4.2 htaccess code successfully.

    AITpro Admin

    Nope, 2775 is pretty much the same thing as 775 permissions so that is not the problem.  Since your WordPress Filesystem API Method is direct then this is not a permissions issue.  It is going to be one of the issues stated above.

    AITpro Admin

    Click the Root Folder BulletProof Mode Deactivate button and let me know if images are displaying correctly and post that root .htaccess file code.

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.