Need Help Isolating "PHP Fatal Error: Out of memory" Issue

Home Forums BulletProof Security Pro Need Help Isolating "PHP Fatal Error: Out of memory" Issue

This topic contains 3 replies, has 2 voices, and was last updated by  AITpro Admin 6 months, 2 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #35181

    Josh
    Participant

    Hi,

    I’ve spent hours trying to figure out what is causing these log entries. When I clear the security log and php error log entries and then rerun the BPS Pro (latest version) pre-installation wizard, the php error log notice pops up and it always contains log entries pertaining to memory issues.

    Example:

    PHP Fatal error: Out of memory (allocated 4194304) (tried to allocate 32768 bytes) in /home/xxxxxxxx/public_html/wp-includes/category-template.php on line 1306
    PHP Fatal error: Out of memory (allocated 8388608) (tried to allocate 8192 bytes) in /home/xxxxxxxx/public_html/wp-content/mu-plugins/bps-pro-mu-tools.php on line 230
    PHP Fatal error: Out of memory (allocated 25165824) (tried to allocate 12288 bytes) in /home/xxxxxxxx/public_html/wp-content/themes/Divi/includes/builder/class-et-builder-element.php on line 9142
    PHP Fatal error: Out of memory (allocated 25165824) (tried to allocate 12288 bytes) in /home/xxxxxxxx/public_html/wp-content/themes/Divi/includes/builder/class-et-builder-element.php on line 9142
    PHP Fatal error: Out of memory (allocated 10485760) (tried to allocate 8192 bytes) in /home/xxxxxxxx/public_html/wp-content/mu-plugins/bps-pro-mu-tools.php on line 230
    PHP Fatal error: Out of memory (allocated 6291456) (tried to allocate 131072 bytes) in /home/xxxxxxxx/public_html/wp-content/plugins/bulletproof-security/includes/firewall-autopilot.php on line 942
    PHP Fatal error: Out of memory (allocated 10485760) (tried to allocate 131072 bytes) in /home/xxxxxxxx/public_html/wp-content/plugins/bulletproof-security/includes/firewall-autopilot.php on line 942
    PHP Fatal error: Out of memory (allocated 6291456) (tried to allocate 131072 bytes) in /home/xxxxxxxx/public_html/wp-content/plugins/bulletproof-security/includes/firewall-autopilot.php on line 942
    PHP Fatal error: Out of memory (allocated 20971520) (tried to allocate 20480 bytes) in /home/xxxxxxxx/public_html/wp-content/themes/Divi/includes/builder/main-structure-elements.php on line 1589
    PHP Fatal error: Out of memory (allocated 6291456) (tried to allocate 32768 bytes) in /home/xxxxxxxx/public_html/wp-content/themes/Divi/functions.php on line 2592
    PHP Fatal error: Out of memory (allocated 8388608) (tried to allocate 131072 bytes) in /home/xxxxxxxx/public_html/wp-content/themes/Divi/epanel/core_functions.php on line 485
    PHP Fatal error: Out of memory (allocated 8388608) (tried to allocate 4096 bytes) in /home/xxxxxxxx/public_html/wp-content/themes/Divi/includes/builder/functions.php on line 7622
    PHP Fatal error: Out of memory (allocated 20971520) (tried to allocate 20480 bytes) in PHP Fatal error: Out of memory (allocated 6291456) (tried to allocate 12288 bytes) in /home/xxxxxxxx/public_html/wp-content/themes/Divi/includes/builder/class-et-builder-element.php on line 9142

     

    I’ve deactivated the only 2 plugins that I use so that only BPS Pro and the latest Divi theme are running. Per Divi support suggestions, I added the following to the root .htaccess file via BPS’s Custom Code > Root htaccess File Custom Code > top box, saved and clicked on “Activate” per the directions:

    php_value memory_limit 256M
    php_value upload_max_filesize 128M
    php_value post_max_size 128M
    php_value max_execution_time 300
    php_value max_input_vars 5000
    
    SubstituteMaxLineLeng
    th 10M

    And I also added the following to my wp-config.php file:

    define('WP_DEBUG', false);
    /* Frontend */
    define( 'WP_MEMORY_LIMIT', '256M' );
    /* Backend */
    define( 'WP_MAX_MEMORY_LIMIT', '256M' );
    /* That's all, stop editing! Happy blogging. */

    According to the local and master values found within my php info file my settings are taking effect and the master values are actually a bit higher than needed.

    I don’t understand what’s going on. But every time I rerun the BPS config wizard I’m able to see the same or similar memory errors every time. I’m not saying this is a BPS issue because it doesn’t appear to be. I just need some suggestions or feedback from someone that can give me a bit of advice on how to fully isolate what the heck is going on.

    The hosting provider says it’s an application issue on my end with WordPress and/or theme plugins. Not to helpful.

    I can create login credentials if need be.

    Thanks for any insights.

    Merry Christmas and Happy New Year,

    Josh

    #35182

    AITpro Admin
    Keymaster

    My best guess would be that there is something going on with your PHP server itself.  Try switching to another PHP server version first.  If your web host uses PHP handler htaccess code then add that PHP handler code to BPS Custom Code in this Custom Code text box:  1. CUSTOM CODE TOP PHP/PHP.INI HANDLER/CACHE CODE.  If your host server does not require PHP handler htaccess code then most likely you can just switch your PHP server version in your web host control panel.  I can’t be more specific because there are so many unique/different web host configs/settings/etc.

    #35195

    Josh
    Participant

    Resolved!!!! Thanks.

    My Cpanel has a “PHP Versions” switcher that allows access to not only the php version, but the extensions some values that are editable. Very nice.

    Switching from PHP 7.0.26 to 7.2 eventually did the trick. All sites now run 7.2. Seem faster and more responsive. But now I’m getting some weird entries in the BPS Pro security log 403’s that comes from my ip address about the BPS ajax.js file when I login.

    I’ll open another ticket about that.

    Hope after the fire you had an enjoyable Christmas and NewYears and everything is ok.

    Josh

     

    #35198

    AITpro Admin
    Keymaster

    Great!  Glad to hear that did the trick.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.