white screen of death in backend

Home Forums BulletProof Security Pro white screen of death in backend

This topic contains 10 replies, has 2 voices, and was last updated by  AITpro Admin 1 year, 9 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #31044

    Haiko Nieuwoudt
    Participant

    Good day.

    I am having trouble on multiple sites updating to the new version of BPS Pro, and I think I have determined that it is a database issue.

    On one website, when I updated to the new version, I received a 500 internal server error. To fix this I deleted the .htaccess files in both the root and wp-content directories. So that problem got resolved.

    But on another site I tried to update, the website broke entirely, resulting in a white screen of death in the backend and messed-up content on the frontend. Deleting the .htaccess files didn’t help, nor did renaming the plugins directory. I tried reverting to a files backup of the day before to no avail, so then I tried to revert to a backup of the database, which ended up working. So the update broke the site’s database.

    Is there any way to install the update without this happening? Please help.

    #31045

    AITpro Admin
    Keymaster

    BPS Pro 12.4 did not automatically do anything with the database like updating plugin options.  The focus of BPS Pro 12.4 was primarily to make BPS Pro Mobile friendly.  So what was changed was BPS Pro plugin files code/framework and the CSS stylesheets had CSS3 Media Queries created.  Other than that there were some minor bugfixes and a new option was added for ISL. How did you update BPS Pro?  Did you update BPS Pro on the Plugins page by clicking the update now link? Did you see any error messages or receive any email alerts?

    #31046

    Haiko Nieuwoudt
    Participant

    Yes, I updated via the Plugins page with the update now link. I tried it twice after restoring just to make sure it was BPS Pro, the second time trying the manual install method (downloading and uploading the zipped files). There were no errors or alerts, the dashboard just went blank and the website frontend displayed horribly. Thanks for the help!

    #31047

    AITpro Admin
    Keymaster

    You should only install BPS Pro using either the WordPress Plugin Upload zip installer or the BPS Pro built-in Upload zip installer. Uploading BPS Pro plugin files via FTP will most likely trigger the BPS Pro anti-piracy/anti-tamper protection.  1 other person also stated this problem occurred.  The only things that I can think of that could cause the problem would be some sort of plugin or theme API server conflict or maybe some server configuration issue or server security measure issue. So it has to be something specific to this particular site since so far only 2 people total have reported this type of problem.  What worked for the other person that ran into this type of problem was these steps below.  If you would like for us to investigate further then create a duplicate test site of your Live site and send a WordPress Administrator login to the site and and FTP login to the site so we can figure out the root cause of the problem.  If you would like to do this then send the login info to:  info at ait-pro dot com.

    1. Delete the /bulletproof-security/ plugin folder.
    2. Deactivate all other plugins.
    3. Reinstall BPS Pro using the WordPress Plugin upload zip installer.
    4. Reactivate all other plugins.

    #31048

    Haiko Nieuwoudt
    Participant

    Thanks, I have followed those steps but now when I try to activate the plugin, I get this error:

    Plugin could not be activated because it triggered a fatal error.
    Warning: require_once(/usr/www/users/hazennbbbv/wp-content/plugins/bulletproof-security/includes/class.php): failed to open stream: No such file or directory in /usr/www/users/hazennbbbv/wp-content/plugins/bulletproof-security-new/bulletproof-security.php on line 79 
    
    Fatal error: require_once(): Failed opening required '/usr/www/users/hazennbbbv/wp-content/plugins/bulletproof-security/includes/class.php' (include_path='.:/usr/share/php:/usr/share/pear') in /usr/www/users/hazennbbbv/wp-content/plugins/bulletproof-security-new/bulletproof-security.php on line 79
    #31049

    Haiko Nieuwoudt
    Participant

    Nevermind, I figured out it’s because I renamed the zip! D’oh!

    Thanks for the help, it seems to have worked. 🙂

    #31050

    AITpro Admin
    Keymaster

    Ok great.  That pretty much confirms that some other plugin is the root cause of the problem, which is then interfering with/breaking the BPS Pro upgrade and causing the whitescreen of death.  Go to the BPS System Info page, click the Get Plugins List button and post all your plugins that you have installed. We test/check all the plugins you have installed on one our testing sites.  Another possibility could be that you are close to your maximum php memory limit.  Post the System Info memory usage and limits for this site:  PHP Memory Usage and PHP Actual Configuration Memory Limit.

    #31051

    Haiko Nieuwoudt
    Participant

    Plugins:

    Bootstrap Shortcodes 3.4.0 – Activated: bootstrap-shortcodes/bootstrap-shortcodes.php
    BulletProof Security Pro 12.4 – Activated: bulletproof-security/bulletproof-security.php
    Contact Form 7 4.5.1 – Activated: contact-form-7/wp-contact-form-7.php
    Custom Facebook Feed 2.4.5 – Activated: custom-facebook-feed/custom-facebook-feed.php
    Custom Twitter Feeds 1.1.8 – Activated: custom-twitter-feeds/custom-twitter-feed.php
    Instagram Feed 1.4.8 – Activated: instagram-feed/instagram-feed.php
    Lockdown WP Admin 2.3.2 – Activated: lockdown-wp-admin/lockdown-wp-admin.php
    Photo Gallery 2.2.52 – Activated: photo-gallery/photo-gallery.php
    Revolution Slider 4.6.92 – Activated: revslider/revslider.php
    WPBakery Visual Composer 4.12.1 – Activated: js_composer/js_composer.php

    PHP info:

    PHP Memory Usage: 28.45 MB
    PHP Actual Configuration Memory Limit: 64M Recommendation: Increase Memory Limit to 128M.

    If it helps at all, the plugins I use on both sites I had an issue are Contact Form 7 and Lockdown WP Admin.

    #31052

    AITpro Admin
    Keymaster

    Ok your php memory looks fine.  So my guess would be the Lockdown WP Admin plugin is where the problem is occurring.  There are definitely not any issues/problems between Contact Form 7 and BPS Pro.  The Lockdown WP Admin plugin will be installed and tested tomorrow morning and I’ll post the results of my testing.

    #31053

    AITpro Admin
    Keymaster

    The Lockdown WP Admin plugin has been tested while doing a BPS Pro upgrade and no problems were found.  The BPS Pro upgrade completed successfully.  I will install and test some of the other likely plugins that you posted above.  Since the BPS Pro upgrade uses an API connection to our API server to install the BPS Pro upgrade then logically one of your other plugins would also be doing some sort of API connection thing that is conflicting with our API connection.  Or it could be something completely unobvious. 😉

    #31054

    AITpro Admin
    Keymaster

    hmm I checked the Lockdown WP Admin plugin Support and Review pages and came across this:  https://wordpress.org/support/topic/ruined-my-db/  So it is possible that the Lockdown WP Admin plugin did cause some sort of DB problem.  You may have a different DB Type then I have on my test site and the other factor is this plugin handles things differently for cli|DSO server types.  You can do these steps below to confirm or eliminate that the Lockdown WP Admin plugin is the root cause of the problem.

    1. Edit this BPS Pro file:  /bulletproof-security/bulletproof-security.php and at the top of the file change this:  Version: 12.4 to this:  Version: 12.3.  This will force another BPS Pro update check and you should see a new BPS Pro upgrade notification on the Plugins page.  You may need to reclick the Plugins page link several times before you see the BPS Pro upgrade notification displayed.
    2. Deactivate all of your plugins except for BPS Pro and Lockdown WP Admin.
    3. Install the BPS Pro upgrade by clicking the update now link.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.