OptinLinks – PHP Error Log Path Does Not Match

Home Forums BulletProof Security Pro OptinLinks – PHP Error Log Path Does Not Match

This topic contains 11 replies, has 2 voices, and was last updated by  AITpro Admin 3 months, 3 weeks ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #20998

    AITpro Admin
    Keymaster

    OptinLinks overrides the BPS Pro php error log path.  Error Log Path Seen by Server: /home/xxxxx/public_html/wp-content/plugins/opt/opt_errors.log

    Instead of fighting the OptinLink plugin for control of a php error log file you can use the OptinLink opt_errors.log php error log file instead of the BPS Pro php error log file:  /home/xxxxx/public_html/wp-content/bps-backup/logs/bps_php_error.log.  Change the PHP Error Log Location Set To: path to the OptinLink php error log path: /home/xxxxx/public_html/wp-content/plugins/opt/opt_errors.log or you can edit your custom php.ini file and change the error_log directive path to:  error_log = /home/xxxxx/public_html/wp-content/bps-backup/logs/bps_php_error.log if you want to override the OptinLink plugin’s php error log path|file and use the BPS Pro php error log path|file instead.

    #35329

    Rafael Da Costa
    Participant

    I am getting this error and I can see the file path at the wp-config.php does not match the current path.

    I’ve tried to edit it but I Could not write on the file because Operation not permitted.

    How do i fix it?

    Thanks

    #35330

    AITpro Admin
    Keymaster

    Go to P-Security > ini_set Options > ini_set PHP Error Log Location Set To > enter the path to your OptinLink plugin PHP error log file > click the Save|Enable Options button.  If you are still seeing an error message then go to the PHP Error Log page > Copy the Error Log Path Seen by Server error log file path > paste the error log file path into the PHP Error Log Location Set To text box > click the Set Error Log Location button.

    #35331

    Rafael Da Costa
    Participant

    Thanks for your prompt reply.

    I have set the “ini_set PHP Error Log Location Set To:” at the “ini_set Options” (it was not set).

    But the “Error Log Path Seen by Server”  does not exist anymore because the folder name changed when I moved servers.So I can’t follow your second instruction (“If you are still seeing”). But if I follow, it gives me a error:

    “PHP Error Log File Not Found! Either the PHP Error Log Folder Location has not been set yet or the PHP Error Log Folder Location path that you set is incorrect. Click the Htaccess Protected Secure PHP Error Log Read Me Help button for more info.”

    So I need to change the name of the “Error Log Path Seen by Server:

    I have also run the “setup wizard” couple times and it did not fix the issue.

    Thanks

    #35332

    AITpro Admin
    Keymaster

    Do you have the OptinLink plugin installed or are you just seeing this error message > PHP Error Log Path Does Not Match?  What do you see for this recommended BPS PHP error log path > ini_set PHP Error Log Location (Recommended)  ?.  What do you see for this PHP error log path > Error Log Path Seen by Server ?

    #35346

    Rafael Da Costa
    Participant

    I don’t have OptinLink plugin installed, I’m just seeing “PHP Error Log Path Does Not Match”.

    There is an extra WWW on Path Seen by Server. This is the details in my server:

    • ini_set PHP Error Log Location (Recommended): /home/MYFOLDER/MYDOMAIN.com/wp-content/bps-backup/logs/bps_php_error.log
    • PHP Error Log Location Set To: /home/MYFOLDER/MYDOMAIN.com/wp-content/bps-backup/logs/bps_php_error.log
    • Error Log Path Seen by Server: /home/MYFOLDER/www.MYDOMAIN.com/wp-content/bps-backup/logs/bps_php_error.log

    What should we do?

    Thanks

    #35347

    AITpro Admin
    Keymaster

    Do these steps:

    1. Go to P-Security > ini_set Options > ini_set PHP Error Log Location Set To text box option setting.
    2. Enter/copy the BPS “ini_set PHP Error Log Location (Recommended)” path.
    3. Click the Save|Enable Options button.
    4. If you are still seeing an error message then go to the PHP Error Log page > Copy the Error Log Path Seen by Server error log file path > paste the error log file path into the PHP Error Log Location Set To text box > click the Set Error Log Location button.

    #35362

    Rafael Da Costa
    Participant

    Hi there,

    Step 1-3 did not work.

    I have done step 4, the error “PHP Error Log Path Does Not Match” have gone disappeared but a new error have came up: “A PHP Error has been logged in your PHP Error Log”

    The path seen by the SERVER has an extra WWW:

    • ini_set PHP Error Log Location (Recommended): /home/MYFOLDER/MYDOMAIN.com/wp-content/bps-backup/logs/bps_php_error.log
    • PHP Error Log Location Set To: /home/MYFOLDER/MYDOMAIN.com/wp-content/bps-backup/logs/bps_php_error.log
    • Error Log Path Seen by Server: /home/MYFOLDER/www.MYDOMAIN.com/wp-content/bps-backup/logs/bps_php_error.log
    #35363

    AITpro Admin
    Keymaster

    I’m guessing that you have accidentally added “www” to your php error log path in your custom php.ini file.  Go to P-Security > PHP.ini Options > click the Diagnostic Checks|Recommendations > Run Check button.  What php.ini path do you see for:  Loaded Configuration File: ?  If the Loaded Configuration File is your custom php.ini file path then open and edit your custom php.ini file and correct the path to your php error log file by removing/deleting “www” from the path.

    #35390

    Rafael Da Costa
    Participant

    Thanks for your help.The file name changed due to server migration.

    Loaded Configuration File: /opt/alt/php70/etc/php.ini

    I cannot find this file and I can find any php.ini file in the search.

    Thanks in advance

    #35393

    AITpro Admin
    Keymaster

    Ok at this point send me a WordPress Administrator login to this website so I can see if this problem can be fixed from your website.  It may be that you will need to contact your web host support to have them fix something on the server.  Send the WP Admin login to:  info at ait-pro dot com.

    #35414

    AITpro Admin
    Keymaster

    I received your login info today, logged in and found the problem.  See troubleshooting and solution notes below>

    Problem: The wp-config.php file is not editable. I checked the file permissions are it is 644, which is correct, but something else is
    causing the wp-config.php from being editable. I checked the Script Owner and File Owner for the wp-config.php file on the BPS System Info page and they are the same so that is not the cause of the problem. /wp-config.php 400 0644 1125 1125
    My guess is that either Mod Security or some other host server security measure is protecting the wp-config.php file somehow. What is interesting and puzzling is that when you originally ran the Setup Wizard the path below was written to the wp-config.php file.

    @ini_set('error_log','/home/xxxxx/www.tkado.com.au/wp-content/bps-backup/logs/bps_php_error.log'); // add the path to your php error log

    When trying to view and edit the wp-config.php file with the P-Security File Editor I see this error below.

    Error: The /home/xxxxx/tkado.com.au/wp-config.php file is NOT writable.
    Your editing changes to this file will NOT be saved. Check the file permissions and path for this file.

    Solution: You will need to use FTP or your web host control panel file manager and manually edit your wp-config.php file and change this php error log file path to: /home/xxxxx/tkado.com.au/wp-content/bps-backup/logs/bps_php_error.log

    Note: BPS Pro additional procedural check for if file is writable is needed. Currently the checking condition only checks file permissions.

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.