Option to Stop AutoRestore from Automatically Turning Back on

Home Forums BulletProof Security Pro Option to Stop AutoRestore from Automatically Turning Back on

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #11377

    Hello, I was wondering if there was a way to tell AutoRestore to not automatically turn back on after a plugin or WordPress update? I ask because for some reason, my site has been hanging after a plugin upgrade and I would simply prefer to turn it back on myself manually.

    To explain in detail:

    1. AutoRestore is currently off

    2. If there is a plugin update available on the Dashboard, I can click on Update Now, the plugin installs and AutoRestore provides the link asking if this was a plugin upgrade.

    3. The link is clicked, AutoRestore turns back on.

    Here is the issue for whatever odd reason, when I go to the AutoRestore tab to manually turn back off the AutoRestore option and click “Submit”, the pop up window comes up but that page just sits there idle. I either have to kill the page or if I wait long enough, I get an alert from my website monitor saying that my site is down and then I just restart my server.

    So instead of doing either of these two things, I wanted to know if I could just tell the AutoRestore feature to not turn itself back on after a plugin or WordPress upgrade. Typically I just upload my plugin upgrades through FTP but in the odd case that I use the Dashboard, I would like to avoid the other issues which come up.

    AITpro Admin

    Personally I do not do plugin updates on the WordPress Updates page and use each plugin’s update now link on the WordPress Plugins page when a plugin update is available.  I only do WordPress new version updates/upgrades and Theme updates/upgrades on the WordPress Updates page.  And would NEVER update/install more than 1 plugin at a time.  I’m old school Microsoft tech based and have it drilled into me NEVER to install more than 1 application at a time.

    If you update/upgrade plugins on the WordPress Updates page this will trigger AutoRestore to shutdown, backup files and turn itself back on.  This is the new intended functionality for AutoRestore Automation.  So if you do not want AutoRestore to do these things automatically you can do plugin updates/upgrades using each plugin’s update now link on the WordPress Plugins page instead of updating plugins on the WordPress Updates page.

    The real issue/problem is what is causing the hang on the AutoRestore page when trying to turn ARQ off.

    We will add an additional option for AutoRestore in BPS Pro 8.0 that you can set/select to tell AutoRestore not to automatically turn itself back on.


    Cool, thanks and agreed with your comments.

    True, I would need to sit down and figure out what is causing the site to hang but sometimes there aren’t enough hours in the day to tackle all these issues.

    AITpro Admin

    These are some possible issues that could cause the hang in AutoRestore:

    PHP Configuration memory limit is set too low – should be set to a minimum of 128M

    Excessive files being monitored by AutoRestore – ARQ performance starts degrading after 5,000 files being checked total.  ARQ has been tested up to 15,000 files being checked – ARQ performance is very sluggish if ARQ is monitoring 15,000+ files.

    Another plugin or theme is loading its js scripts on BPS Pro pages including AutoRestore, which causes a range of problems:  hanging, menus breaking and complete loss of functionality – unfortunately this is a very common problem – some plugin and theme authors do not contain their js scripts to load only in areas of the website where they should be loading and instead load their scripts everywhere – all WordPress wp-admin backend Admin pages, all other plugin settings pages, everywhere.

    Host Server configuration issues – open_basedir is in use (open_basedir is a menace and useless), mod_security restrictions – excessively restrictive SecRules/SecFilters are interfering with normal WordPress functionality in plugins and themes.


    Hi, just seeing your latest response, thanks for the suggestions. I probably missed the email when it came in.

    Thanks again for implementing the override option to ARQ. Just got around to testing it today and it worked perfectly. I doubt I will find the time to diagnose the issue, so it is great to have the alternative until I can free up some time.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.