Oxygen Plugin – BPS Maintenance Mode not working

Home Forums BulletProof Security Pro Oxygen Plugin – BPS Maintenance Mode not working

This topic contains 1 reply, has 1 voice, and was last updated by  AITpro Admin 5 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #33288

    AITpro Admin
    Keymaster

    Problem Reference: https://wordpress.org/support/topic/maintenance-mode-not-able-to-access-front-end/

    Problem Description: The Maintenance Mode page is being displayed to the site owner instead of the site displaying normally for the site owner.  The site ownere has correctly entered his/her IP address in the BPS MMode Maintenance Mode IP Address Whitelist Text Box option and should be seeing his/her website displayed normally.

    Problem Cause: This is not verified yet, but the Oxygen Plugin appears to alter/modify the default WordPress index.php file, which BPS MMode also does.  The cause of the problem could be something else entirely.  Pending additional investigation.

    Solution|Workaround:  Deactivate the Oxygen plugin, save BPS MMode options settings, Turn MMode On and then activate the Oxygen plugin.  Note:  If a problem occurs when turning MMode Off then logically these steps would fix that problem:  Turn MMode Off, deactivate and reactivate the Oxygen plugin.

    Update 6-5-2017:
    We can add a check for this issue and display a message to folks for this issue on the BPS MMode page in the next BPS plugin version. What I need from you in order to create that check is the name of the Oxygen plugin’s initialization plugin filename. You can get that info by going to the BPS System Info page > click the Get Plugins List button > post this path info: Oxygen version # – Activated: path to plugin folder/path to plugin filename.php

    The message that would be displayed in this check would be something like: “You have the Oxygen plugin installed, which prevents BPS MMode from being successfully turned On while the Oxygen plugin is activated. Please temporarily deactivate the Oxygen plugin, save your MMode settings, turn On MMode and activate your Oxygen plugin again.”

    #35174

    AITpro Admin
    Keymaster

    New Info courtesy of imtino:  https://wordpress.org/support/topic/maintenance-mode-and-oxygen/

    I wanted to update you but the thread was closed. Anyways, it’s working fine with Oxygen now. I don’t know exactly what happened. But there was a few things that I did with my server for the past months.

    1. I now running Apache only because I was having issues with cache not cache properly.
    2. Updated to latest Curl.
    3. Updated cacert.pem getting from https://curl.haxx.se/docs/caextract.html

    Those are the 3 major things I did. Everything was working great on my server so I decided to give BPS Maintenance Mode a try again. And it’s working fine.

    I prefer BPS Maintenance Mode than having to add another plugin. And it’s a simple.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.