DSO Apache Module – default.htaccess is not writable, secure.htaccess is not writable

Home Forums BulletProof Security Free DSO Apache Module – default.htaccess is not writable, secure.htaccess is not writable

This topic contains 1 reply, has 2 voices, and was last updated by  AITpro Admin 6 years, 8 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #1658

    Peter
    Member

    Hi,
    your plugin sounds really good, but after installing the plugin (version 47.8), nothing works as it should …
    I get all the warnings and try to activate the security modes but even the creation of the .htaccess files fails.
    The file /www/xxx/yyy/zzz/wp-content/plugins/bulletproof-security/admin/htaccess/default.htaccess is not writable or does not exist.
    The file /www/xxx/yyy/zzz/wp-content/plugins/bulletproof-security/admin/htaccess/secure.htaccess is not writable or does not exist.
    All the files exist and have 644 access-rights.I am using WP 3.5.1 (de) on an Apache server with PHP5.Since its just a webhoster, I have no configuration access to the server. Here is some stuff from your “system info” page. I skipped anything that points back to my site/hoster

    Server Type: Apache
    Operating System: Linux
    Server API: apache2handler – Your Host Server is using DSO or another SAPI type.
    cURL: cURL Extension is Loaded
    Zend Engine Version: 2.3.0
    Zend Guard/Optimizer: Zend Guard Loader Extension is Loaded
    ionCube Loader: ionCube Loader Extension is Loaded Version: 40202
    Suhosin: The Suhosin-Patch is installed
    APC: APC Extension is Not Loaded
    eAccelerator: eAccelerator Extension is Not Loaded
    XCache: XCache Extension is Loaded but Not Enabled
    Varnish: Varnish Extension is Not Loaded
    Memcache: Memcache Extension is Not Loaded
    Memcached: Memcached Extension is Not Loaded

    PHP Version: 5.3.18-nmm1
    Permalinks Enabled: v Permalinks are Enabled
    PHP Version Check: v Using PHP5

    I hope you can help, I would love to use your plugin, but unfortunately I am no real admin tech guy.So either it works out of the box for me or with limited troubleshooting or I have to skip it.
    Thanks!

    #1665

    AITpro Admin
    Keymaster

    DSO Server types/configurations require additional BPS setup steps since DSO / Apache Module Server configurations are problematic for BPS, BPS Pro, all other WordPress plugins that have file write capability and of course WordPress itself.  This has been a known issue about DSO / Apache Module Server configurations / types for at least 10 years now.

    In order to setup BPS up on a DSO Server type you will need to do these additional setup steps.

    http://forum.ait-pro.com/forums/topic/dso-setup-steps-bulletproof-security-free/

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.