Pre-installation wizard – Resource Limit Is Reached error message

Home Forums BulletProof Security Pro Pre-installation wizard – Resource Limit Is Reached error message

  • This topic has 5 replies, 2 voices, and was last updated 1 year ago by avery.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #39297
    avery
    Participant

    Hello, I just tried installing BPS Pro onto a new website. When running the Pre-Installation Wizard, it just hangs with a blank page, even when turning the cURL option off as suggested in the Readme.

    Also after the hang, when trying to access my website it displays an error:

    Resource Limit Is Reached
    The website is temporarily unable to service your request as it exceeded resource limit. Please try again later.

    After a few minutes, the website can then be accessed again. I’m not overly technical so any help or pointers in the right direction would be appreciated, thank you.

    #39298
    AITpro Admin
    Keymaster

    Deactivate all of your other Plugins so you can successfully run the BPS Pro Pre-Installation and Setup Wizard.

    Next do a Google search for this search term:  resource limit is reached The website is temporarily unable to service your request as it exceeded resource limit. Please try again later.

    That will give you idea of possible causes for the resource limit is reached error message.

    There are several possible causes for this error. So before even attempting to offer some ideas, you need to be on the same page and understand the possible causes for this error.

    #39301
    AITpro Admin
    Keymaster

    After you have a general understanding of what that error means then I will try to figure out why it is occurring. How many plugins do you have installed?  How much PHP memory do you have (you can find that on the BPS System Info page)?

    #39303
    avery
    Participant

    Thank you for the information. 12 Plugins were installed and the PHP Memory usage:

    PHP Memory Usage: 60.93 MB
    WordPress Admin Memory Limit: 256M
    WordPress Base Memory Limit: 40M
    PHP Actual Configuration Memory Limit: The Memory Limit value is not available from your Server.

    I deactivated all of the other plugins and the Pre-Installation Wizard ran without any errors.

    The Setup Wizard also seemed to run successfully, there were only 2 lines in blue so not sure if this is a concern:

    • Unable to get the PHP Configuration Memory Limit value from the Server. The ini_set Options memory limit setting will be set to 128M automatically by the Setup Wizard to prevent problems or errors with the BPS Pro Setup.
    • Your current Root .htaccess file is not locked. In order to ensure that the Setup Wizard completes successfully your files will NOT be locked by BPS Pro F-Lock. Your F-Lock settings will be set to “Checking & Alerts Off”.

    I am also getting the following error:
    PHP Error Log Path Does Not Match
    The PHP Error Log Location Set To: folder path does not match the Error Log Path Seen by Server: folder path.

    From looking at the same topic on the forum, this is the following information that is hopefully helpful

    In the PHP Error Log section:
    ini_set PHP Error Log Location (Recommended): /home/xxxxx/public_html/wp-content/bps-backup/logs/bps_php_error.log
    PHP Error Log Location Set To: /home/xxxxx/public_html/wp-content/bps-backup/logs/bps_php_error.log
    Error Log Path Seen by Server: error_log

    In the ini_set Option section:

    ini_set PHP Error Log Location Set To: /home/xxxxx/public_html/wp-content/bps-backup/logs/bps_php_error.log

    Running the Diagnostic Checks gives:
    PHP Version: 7.0.33
    PHP|php.ini Handler: A PHP|php.ini Handler was Not found in your Root .htaccess file.

    Configuration File (php.ini) Path: Click the View PHPINFO button on the PHP Info Viewer page to get this path.
    Loaded Configuration File: /opt/alt/php70/etc/php.ini

    php.ini, php5.ini & .user.ini File Search Results: (Displays the file paths below if files were found)

    disable_functions: The ini_set function is Not Disabled

    wp-config.php File: The wp-config.php file was found in the website root folder.

    Error Log Path Seen by Server: error_log
    PHP Error Log Location Set To: /home/xxxxx/public_html/wp-content/bps-backup/logs/bps_php_error.log
    ini_set PHP Error Log Location Set To: /home/xxxxx/public_html/wp-content/bps-backup/logs/bps_php_error.log

    Any additional help would be appreciated, thank you.

    #39308
    AITpro Admin
    Keymaster

    The PHP Configuration Memory Limit value check in blue font is just a general check that you can ignore.

    I recommend that you lock your Root htaccess file. To do that do the steps below.

    Go to the BPS Pro > B-Core > htaccess File Editor tab page.
    Click the Lock htaccess File button and the Turn On AutoLock button.

    Your host server uses a default php error log value of: error_log and does not allow using the BPS PHP error log. To fix the PHP Error Log Path Does Not Match error message do the steps below.

    Go to the BPS Pro > P-Security > PHP Error Log tab page.
    Copy your server’s default php error log value: error_log.
    Paste it into the PHP Error Log Location Set To text box.
    Click the Set Error Location button.

    #39309
    avery
    Participant

    Thank you very much for the additional steps and everything appears to be working correctly now, much appreciated.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.