Pre-Installation Wizard error – Uncaught UnexpectedValueException: RecursiveDirectoryIterator

Home Forums BulletProof Security Pro Pre-Installation Wizard error – Uncaught UnexpectedValueException: RecursiveDirectoryIterator

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #36536
    alan sills

    I ran into this while running the pre-install wizard – What do I do? I already read the “read me” and disabled the cURL option.

    All other findings were green except for a blue note stating root .htaccess file is not locked….

    AutoRestore|Quarantine Exclude Rules

    Fatal error: Uncaught UnexpectedValueException: RecursiveDirectoryIterator::__construct(/home/rvacro5/public_html/wp-content/updraft): 
    failed to open dir: Permission denied in /home/rvacro5/public_html/wp-content/plugins/bulletproof-security/admin/wizard/pwizard-functions.php:886 
    Stack trace: #0 [internal function]: RecursiveDirectoryIterator->__construct(‘/home/rvacro5/p…’, 0) 
    #1 [internal function]: RecursiveDirectoryIterator->getChildren() 
    #2 /home/rvacro5/public_html/wp-content/plugins/bulletproof-security/admin/wizard/pwizard-functions.php(886): RecursiveFilterIterator->getChildren() 
    #3 /home/rvacro5/public_html/wp-content/plugins/bulletproof-security/admin/wizard/wizard.php(755): bpsSetupWizardARQExcludeDB() 
    #4 /home/rvacro5/public_html/wp-content/plugins/bulletproof-security/admin/wizard/wizard.php(2406): bpsSetupWizardPrechecks() 
    #5 /home/rvacro5/public_html/wp-admin/admin.php(253): include(‘/home/rvacro5/p…’) 
    #6 {main} thrown in /home/rvacro5/public_html/wp-content/plugins/bulletproof-security/admin/wizard/pwizard-functions.php on line 886
    AITpro Admin

    Does this Updraft folder exist: /wp-content/updraft/? If the Updraft folder exists are the permissions and/or folder Ownership correct for the /updraft/ folder? If the Updraft folder does not actually exist then go to AutoRestore > Exclude wp-content Folders tab page > delete the updraft folder from whichever slot it is in > click the Save Folder Exclude Rules button.

    alan sills

    The updraft folder does exist (I see it in ftp filezilla), but when I click on it, I get the following error in filezilla: Response: 550 Can’t change directory to updraft: Permission denied
    Error: Failed to retrieve directory listing

    The folder will not open. It looks like it has not been updated since April, can I delete it? Or… if I go to “file permissions” in filezilla, what do I do? It appears that the owner (me?) has full permissions to read/write/execute.


    alan sills

    problem solved – i contacted my hosting company – they unlocked the folder and i deleted it

    AITpro Admin

    Great! Glad you got it figured out.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.