Pre-Install Wizard Not found blog notice

Home Forums BulletProof Security Pro Pre-Install Wizard Not found blog notice

This topic contains 8 replies, has 2 voices, and was last updated by  AITpro Admin 4 years, 6 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #11555

    Leo A. Geis
    Participant

    Greetings from Boise!

    DreamHolst (CPanel), 4 websites with the Cufon Theme, all 4 are pretty much identical:
    http://www.idahoairships.com
    http://www.persuasion-interactive.net
    http://www.redlens.net
    http://www.forensicallyfit.net

    Problem: Free installed flawlessly on all 4 last week. Thing of beauty.

    Bought Pro this morning, install went swimmingly. However, on all 4 the first run of Pre-Installation Wizard gave me a “Nothing found for Wp-Admin Admin Php?page = Bulletproof-Security Admin Wizard Wizard Php http://www.idahoairships.com/wp-admin/admin.php?page=bulletproof-security/admin/wizard/wizard.php”

    3 sites would work fine and show me a successful Pre-Install if I refreshed the browser or ran the Pre-Install Wizard again. Then I ran the Setup Wizard, and 3 sites showed success as well. Yay. 1 site will not cooperate: http://www.idahoairships.com. I cannot get it to do anything in the Pre-Install Wizard except show me a  “Not found” blog notice (presuming this is a server-side problem…not sure why it’s not giving me a number). It is the only site showing me a banner, “BPS Pro Alert! Your site does not appear to be protected…” I am an ECMAScript guy and can’t even spell htaccess, so please be gentle with me…

    Thanks in Advance-
    Leo

    #11557

    AITpro Admin
    Keymaster

    I do not fully understand the issue/problem on the 1 site.  Try uninstalling BPS Pro and reinstalling BPS Pro on that site and re-run the Pre-Installation Wizard.

    #11558

    Leo A. Geis
    Participant

    Thanks for the quick response! Wow!

    1. Uninstalled, waited a few minutes, refreshed browser, reinstalled.
    2. Clicked on Pre-Installation Wizard, got:

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster @ idahoairships.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    More information about this error may be available in the server error log.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    3. Refreshed browser, got the same. The URL was: http://www.idahoairships.com/wp-admin/admin.php?page=bulletproof-security/admin/wizard/wizard.php
    4. Clicked the “Back” Arrow and was immediately presented the Setup Wizard Page.
    5. Clicked Pre-Installation Wizard button again. “Internal Server Error” as above.
    6. Sat on my hands for 2 minutes, clicked Pre-Installation Wizard button again: success!
    7. Clicked Run Setup Wizard Button. Chugged for 90 seconds, “Internal Server Error.” Hit Back arrow twice (past the “webpage has expired” notice)
    8. Waited 2 minutes. Clicked Run Setup Wizard Button. Was warned that I must run the Preinstallation Wizard…so I did. Success!
    9. Waited 2 minutes. Clicked Run Setup Wizard Button. Daydreamed about sacrificing 1 of my 3 teens to see if that would help, or just make a mess on my desk.
    10. Chugged for about 90 seconds. Success!

    I bore you with this just because it’s behaving like a timeout would in my world and may be of some interest? I have my account with DreamHost and self-host the blogs, WP 3.7.1, have JetPack, All In One SEO, and Kimili Flash Embed (I think your head will asplode knowing that?) plugins installed and activated.

    I’m sure I’ll be back: PHP errors are being logged and the Kimili Flash Embed needs to be whitelisted, but at least I’m installed. Thanks much!

    Leo

    #11559

    AITpro Admin
    Keymaster

    hmm ok it sounds like you are maxing out on memory limit or resources or maybe a caching plugin is interfering with things.  Your minimum PHP Actual Configuration Memory Limit setting should be 128M for things to run smoothly.  64M works if you are only using a small number of plugins, but 128M is still the optimum minimum memory limit you should be using.  WordPress needs 32M – 40M of the PHP memory limit by itself.

    Go the BPS Pro System Info menu page and copy and paste this info about this site:

    PHP Memory Usage:
    WordPress Admin Memory Limit:
    WordPress Base Memory Limit:
    PHP Actual Configuration Memory Limit:

    #11567

    Leo A. Geis
    Participant

    Ah, yes.

    • PHP Memory Usage: 43.2 MB
    • WordPress Admin Memory Limit: 256M
    • WordPress Base Memory Limit: 40M
    • PHP Actual Configuration Memory Limit: 90M

    So, I changed config to

    @ini_set(‘memory_limit’,’256M’);

    Will do so for all 4 sites if you instruct. I chose 256M instead of 128M because more is better, right? Ha!

    #11569

    AITpro Admin
    Keymaster

    Yes, 256M would be better than 128M, but the actual maximum memory limit is determined by whatever the Server has allocated as the maximum memory limit.  For example let’s say your Server has a maxium allowed memory limit setting of 128M and you use 256M with the ini_set function.  You will see 256M as the memory_limit value locally, but the actual Server memory limit setting will be 128M.  The Server will not let you go above the maximum memory limit allowed in the Server’s configuration file.

    #11575

    Leo A. Geis
    Participant

    I deactivated BPS on all four sites, changed the permissions so I could rewrite the wp-config.php’s, changed ’em to 256, and reactivated BPS. Then I FTP’d each of the 4 .php’s down and checked them…it stuck! Also waited for a quarantine notice, and got none. Unfortunately-for all 4-BPS System Info is still showing an Actual Configuration Memory Limit of 90MEG. A visit to DreamHost’s Wiki gives this data (adding it for search reasons for other DreamHost folk):

    http://wiki.dreamhost.com/PHP.ini#Increasing_the_PHP_Memory_Limit (Talking about v5.2)

    “The default memory limit is 90M and this is usually more than sufficient for most needs.
    If you wish to increase this limit, you’ll want to use the following: memory_limit = 128M”

    Unfortunately, they’re not talking about the wp-admin.php file, they’re talking about the php.ini file, and that scares me to death.
    As of 12/1/13 DreamHost is running v5.3.13.
    However, this page http://phpinfo.dreamhosters.com/phpinfo.php shows a memory_limit parameter of 90M for both local value and master value. I don’t know what this all means, but there it is for searchers…I think I’ll send in a support ticket to see if they’ll bump my .php memory resources?…

    #11584

    Leo A. Geis
    Participant

    OK, here’ s the .php v.5.3 and 5.4 memory solution for DreamHost. Make a folder name .php at the root directory. Inside of that make a folder with the .php version number, e.g 5.3. Inside of that make a text file with no suffix named phprc. In that text file place: memory_limit = 256M. Save the file. Ensure there is no file suffix. Upload it so the full path is /.php/5.3/phprc. Voila. Check BPS>System Info and it should show your new allotment:

    PHP Version: 5.3.27
    PHP Memory Usage: 32.67 MB
    WordPress Admin Memory Limit: 256M
    WordPress Base Memory Limit: 40M
    PHP Actual Configuration Memory Limit: 256M

    I tested both 128M and 256M, but nothing beyond that…wouldn’t want to be seen as greedy.

    #11586

    AITpro Admin
    Keymaster

    Thanks for posting this info!  Yeah, I cannot imagine ever actually needing 256M, but remember the days when a lot of computer RAM was only 256M.  These days RAM is in Gigs so you know how that goes.  😉

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.