Unable to activate Root BulletProof Mode

Home Forums BulletProof Security Pro Unable to activate Root BulletProof Mode

This topic contains 2 replies, has 2 voices, and was last updated by  AITpro Admin 2 years, 9 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #23910

    tapps
    Participant

    i’ve never run into this issue before. but every time i save my secure .htaccess file, everything turns green, until i click into something else, and the root .htaccess file goes right back to the default wordpress .htaccess file. i have deactivated all other plugins and tried, but nothing works. i’ve even tried just copying / pasting the “secure .htaccess” code into the .htaccess via FTP, it saves and uploads fine, but then i go and check, and it’s still the old default WP .htaccess file.

    i’ve also disabled the autorestore, just in case that was causing some issue, but that doesn’t seem to help either. any ideas what’s going on here? also here is all my system info, just in case this is something with this particular server (which doesn’t make sense either, since i’ve successfully installed BPSpro on other sites hosted by this company before…)
    [data copied and deleted from this topic]

    #23912

    AITpro Admin
    Keymaster

    What you describing is unusual so it may be related to the odd things we are seeing with 10.5 RSK filters. So I would like to take a look at this site personally.  Please create a temporary Administrator login and send that login info to:  info at ait-pro dot com.

    #23914

    AITpro Admin
    Keymaster

    The problem is not being caused by the BPS Pro RSK 10.5 filters.
    The problem is not being caused by another plugin or your theme.

    If I try to change anything at all about the standard generic WP code in your existing root htaccess file it is being blocked or reverts back to the generic WP htaccess code.

    Example:  Even manually adding BEGIN WordPress “test” is not allowed/is being blocked.  It does not appear to have anything to do with any other plugins you have installed or your theme.  This is a problem with either the server itself or a cPanel setting of some kind or maybe mod_security.  So you need to contact your host support and ask them why when you try to change your root htaccess code the file/code reverts back to the generic WP code below.  In other words, something is preventing you from being able to edit your root htaccess file and it does not appear to be coming from anything installed on your site and instead appears to be a server or cPanel setting or mod_security setting that is breaking things.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress
Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.