Security log not being zipped or emailed – DSO Server

Home Forums BulletProof Security Free Security log not being zipped or emailed – DSO Server


Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #16148

    Hi there,

    Hope you can offer a suggestion to fix this minor problem I’ve been experiencing with the security log function in BPS free plugin.  I have it set to email and then delete the log when it reaches 500kb.  However this doesn’t seem to work for some reason.  I receive an email every hour which just says:

    Security Log File For:

    But has no log file attached.  Also the log file is not being deleted and so currently stands at about 2000kb.  Obviously I can just delete this manually now, but it would be good to get the plugin working fully.

    So any suggestions as to why this might be happening?  I though it might be a permission error with the log file (my server runs with DSO so permission settings can sometimes be a little odd), however the log file is being written file and it can be manually deleted with the button in the plugin without any problem.

    Many thanks, James 🙂

    AITpro Admin

    This is probably a host specific thing or a DSO file/folder Ownership thing.  The security log text file is located in the /bps-backup/logs/ folder and the zip archive is created in that same folder.  So if the /bps-backup/logs/ folder (not just files – the entire folder) has the correct Ownership settings then that would not be the problem.  The zip function tries to use the ZipArchive class first and if that is not available falls back on PCLZip.  I guess it is possible you do not have either of those things available to you on your server, but very unlikely.  I think you should check with your host and ask them about all of these things and see what they say.

    AITpro Admin

    Check your server log file and see if there is an error regarding this for clues.  You can post it here and I may be able to tell you what the issue is.  DSO servers are a completely different animal though so it is 50/50 that I can tell you what the issue is.

    Also have you tried to do a DB Backup with BPS to see what happens.  That will give you some clues as well.


    Hi, thanks for the super-quick response.

    So I logged in this morning to try the various things you suggested, only to find that there was an email in my inbox with a zipped security log file attached and that the log has been deleted.  Not sure why this has suddenly all worked, I’d not yet got around to making any changes and it had been failing (black email and log file not deleted as described above) every hour for the past few days.  Now that’s strange!

    Only just found the new db backup tools.  All this seems to work perfectly, files can be written and backups made with no errors or other problems that I can see.  I have adjusted the permissions for the log file anyway to ones which I know work with my DSO server setup, just in case this is needed.  So I guess I’ll wait and see what happens next time the security log fills up again.

    My problem not though is that I spotted the option to change the wp db prefix which seemed a good idea.  So went ahead and made the changes, but it has broke the website I’m afraid 🙁  The browser says ‘this website has a redirect loop whenever I access either the site itself or the wp admin backend.  I hoped I would just need to clear the cache and it would be fine, but no luck so far.  It’s on an unimportant site so not a big issue and I don’t have much time to devote to fixing it at the moment, but any suggestions to get it back up and running easily would be gratefully accepted!

    While I’m here, just a couple of suggestions I’ve noticed which might be useful for you:-

    When I log into this site using the login box in the top right of the page (i.e. in the sidebar) it redirects to the main login page saying the captcha input is wrong.  There doesn’t seem to be anyway of entering the captcha word from the sidebar login though.

    In the plugin where you set the max filesize for the db and security log files before they get emailed and/or deleted, the three size options say 500kb, 256kb, 1Mb.  This is in descending numerical order, but not is descending size order – 100kb, 500kb then 256kb would make more sense rather than having medium, lowest then highest.

    Also the option to set the max size of the security log file in the db backup settings, and the db backup log file max size in the security log settings was initially a bit confusing.  Do they need to be repeated in the ‘other’ settings page?

    Many thanks, keep up the good work 🙂  James


    AITpro Admin

    I think it probably worked because you saved the Security Log/email options.  In BPS free I am not sure if we are automatically saving all DB options, but that should be done if it is not already being done.

    Check any custom code that you have added to see if it has a redirect loop.
    Click the activate BulletProof Modes button to see if that fixes it.

    Yep, not sure why the captcha cannot be added in the sidebar on this BuddyPress site.  At some point we will look into that.

    I believe the size options were done in the best/optimum size order. 500KB is the best size to choose, 256KB is the second best size to choose and 1MB is the worst size option to choose.

    Yes, in BPS free they are repeated instead of creating separate options like in Pro.  😉  Just cutting corners to make development quicker on BPS free.


    Thanks, all seems good for now.  James 🙂

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.