The requested URL index.php was not found on this server

Home Forums BulletProof Security Pro The requested URL index.php was not found on this server

This topic contains 4 replies, has 1 voice, and was last updated by  AITpro Admin 6 years, 8 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #1679

    AITpro Admin
    Keymaster

    New Topic created – Split from unrelated Topic

    I have done everything as the video instructs and as you have added. So, I went over to the homepage and it works properly but clicking on any other link to any other post or page on the website gives me the following:
     
    Not Found
    The requested URL /index.php was not found on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    #1681

    AITpro Admin
    Keymaster

    This is going to be an issue/problem with your Root .htaccess file or you have not created a custom permalink structure or the custom permalink structure you created is not valid or you have a DNS issue/problem.

    Did you click the [obsolete-removed] buttons before activating BulletProof Modes?

    Did you create a custom permalink structure?  If so, what is your custom permalink structure?

    #1685

    AITpro Admin
    Keymaster

    I am currently looking at your website and will post back here after I have checked your links.  thank you.

    #1686

    AITpro Admin
    Keymaster

    What I see is that you have a subfolder WordPress site installed under a subdomain site.  Is this WordPress subfolder site installed in a folder called – churchgrowth under the ng folder?  Example:  /ng/churchgrowth.

    subdomain is:  ng
    subfolder site is:  churchgrowth
    Your WordPress General Settings should be similar to this (NOTE: I am using example.com for the domain name as an example ONLY):
    WordPress Address (URL)   http://ng.example.com/churchgrowth
    Site Address (URL)   http://ng.example.com/churchgrowth

    Since you have WordPress installed in a subfolder then your Root .htaccess file should have /churchgrowth/ as the RewriteBase.  Please ensure that you have clicked the [obsolete-removed] Buttons and then activate Root BulletProof Mode again.  Then go to the B-Core Edit/Upload/Download page and check Your Current Root htaccess File tab to check that /churchgrowth/ is being added as the RewriteBase in your root .htaccess file.

    #1700

    AITpro Admin
    Keymaster

    Problem Resolved:

    Cause of problem:  The [obsolete-removed] buttons were not clicked before activating BulletProof Modes.  The RewriteBase in the Root .htaccess file was incorrect due to not clicking the [obsolete-removed] buttons before activating BulletProof Modes.  RewriteBase was / and not /churchgrowth/.

    Solution:  Clicked the [obsolete-removed] buttons and activated Root BulletProof Mode.  Links are working and no longer generating 404 errors.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.