Upgraded BPS version, getting errors on the site, thanks

Home Forums BulletProof Security Free Upgraded BPS version, getting errors on the site, thanks

This topic contains 6 replies, has 2 voices, and was last updated by  danny cheng 5 years, 4 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #1352

    danny cheng
    Member

    Hi, thanks for the great plugin. I really  think BPS is super.
    Here’s the problem and I hope someone can help..(please)

    Upgraded to the latest BPS version  a few hours ago- (I’m still using WP version 3.4.2)

    1. BPS keeps showing “site not protected message” even after activating all BPS modes successfully..
    2. Next- WP super cache tests show timestamps do not match anymore..
    3. Next- plugin page to upload, search for plugins etc…- shows error message (if you try to search for a plugin and others) like so:
    “either your server’s config is wrong or there’s a problem with wordpress.org” (I checked my other site- no problem with wordpress.org)
    4. Install theme page shows same error message…
    Can someone help me out? I’d appreciate any help that I can get.  I’m stumped.
    I’ve left BPS installed on my site at the moment.
    Thanks in advance…

    #1359

    AITpro Admin
    Keymaster

    Please read through the Read Me first page and after you have eliminated all of those possibilities and the problem still exists then post back here. >>> http://forum.ait-pro.com/forums/topic/read-me-first-free/

    What I suspect is going to be the problem is either this is the cPanel Broken HotLink Protection Tool problem or the flush_rewrite_rules problem.

    #1372

    danny cheng
    Member

    Hi and thanks for the quick reply-

    I’ve eliminated all the possibilities including deactivating other plugins and such- except messing about with the hotlink protection tool part because I really don’t know how…(sorry) So for now- I’ve decided to remove BPS to see if the site functions work properly- however, I can’t seem to remove BPS the way that is suggested on the trouble shooting page.

    quote:
    1. On the Security Modes page, click the Root Folder BulletProof Mode Deactivate button. See Custom Code Note if doing this step works.
    2. On the Security Modes page, click the wp-admin Folder BulletProof Mode Deactivate button. See Custom Code Note if doing this step works.
    3. If an issue/problem is related to Login Security turn Off Login Security on the Login Security & Monitoring page.
    4. If an issue/problem is related to ISL or ACE see this forum topic: http://forum.ait-pro.com/forums/topic/idle-session-logout-isl-and-authentication-cookie-expiration-ace/

    When I try to delete the plugin from the plugin page – it says I can’t do that for an active plugin. I only have one last question left: Can I safely remove the plugin by following the steps above, deactivate the plugin and delete “all files” without any problems? Please advice this non techie noob, thanks ever so much in advance.

    updates: after deactivating BPS and removing WP Super cache and reinstalling WP Super cache for about 4 times- the timestamps now match. But the plugin and theme pages are still sort of broken. Thanks..

    #1377

    AITpro Admin
    Keymaster

    To completely remove BPS manually you can delete the BPS plugin on the WordPress Plugins page and then FTP to your site and delete the .htaccess file in your website Root folder and the .htaccess file in your wp-admin folder.

    When I try to delete the plugin from the plugin page – it says I can’t do that for an active plugin.

    I have never heard of a message like that before in WordPress?  Do you have some other plugin installed that monitors other plugins?  WordPress does display a message along the lines of “you do not have permission to do that”. If plugin pages are displaying broken then most likely you have another plugin installed that is loading its script inappropriately.  See this Topic and let me know if this is what you are seeing >>> http://forum.ait-pro.com/forums/topic/bulletproof-security-menus-css-and-js-not-displaying-correctly/ I have no idea why there is a timestamp issue going on on your website.  What I am suspecting from everything you have told me is that you have another plugin installed that is interfering with your other plugins.

    Have you tried deactivating all your plugins except for BPS and WPSC and seeing what happens then?
    Also has your website ever been hacked before?  Or is it currently hacked?
    Do you have a standard single installation of WordPress or do you have a Network/Multisite installation of WordPress?

    #1389

    danny cheng
    Member

    Hi,

    It’s so good of you to reply…! I really appreciate your prompt response- and I commend you for your wonderful support. When I try to delete the plugin from the plugin page – it says I can’t do that for an active plugin. I have never heard of a message like that before in WordPress? Do you have some other plugin installed that monitors other plugins?
    Holy cows, thank you!
    After you mentioned this, I went about recalling the stuff I’ve been installing on the site lately and remembered that I had recently inserted a script by quantaast (for tracking ) into the section of the site. (I had heard that their service could help with finding out the demographics of your visitors…arghhh…) Anyway after removing it, everything is good again! I’m going to re activate BPS now and I suspect everything will be good. I’ve used BPS for the past 6 months without any hitches (even updated BPS once) and was planning to trouble shoot it by removing it and reinstalling it.(as I did with WP super) Looks like I don’t have to anymore. What can I say but- Thank you very much for your excellent support! I’ll be sure to get the pro version as soon as I can….

    #1392

    AITpro Admin
    Keymaster

    Great!  Glad you got it sorted out.  Please post the name of the script or plugin so that any other folks who run into this problem will know where to look or what to do to fix the issue.  Thanks.

    #1460

    danny cheng
    Member

    Hi and thanks again- I’ve just reactivated BPS and everything works like a charm..! Unfortunately I deleted the script before I’d seen your post-but I used a script from quantcast.com-basically to measure my traffic demographics. If you sign up for the service, you’ll receive a script to insert somewhere before the end of the body section. Here’s thanking ya again for the super great super support.
    Again- I’ll upgrade my plugin to the pro version as soon as I can,…

    Danny Cheng

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.