website blank – file downloaded when visiting website

Home Forums BulletProof Security Free website blank – file downloaded when visiting website

This topic contains 7 replies, has 2 voices, and was last updated by  AITpro Admin 2 weeks, 5 days ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #38184

    Wayne Seibel
    Participant

    I  obviously did something wrong with the set up wizard for whitelist.  When I attempt to open my website, I get a blank page.  Also when I attempt to open through wp-admin, blank page.  I get a pop up  asking to open application/x-httpd-php (2.2 KB) from: http://parkup.org  I saved the file.  I attempted a BPS back up through our web host and still a blank screen.  Any suggestions.

    Wayne

    #38185

    AITpro Admin
    Keymaster

    The problem is that your root htaccess file does not have your php/php.ini handler htaccess code in it.

    1. Use FTP or your web host control panel file manager and rename the /bulletproof-security/ plugin folder to /_bulletproof-security/.
    2. Manually edit your root htaccess file and add your php/php.ini handler htaccess code at the very top of your root htaccess file.  You can find our php/php.ini handler htaccess code in the most current backup of your root htaccess file here:  /wp-content/bps-backup/master-backups/root.htaccess-2019-11-12-6-23-59-pm.
    3. Login to your website.
    4. Go to the WordPress Plugins page and click the Must-Use link at the top of the Plugins page. If AutoRestore is turned Off you will see – “AutoRestore is turned Off” in green font under the BPS Pro MU Tools must-use plugin. If AutoRestore is not turned Off then click the “Turn Off AutoRestore” link to turn Off AutoRestore.
    5. Rename the /_bulletproof-security/ plugin folder back to /bulletproof-security/.
    6. Go to BPS Root Custom Code and add your php/php.ini handler htaccess code in this BPS Custom Code text box: CUSTOM CODE TOP PHP/PHP.INI HANDLER/CACHE CODE
    7. Click the Save Root Custom Code button.
    8. Go to the Security Modes page and click the Root Folder BulletProof Mode Activate button.

    #38209

    Wayne Seibel
    Participant

    Good Morning:   I added this htaccess code to the root htaccess as instructed above and it failed to let me log into the website.

    AddHandler application/x-httpd-php-5.2.17 .php

    Any other suggestions to try?

    Wayne

    #38211

    AITpro Admin
    Keymaster

    Oops I thought you had the BPS Pro plugin installed.  Delete your root htaccess file and let me know if that works or not.  Also I checked your server and your server is running PHP 7.x.  The php/php.ini handler htaccess code you posted above is for PHP 5.2.17

    Your web host is A2 Hosting.  See this A2 Hosting help page for how to create or get the Apache php handler for the PHP server version that you want to use > https://www.a2hosting.com/kb/cpanel/advanced-features/apache-handlers

    #38216

    AITpro Admin
    Keymaster

    Actually I think this is the A2 Hosting help page that you need > https://www.a2hosting.com/kb/cpanel/cpanel-software/changing-php-versions-and-settings-in-cpanel

    Do these steps:
    1. Delete your root htaccess file.
    2. Use the cPanel > Select PHP version tool > pick the PHP server version that you want to use.
    3. At this point a new root htaccess file may or may not be automatically created by using the cPanel php version tool.
    4. If you do not see a new root htaccess file then your host server does NOT use php/php.ini handler htaccess code. Go to BPS Root Custom Code and delete any php/php.ini handler htaccess code that you see in this Custom Code text box: 1. CUSTOM CODE TOP PHP/PHP.INI HANDLER/CACHE CODE, click the Save Root Custom Code button and click the Root Folder BulletProof Mode Activate button on the Security Modes tab page. If you do see a new root htaccess file then copy the php/php.ini handler htaccess code into this BPS Root Custom Code text box: 1. CUSTOM CODE TOP PHP/PHP.INI HANDLER/CACHE CODE, click the Save Root Custom Code button and click the Root Folder BulletProof Mode Activate button on the Security Modes tab page.

    #38217

    Wayne Seibel
    Participant

    Did the above and this is what comes up when logging into website

    new-applicaiton/x-httpd-php-7.1 .php /* Plugin Name: BulletProof Security Plugin URI: https://forum.ait-pro.com/read-me-first/ Text Domain: bulletproof-security Domain Path: /languages/ Description: Feature Highlights: Setup Wizard • MScan Malware Scanner • .htaccess Website Security Protection (Firewalls) • Security Logging|HTTP Error Logging • DB Backup • DB Table Prefix Changer • Login Security & Monitoring • JTC-Lite Login Form Bot Lockout Protection • Idle Session Logout (ISL) • Auth Cookie Expiration (ACE) • UI Theme Skin Changer • System Info: Extensive System, Server and Security Status Information • FrontEnd|BackEnd Maintenance Mode Version: 3.7 Author: AITpro Website Security Author URI: https://forum.ait-pro.com/read-me-first/ */ /* Copyright (C) 2010-2019 Edward Alexander | AITpro.com This program is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version. This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details. You should have received a copy of the GNU General Public License along with this program; if not, write to the Free Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA */ 
    #38223

    AITpro Admin
    Keymaster

    Ok contact us directly > info at ait-pro dot com so we can get this problem sorted out.  Please add a link to this forum topic for reference.

    #38228

    AITpro Admin
    Keymaster

    The problem is now fixed.  Here is what happened…

    A2 Hosting no longer uses php/php.ini handler htaccess code for PHP7.x versions.  You will not find that information anywhere on the A2 hosting website help pages because that information does not exist anywhere on their website.  At this point your website is using PHP7.2 which I choose in your cPanel.  You cannot use PHP7.3 because this error is being displayed:  Your PHP installation appears to be missing the MySQL extension which is required by WordPress.

    So what you need to do now are the steps below to finalize the fix permanently:

    1. Login to your website.
    2. Go to BPS Root Custom Code and delete the old php handler htaccess code that is saved in this Custom Code text box: 1. CUSTOM CODE TOP PHP/PHP.INI HANDLER/CACHE CODE.
    3. Click the Save Root Custom Code button.
    4. Go to the Security Modes page and click the Root Folder BulletProof Mode Activate button.

    Additional Notes for future reference:
    Google Browser cache was working against me until I figured out that Google cache was caching your old website state. Once I cleared my Browser cache I was able to successfully switch your PHP server version and see the actual current state of your website.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.