XAMPP – XAMPP WordPress Permalink Structure, XAMPP Virtual Host

Home Forums BulletProof Security Free XAMPP – XAMPP WordPress Permalink Structure, XAMPP Virtual Host

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #1611
    AITpro Admin

    Email Question:

    Hi there

    I am trying to activate the free version, however it seems to break everything but the home page. I have read the troubleshooting basic steps I found in your forum but it did not help.

    I am using xampp-portable on localhost.

    I deactivated the plugin and repeat the process of installing twice already, and keep getting the same problem.
    Please help! I heard such great things about this product.


    AITpro Admin

    XAMPP WordPress Custom Permalink structures should include index.php? in the Custom Structure path.


    I also recommend that you setup Virtual Hosting not only because this is smarter for Development, but it is just smart in general.  See this link below.




    Thank you,
    I am rather new at this. My Permalink structure indeed does not include index.php. it looks like this:  http://mgd.local/sample-post/
    AS you see I did switch to virtual hosts according to your recommendation.
    However, I do not see the option in my wordpress configuration to use index.php as part of link.
    Is this a must have in order to use your free security tool?

    AITpro Admin

    I meant your actual WordPress Custom Permalink Structure and not the URL itself.

    You would change your Custom Permalink Structure under the WordPress Settings >>> Permalinks.  The Custom Permalink Structure that I MUST use in order for URLs to display correctly on my XAMPP installation setup with Virtual sites is this:  /index.php?/%postname%/  You could of course use any of the other standard WordPress structure tags after /index.php?  

    WordPress Using Permalinks Codex:  http://codex.wordpress.org/Using_Permalinks



    Thank you – That worked, I changed the permalink structure like you described. .  I do have one problem with one page that it’s premalink I cannot change.
    The WP theme I am using. I have one link that represents Events and looks like this: http://mgd/index.php/pt-event/march
    Where the actual postname is ‘march’ and the ‘pt-event’ is built in for any page that is marked as ‘event’.
    When your tool is activated, the page returns 404 error. I tried creating a new event, same result.
    This is actually the most important page for me, as it’s password protected.
    Any idea what I need to do?

    AITpro Admin

    A 404 error means that your URL or URL structure is not valid and the page cannot be found.  The link you posted does not contain .local in the URL.  What exactly does this mean?  “the ‘pt-event’ is built in for any page that is marked as ‘event’.”  How are you password protecting these pages?

    To eliminate/test if BPS is causing this issue do these steps.

    1. On the Security Modes page, click the Root Folder BulletProof Mode Deactivate button. See Custom Code Note if doing this step works.
    2. On the Security Modes page, click the wp-admin Folder BulletProof Mode Deactivate button. See Custom Code Note if doing this step works.
    3. Test your plugin or theme.


Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.