You dont have permission to access wp-admin on this server

Home Forums BulletProof Security Free You dont have permission to access wp-admin on this server

This topic contains 1 reply, has 2 voices, and was last updated by  AITpro Admin 4 years, 9 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #7932

    Michael Milauskas
    Participant

    Hi,

    I’ve installed BPS on several sites and it’s worked flawlessly. However, I went back to one site (a client’s site) that I hadn’t looked at for  a while. I think he was having trouble viewing the site. He spoke with his hosting company and they did something with the htaccess file. When I viewed the admin section, I saw the BPS warning that the site was not being protected so I went into the BPS settings and started reapplying things (master htacces file, bulletproof mode, etc.). I must have done something wrong because I can’t access the wp-admin area or any other part of the site. If I try to go to the site (ceotech.com) I see this:

    Forbidden
    You don’t have permission to access / on this server.

    Same for the wp-admin:
    You don’t have permission to access /wp-admin/ on this server. What might I have done? And what can I do to resolve this? I also can’t access the site via FTP (don’t know if that’s related or not).

    #7933

    AITpro Admin
    Keymaster

    BPS does not affect FTP so that is another separate issue.  Possible causes for the FTP issue could be that the password has been changed or if this is a DSO configured Server then it could be an Ownership issue/problem.  ie the user/group has been changed and you would need to use chown to have priviledges to access this directory.

    What I suspect the issue/problem is is that the Host is no longer allowing 404 Read-Only permissions for .htaccess files to be used on this Server.  Use the web host control panel file manager and delete the .htaccess file in the website root folder and the .htaccess file in the wp-admin folder or you can change the file permissions of these files to 644 and you should be able to login.

    Troubleshooting steps for this problem:

    The most likely cause is that your Host does not allow you to lock your root .htaccess file with 404 file permissions.

    Do this first:
    FTP to your website and change the file permissions of the root .htaccess file to 644 permissions. If the site comes back up then go to the htaccess File Editor tab page and click on the Turn Off AutoLock button so that your root .htaccess will NOT be locked ever again.

    If the problem is still occurring then delete the root .htaccess file and the wp-admin .htaccess file, log back into your site, go to the BPS System Info tab page and post this information about your website below:

    Server Type:
    Operating System:
    WP Filesystem API Method:
    Server API:

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.