Your PHP Configuration Memory Limit is set to: 32M

Home Forums BulletProof Security Free Your PHP Configuration Memory Limit is set to: 32M

This topic contains 6 replies, has 2 voices, and was last updated by  Ginger 5 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #37341

    Ginger
    Participant

    Hi,

    I use BPS on all of my WP websites and can usually sort out any issues by looking in these forums. However, this one has me stumped.

    I noticed today that ALL of my websites have started having a red section on the Wizard screen. It says:

    Error: Your PHP Configuration Memory Limit is set to: 32M. WordPress needs a bare minimum Memory Limit setting of 64M to perform well. Contact your Web Host and ask them to increase your memory limit to the maximum memory limit setting allowed by your Host.

    However, if I go into MultiPHP INI Editor (in cPanel), I can see that “memory_limit” is set to “768M” for each of the sites.

    Clicking on “System Info” within BPS tell ms this …

    PHP Server|PHP.ini Info File|Folder Permissions (CGI or DSO)|Script Owner User ID (UID)|File Owner User ID
    PHP Version: 7.3.5
    PHP Memory Usage: 39.83 MB
    WordPress Admin Memory Limit: 768M
    WordPress Base Memory Limit: 40M
    PHP Actual Configuration Memory Limit: 32M Recommendation: Increase Memory Limit to 128M.
    PHP Configuration File (php.ini): /opt/cpanel/ea-php73/root/etc/php.ini
    WP Temp Dir: /tmp/
    PHP Temp Dir: /tmp
    PHP Upload Temp Dir: Not set/defined or directory is not writable
    Session Save Path: /var/cpanel/php/sessions/ea-php73
    Garbage Collector: On | Cycles: 0
    PHP Max Upload Size: 64M
    PHP Max Post Size: 8M
    PHP Safe Mode: Off
    PHP Allow URL fopen: Off
    PHP Allow URL Include: Off
    PHP Display Errors: Off
    PHP Display Startup Errors: Off
    PHP Expose PHP: Off
    PHP Register Globals: Off
    PHP MySQL Allow Persistent Connections: Off
    PHP Output Buffering: Off
    PHP Max Script Execution Time: 900 Seconds
    PHP Magic Quotes GPC: Off
    PHP open_basedir: Off/Not in use
    PHP XML Support: Yes
    PHP IPTC Support: Yes
    PHP Exif Support: Yes
    PHP Disable Functions: No PHP functions are disabled.

    “WordPress Admin Memory Limit” is set to 768M, but “PHP Actual Configuration Memory Limit” is set too low, at just 32M.
    What is which “PHP Actual Configuration Memory Limit” and where can I change it?

    Thanks

    #37342

    AITpro Admin
    Keymaster

    If you are sure that your PHP memory limit is 768M then you can ignore the BPS check on the System Info page and the warning about your PHP memory limit on the Setup Wizard page.  BPS makes every possible attempt to get the PHP memory limit from a host server, but some host servers do not return a correct value for the PHP memory limit variable.

    #37343

    Ginger
    Participant

    It certainly says that “memory_limit” is set to “768M” in MultiPHP INI Editor (in cPanel), but maybe there’s an issue?

    How do I know if cPanel or BPS is correct?

    Maybe BPS is picking up on a problem?

    #37344

    AITpro Admin
    Keymaster

    You can either check with your web host to make sure the PHP memory limit is really 768M or you can create a php file and add this one line of code in it below, upload the php file you created to your hosting account root folder and then use your Browser to go to view your website/server phpinfo.  Example: https://www.example.com/phpinfo.php. phpinfo — Outputs information about PHP’s configuration.  You will see to table columns under the Core section > Local Value and Master Value.  The Local Value is what your PHP config is for your website.  The Master Value is what your PHP config is for your server.  Usually you will see the same value for memory_limit for both the Local Value and Master Value table column rows.

    <?php phpinfo(); ?>
    #37345

    Ginger
    Participant

    Thanks for that.

    It looks like “memory_limit” is 768M for the Local Value and 32M for the Master Value.

    Should I worry about that Master Value?

    Thanks

    #37346

    AITpro Admin
    Keymaster

    That’s fine then.  The Master Value is set in your server’s php.ini file and is the PHP memory limit of 32M BEFORE any of your website’s php code is executed.  The Local Value overrides the Master Value.  So that means you have 768M of PHP memory available for executing php code.

    What used to happen pretty much all the time in previous versions of PHP was that when you changed the Local Value then the Master Value would be changed as well to whatever the Local Value is set to.  That no longer seems to happen as often in PHP7.x.  Not really sure why that is, but must be some new PHP server config thing in PHP7.x.

    #37350

    Ginger
    Participant

    Perfect. Thank you.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.