Crash after upgrade of wordpress to 3.5.2

Home Forums BulletProof Security Pro Crash after upgrade of wordpress to 3.5.2

This topic contains 9 replies, has 3 voices, and was last updated by  Young Master 5 years ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #7085

    Krzysztof
    Participant

    I have upgraded wordpress to 3.5.2 but before turned off ARQ as recomended. I think that the update went well – the site is working but when I try to login I always get a 404 error – I’m logged in but can not access the admin area. The same goes for regular users.

    Edit:
    Here is the solution: http://wordpress.org/support/topic/upgrade-to-34

    #7087

    AITpro Admin
    Keymaster

    This is a very old forum topic:
    Important Note: If you have BPS Pro 12.8 or higher versions of BPS Pro installed click this link for quickier and easier steps to fix quarantined files problems: https://forum.ait-pro.com/forums/topic/website-not-loading-after-wordpress-upgrade-or-theme-upgrade-500-error-files-quarantined/. BPS Pro 12.8+ versions automatically deactivate/turn ARQ Off when the /bulletproof-security/ plugin folder is renamed instead of having to use the BPS Pro XTF Form Tools to deactivate/turn ARQ Off.

    Actually by manually doing a WordPress downgrade or WordPress upgrade this will resolve the problem.  I am surprised that you were able to manually upgrade without first using the arqdelete.php script to turn off AutoRestore.  The majority of WordPress Core files are the same from version 3.5.1 to 3.5.2 so the files that stayed the same would not be autorestored or quarantined, but any new WordPress Core files that have changed would be autorestored or quarantined if ARQ is not turned Off when doing a manual upgrade.

    http://forum.ait-pro.com/forums/topic/autorestore-quarantine-guide-read-me-first/#ARQ-Troubleshooting
    Outdated/old info removed – the link above points to current/new info.

    #7090

    Krzysztof
    Participant

    My instalation was missing upgrade.php and after uploding it via ftp it went ok. I have turned off ARQ before tinkering with the new version as recomended in the box that popped out when the update became available 😉

    #7092

    AITpro Admin
    Keymaster

    Oh ok then in your case I guess the upgrade.php file did not get unpacked to your website like the WordPress Forum topic is explaining.

    #7093

    Krzysztof
    Participant

    Sory for confusion – probably I haven’t explained it clearly enough in the first post.

    #7094

    AITpro Admin
    Keymaster

    Actually this is a very good thing since 2 different causes of the problem have similar symptoms/end results and 2 solutions have posted depending on which problem might have occurred.

    #7105

    Young Master
    Participant

    I read an article here http://www.inmotionhosting.com/support/website/wordpress/update-wordpress-from-admin-dashboard they say that inorder to allow WordPress to automatically update itself you would need to change file permissions on your/wp-content/ directory to 775. Is it really to change wp-content file permission to 775?

    #7106

    AITpro Admin
    Keymaster

    Typically you would only have to make a permission change if your Server Type is DSO and not CGI.  Each web host is different so maybe inMotion is doing something differently.  If you can install/upgrade plugins without having to change permissions then you should also be able to upgrade WordPress without having to change permissions.  Try the WordPress upgrade without changing permissions.  If there is a problem then WordPress will automatically stop the upgrade and display an error message so that your upgrade will not crash your website.

    #7107

    Young Master
    Participant

    my server type is CGI and I can install/upgrading plugins without changing folder permissions.

    #7108

    Young Master
    Participant

    The update worked just fine without the need of changing wp-content file permission.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.