failed to open stream: Permission denied in general-functions.php on line 1474

Home Forums BulletProof Security Pro failed to open stream: Permission denied in general-functions.php on line 1474

This topic contains 8 replies, has 2 voices, and was last updated by  AITpro Admin 3 years, 6 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #20178

    AITpro Admin
    Keymaster

    [Copied from wordpress.org support forum]

    https://wordpress.org/support/topic/issue-after-latest-bulletproof-pro-upgrade?replies=1

    This plugin showed that it needed an upgrade. Clicked upgrade now. Stated it installed and activated successfully. Now on every admin page, it shows this at the top: Do you have any idea or resolution to this issue?

    Warning: file_put_contents(/home/{xxxxx}/public_html/{xxxxx}/.htaccess): failed to open stream: Permission denied in /home/{xxxxx}/public_html/{xxxxx}/wp-content/plugins/bulletproof-security/includes/general-functions.php on line 1474
    #20179

    AITpro Admin
    Keymaster

    I have never seen this error before so I assume the upgrade failed.  Use the BPS Pro built-in Upload Zip Installer to reinstall BPS Pro.  Did you upgrade BPS Pro by clicking the BPS Pro update now link on the WordPress Plugins page or did you update BPS Pro some other way?

    http://forum.ait-pro.com/forums/topic/bulletproof-security-pro-bps-pro-upgrade-installation-methods/

    Upgrading an existing BulletProof Security Pro Installation (Using the BPS Pro Built-in Upload Zip Installer)
    Download the bulletproof-security.zip file from the AITpro.com Secure Download Area. Under the BPS Pro Setup Main menu, click the Upload Zip Install submenu link. Click the Choose File button, navigate to where you downloaded the bulletproof-security.zip file on your computer (Note: the zip file MUST be named bulletproof-security.zip), click the Upload Zip File button and click the Install Zip Now button.

    #20181

    JP Martinez
    Participant

    I used the Update link next to the plugin name. I followed your directions and still them same error.  I deactivated any security plugins such  as Wordfence, Exploit Scanner and Lockdown WP Admin.  No change. Should I uninstall and reinstall?

    #20182

    AITpro Admin
    Keymaster

    Hmm interesting.  This is a fairly new error check that has been added in BPS Pro.  I think the problem that is happening is that you have generic WordPress rewrite code in your root .htaccess file somewhere and probably saved to BPS Custom Code as well.  Go to the htaccess File Editor and post the entire contents of “Your Current Root htaccess File” from the tab window.

    #20183

    JP Martinez
    Participant

    Is it safe to put the htaccess which has Ip addresses in this post?

    #20184

    AITpro Admin
    Keymaster

    Yeah it is safe since this would be considered public/known info, but you can send your root htaccess file contents to info at ait-pro dot com if you are more comfortable with that.

    #20185

    JP Martinez
    Participant

    OK. Just sent you the file 😉  thanks for being understanding..

    #20187

    AITpro Admin
    Keymaster

    Obsolete BPS no longer uses this feature: Did you get my email reply that I sent an hour+ ago?  If so, did creating new htaccess files with AutoMagic and activating BulletProof Modes work or did you see errors when trying to create new htaccess files with AutoMagic or activating them?

    #20188

    AITpro Admin
    Keymaster

    Obsolete BPS no longer uses this feature: This issue/problem was resolved by clicking the AutoMagic buttons and activating BulletProof Modes.  The root cause is still not known, but the error check in the general-functions.php file will have a new displayed message in the next BPS Pro version that will display a step by step correction steps.  ie Do X, Y and Z.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.