ini_set options Save|Enable button not clickable

Home Forums BulletProof Security Pro ini_set options Save|Enable button not clickable

This topic contains 7 replies, has 2 voices, and was last updated by  Nik 1 year, 6 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #31104

    Nik
    Participant

    [Topic Split & Topic Title changed]
    Hello,

    I changed “Max Executiion time from 30 to 60, but the Save|Enable Options button does not work, so I cannot save the changes.
    The htacess is open and writable.
    Am I missing something?

    Nik

    #31106

    AITpro Admin
    Keymaster

    @ Nik – See this Reply in this forum topic for possible reasons why the ini_set options code is not being saved in your wp-config.php file:  http://forum.ait-pro.com/forums/topic/ini_set-not-created-in-wp-config-php/#post-28240

    #31107

    Nik
    Participant

    Hi AITpro Admin,

    Thanks for your quick reply.  I checked the wp-config.php file.  Everything is coded right.  I had increased the parameter for the memory.  See code below.  I thought that was the issue, so I removed the code.

    The issue persist.  Changing the “Max Execution time from 30 to 60 is still not possible as the Save|Enable Options button does not work

    define('WP_DEBUG', false);
    define( 'WP_MEMORY_LIMIT', '64M' );
    
    /* That's all, stop editing! Happy blogging. */

    Any help would be appreciated.

    Thanks,

    Nik

    #31111

    AITpro Admin
    Keymaster

    @ Nik – Is your wp-config.php file in the standard/default WordPress location, which is in the WordPress installation folder?  Do you see any BPS ini_set code in your wp-config.php file IF the wp-config.php file is in the standard/default WordPress location?  If your wp-config.php file is not in the standard/default WordPress location then you will need to add/create the BPS ini_set code manually in your wp-config.php file or you can move your wp-config.php file back to the standard/default WordPress location so that the BPS Pro ini_set Options tool will be allowed to write to your wp-config.php file.

    /* That’s all, stop editing! Happy blogging. */

    /** BEGIN BPS Pro ini_set Settings **/
    @error_reporting(E_ALL|E_STRICT);
    @ini_set('log_errors','On');
    @ini_set('error_log','/your-actual-website-folder-path/wp-content/bps-backup/logs/bps_php_error.log'); // add the path to your php error log
    @ini_set('log_errors_max_len','1024');
    @ini_set('memory_limit','128M');
    @ini_set('session.cookie_httponly','On');
    @ini_set('session.use_only_cookies','On');
    @ini_set('session.cookie_secure','Off');
    @ini_set('ignore_repeated_errors','On');
    @ini_set('ignore_repeated_source','Off');
    @ini_set('allow_url_include','Off');
    @ini_set('define_syslog_variables','Off');
    @ini_set('display_errors','Off');
    @ini_set('display_startup_errors','Off');
    @ini_set('implicit_flush','Off');
    @ini_set('magic_quotes_runtime','Off');
    @ini_set('max_execution_time','30');
    @ini_set('mysql.connect_timeout','30');
    @ini_set('mysql.trace_mode','Off');
    @ini_set('report_memleaks','On');
    /** END BPS Pro ini_set Settings **/
    #31119

    Nik
    Participant

    Hi AITpro Admin,

    The wp-config.php file is in the standard/default WordPress location, and I see all BPS ini_set code in your wp-config.php file.
    The coding is exactly as you described above, except the memory_limit is 512M instead of 128M.
    The Save|Enable Options button still does not work.
    I changed  the “Max Execution time from 30 to 60 in the wp-config.php file, but the change is not reflected in BPS ini_set Options.
    Any other suggestions to troubleshoot the issue is appreciated.

    Thanks,
    Nik

    #31120

    AITpro Admin
    Keymaster

    @ Nik – Oops I should have literally checked the ini_set Options Save|Enable Options button first.  Yep, there is a new CSS/div bug/problem so that the button is literally not clickable at all.  This new problem occurred during the new Mobile friendly code changes in BPS Pro 12.4.  For now manually edit your wp-config.php file and change the value from: 30 to 60.  This bug will be fixed in the next BPS Pro version release.

    #31122

    AITpro Admin
    Keymaster

    @ Nik – We decided to fix this bug now and upload a new BPS Pro 12.4 zip file.  You can do either of these methods below to upgrade to the new fixed BPS Pro 12.4 version.

    Force a BPS Pro upgrade from our API server:
    Go to the WordPress Plugins page and click the Edit link under the BPS Pro plugin.
    On the WordPress Edit Plugins page, change the version number from:  12.4 to 12.3 and click the Update File button.
    Go back to the WordPress Plugins page, click the WordPress Plugins page menu link 3 times.
    You should see a new BPS Pro 12.4 upgrade notification on the Plugins page.

    Manual BPS Pro upgrade:  http://forum.ait-pro.com/forums/topic/bulletproof-security-pro-bps-pro-upgrade-installation-methods/

    #31142

    Nik
    Participant

    Hi AIT pro Admin,
    Thank you very much for you quick follow up to resolve the issue.  I will update the BPS 12.4.
    Nik

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.