Installing with FCGID

Home Forums BulletProof Security Free Installing with FCGID

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #3595

    I’ve spent the last few days looking for the best firewall and it looks like this one is it – and in fact looks like the only one that is really up to date.

    However, when trying to install, I run into all sorts of file permission problems.

    I don’t know much about php modes, but my server is CENTOS  6 running Virtualmin. I am told virtualmin runs FCGID by default.

    I can change it though, I have these options:

    Apache mod_php (run as Apache’s user)
    CGI wrapper (run as virtual server owner)
     FCGId (run as virtual server owner)

    I’ve tried all three and get the same results.

    Any other suggestions, or thoughts on an alternative firewall if BulletProof doesn’t work with my setup?


    PS: just a thought, could I ssh in as root and run some command that would set bulletproof files up?

    AITpro Admin

    You will have to either change file / folder Ownership or temporarily change file permissions to 777.  See this Forum Topic regarding DSO.  The same steps will apply to you and would need to be done or you could switch to suPHP.



    Thank you, got it installed now with green lines all about 🙂

    I did have to set several files & directories to 777 – now that I have it installed, will it work to reset them back to the recommended permissions, or will that mess BP up?

    When I update BP, will I need to set them back to 777 and then return them to recommended again?



    AITpro Admin

    Yes, you can reset all permissions back to what they were and BPS will work fine.

    Yes, when you upgrade BPS the automatic .htaccess file update will not be able to access/write to the root and wp-admin .htaccess files so you will have to temporarily change the file permissions for the root .htaccess file and the wp-admin .htaccess again to allow BPS to auto-update these .htaccess files and then reset the permissions back to what they were.


    Ok, that won’t be difficult now that I’ve done it once 🙂

    I just ran a sitecheck with sucuri (the free check they do).

    They found:


    Web application version:

    WordPress version: WordPress
    Wordpress Version 3.5 based on: http: //www.(mysite).com/wp-admin/js/common.js
    WordPress directory: http: //www.(mysite).com/wp-content
    WordPress theme: http: //www.(mysite).com/wp-content/themes/(mytheme)/


    Should they have been able to find those directories and info with BulletProof activated?

    Thanks again for all your awesome support here,


    AITpro Admin

    It is impossible and pointless to hide your WordPress version.  There are dozens of ways to find out which version of WordPress you have installed.  BPS has an old feature that was added years ago and was left behind.  We may or may not delete it.  Either way Sucuri is using one of the other dozens of ways to detect your WordPress version which cannot be hidden.

    √ WordPress Meta Generator Tag Removed
    √ WordPress Version Is Not Displayed / Not Shown


    Ok, just wanted to make sure that was expected behavior,

    Thanks again,


Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.