Internal Server Error

Home Forums BulletProof Security Pro Internal Server Error

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
  • #5221
    AITpro Admin

    Email Question:

    Thank you for the latest update.

    One thing. The system started to give this error after the latest update. What is the reason? Thank you

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    AITpro Admin

    How did you do the upgrade installation?  From your WP Dashboard or Zip installation?  If you installed the upgrade from a zip file did you use the BPS Pro Upload Zip installer or the WordPress Upload Zip installer?

    Did you install ONLY the BPS Pro plugin update or did you install all available plugin updates at the same time?

    Did you do anything else besides just installing the BPS Pro upgrade?

    Explain exactly what you were doing at the time the error occurred.  Be very specific with exact details of what you were doing when the error occurred.


    I am working on a new installation of BPS Pro and am hitting this exact error with “Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request” at the bottom. I am also working on a local MU dev site using  DesktopServer prior to pushing the site live.

    Activating the “Website Root Folder htaccess Security Mode” seems to work okay as I can see all the BPS code in the .htaccess file. The ISE error appears when I use the auto-magic buttons to “Activate Website wp-admin Folder htaccess Security Mode.”

    Since I am rather new to WP, I have not added custom code on my own but it could have been added through WP or my themes. For try #2, I copied the contents of the original .htaccess file into the Custom Code (top) and saved it before activating the root and wp-admin security modes. Same thing happened – root saved correctly, wp-admin threw the Internal Server Error.

    I can get back into my sites by resetting the .htaccess to the original contents but that means BPS is not active. Look forward to a solution.

    AITpro Admin

    Do you have a XAMPP, MAMP, etc. installation on your System?  It is Apache based correct and not IIS based?  Assuming that the root .htaccess file is not crashing the site then it would appear that you have a local Apache Server installed.

    Is DesktopServer made by

    AITpro Admin

    Hmm let’s backtrack and check the most obvious things first.



    AITpro Admin

    Also check that you are clicking the correct [obsolete-removed] buttons for whichever Network/Multisite that you have – subdirectory or subdomain.  Delete any Custom Code that you have added before you click the [obsolete-removed] buttons.


    Yes – it is Desktop Server by and it created a XAMPP folder on the root level of my Win7 computer.

    Okay – I did Network Activate BPS so let me reset and try again. I may have gotten confused following the video as it tracks a single site installation. Something lead me to believe that the Activation key was particular to each site, not a Network site with multiple sites. I’m the Super Admin and can see BPS options in both the network and individual sites. I’ll post back my results. Thanks.


    Confirming Desktop Server is using a local Apache server (XAMPPLITE). After resetting the .htaccess file to remove the Internal Server Error, I did the following:
    – went into Network Admin area and deactivated the Network level BPS Plugin.
    – navigated to one of the sites (virtual sub-directory) and activated the BPS Plugin.
    – clicked on the top to-do item (security status page). Moved to the Custom Code tab, deleted the root code and saved.
    – Move to Security Mode tab
    – Activate the root .htaccess file. Everything works.
    – Activate the wp-admin .htaccess file. The Internal Server Error appears again. 🙁


    Should I try this?

    500 Internal Server Error After Activating BulletProof Mode for your Root Folder

    Some Web Hosts do not allow you to use the “Options” Directive in .htaccess files. If you see a 500 Internal Server Error then comment out the “Options” Directive by adding a pound sign (#) in front of Options -Indexes in your Root .htaccess file as shown below.

    # If you are getting 500 Errors when activating BPS then comment out Options -Indexes
    # by adding a # sign in front of it. If there is a typo anywhere in this file you will also see 500 errors.
    #Options -Indexes

    Some Web Hosts do not allow you to use the “DirectoryIndex” Directive in .htaccess files. If you see a 500 Internal Server Error then comment out the “DirectoryIndex” Directive by adding a pound sign (#) in front of DirectoryIndex in your Root .htaccess file as shown below.  Known Hosts with this issue:  NordNet

    # Use index.php as default directory index file
    # index.html will be ignored will not load.
    #DirectoryIndex index.php index.html /index.php
    AITpro Admin

    “…- navigated to one of the sites (virtual sub-directory) and activated the BPS Plugin….”



    Thank you for your clarification…and patience! I have made it past the root/wp-admin secure modes. Woo hoo! Working with Network/Multisite adds another level of complexity during set up but it will hopefully save management time down the road. And then there’s the learning curve of being new to WP.  I did not want to go live without security in place.

    The file lock step noted that my local Apache server is DSO and to only select the 644-permissions options for the first four items. I did this and continued through the firewall test mode. Everything looked okay however yellow boxes remain (listed below). I suspect I’ll need to change the file lock settings once the site is on Hostgator (turn off firewall, make file lock changes, save and reset firewall). Does that sound correct?

    Your Root htaccess File is not Locked
    To Lock your Root htaccess file Click Here.
    Your wp-config.php File is not Locked
    Click Here To Lock your wp-config.php file.
    Your WP Root index.php File is not Locked
    Click Here To Lock your WP Root index.php file.
    Your wp-blog-header.php File is not Locked
    Click Here To Lock your wp-blog-header.php file.
    The Plugin Firewall Needs To Be Activated
    Click Here to go to the Plugin Firewall to create your Plugin Firewall Whitelist and then Activate the Plugin Firewall.

    AITpro Admin

    Actually for DSO Servers you can turn Off F-Lock checking & alerts for all files since DSO file permissions work differently then CGI and you cannot actually lock DSO Server files.

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.