Migrated site to new hosting – getting lots of error boxes

Home Forums BulletProof Security Pro Migrated site to new hosting – getting lots of error boxes

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #38970
    Carlo
    Participant

    Have just migrated from a shared hosting plan a new hosting (cloudways).
    So the “new” site is cloned and ready, i havent pointed the domain to the new one as i see alot of errors in the wordpress dashboard (all from BPS pro).

    what process should i do to make sure everything is set for the new migrated site?

    #38971
    AITpro Admin
    Keymaster

    Here is a help forum topic for doing migrations/moves/cloning > https://forum.ait-pro.com/forums/topic/migrating-moving-or-cloning-websites/#post-20407. Since you have already migrated your site then try running the Setup Wizards and see if they takes care of some of the errors. Most likely you will need to work through the other errors one by one. If you run into problems with solving any problems then post the error in your forum reply.

    #38974
    Carlo
    Participant

    Ok, followed your directions and as far as i can see everything went well and no more errors.

    1.the only thing i didn’t do was get the custom codes from the old hosting (i still have access, just don’t know what folder they would be stored in). is there a way to access this in file manager or ftp, i actually don’t remember if there was anything major there but good to check if possible?

    2. I’m guessing the Plugin Firewall will workout itself over time again? as i didn’t get the list from the old hosting version?

    3.i would want to update the https redirection code:obviously with my site name below, but where would i put that in BPS?

    # Canonical HTTPS/non-WWW
    <IfModule mod_rewrite.c>
    RewriteCond %{HTTPS} off [OR]
    RewriteCond %{HTTP_HOST} ^www\.example\.com [NC]
    RewriteRule (.*) https://example.com/$1 [L,R=301]
    </IfModule>
    #38975
    AITpro Admin
    Keymaster

    You can grab your old root htaccess file from your old site/hosting and then copy the Custom Code in that root htaccess file into your new site’s Custom Code text boxes.

    The Plugin Firewall is automated with the AutoPilot Mode Cron, which will automatically check for any needed whitelist rules and automatically create them.

    Use the BPS HTTPS Rewrite code and steps in this forum topic > https://forum.ait-pro.com/forums/topic/wordpress-ssl-htaccess-code-rewrite-ssl-rewritecond-server_port/#post-7233

    #38976
    Carlo
    Participant

    Thanks, i tried the HTTPS rewrite code(s).

    I added it to the CUSTOM CODE WP REWRITE LOOP START box. each time i save in that box, does it double up on the rewrite codes? or just rewrite the existing one? because i added the code and the site crashed.

    somehow got back into the admin area and removed it and got it up again. i think i read somewhere that if there is http://site-image-links  then it cause a loop error? well somehow after this migration my images in each post are HTTP…  weird thing is the source image is https though. so I’m a little lost at the moment.

    at one stage

    #38977
    AITpro Admin
    Keymaster

    Whatever code is in the CUSTOM CODE WP REWRITE LOOP START it will be written to this section of the BPS Root htaccess file and will replace this standard BPS Rewrite Loop Start code. If any of your htaccess code in any of the Custom Code text boxes is invalid/bad then when you activate Root BulletProof Mode your site will crash. Check that all of your custom code is valid/good.

    # WP REWRITE LOOP START
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    Most likely the cause of your image file URL’s being http and not https is that your WordPress General URL settings are http and not https.

    WordPress General Settings:
    WordPress Address (URL)    https://www.your-domain-name.com
    Site Address (URL)                https://www.your-domain-name.com

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.