Images not showing and scripts not loading

Home Forums BulletProof Security Pro Images not showing and scripts not loading

This topic contains 11 replies, has 2 voices, and was last updated by  Tin Hoang 3 years, 5 months ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #20636

    Tin Hoang
    Participant

    Hello,

    I have two issues right now with my multisite sites:
    1. all sudden SOME images are not appearing in my front/back end
    When I use Chrome developer tools I see the error:
    Failed to load resource: the server responded with a status of 500 (Internal Server Error)
    for example, my recaptcha images near the bottom of http://bluegemini.ca do not appear.
    2. Plugins in wp-admin like BPS Pro are not loading correctly. For one the BPS Pro icon doesn’t appear – same error ‘status 500’ . But also the BPS Pro pages like “P-Security” do not fully render. It appears the javascript might not be executing to create tabs for the different P-Security sections like PHP error log, PHP .ini options, etc.

    below are images of the errors:
    Back end icons not showing | Back end plugins not loading | Front end icons not showing

    Backend icons not showingBackend plugins not loadingFrontend icons not showing

    please help.
    Tin

    #20642

    AITpro Admin
    Keymaster

    Do BPS Pro troubleshooting step #3 and then do the Plugin Firewall manual setup steps:

    Source: http://forum.ait-pro.com/forums/topic/read-me-first-pro/#bps-pro-general-troubleshooting

    3. On the Security Modes page, click the Plugin Firewall BulletProof Mode Deactivate button.

    Plugin Firewall Manual Setup Steps
    1. Copy and paste plugin scripts/whitelist rules to the Plugins Script|File Whitelist Text Area.
    2. Click the Save Whitelist Options button.
    3. Turn AutoPilot Mode On.
    4. Click the Plugin Firewall BulletProof Mode Activate button.

    Plugin Firewall Error Checking & Displayed Error Messages:

    BPS Alert! Plugin Firewall Invalid Whitelist Rules
    One or more of your Plugin Firewall Whitelist rules are not valid. Click Here to go to the Plugin Firewall Tools, click on the Plugin Firewall Whitelist Tools accordian tab and correct/fix any invalid plugin whitelist rules in the Plugins Script/File Whitelist Text Area based on the Plugin Firewall error checks that are displayed to you.

    Example Plugin Firewall error check message (edit: ironic that this was actually the problem occurring)
    Error: Your Whitelist rules either have additional/extra whitespaces between whitelist rules, line breaks/new lines between or after your whitelist rules or no space after the comma between your plugin scripts/paths/rules.
    Click on the Plugin Firewall Whitelist Tools accordian tab and correct/fix any invalid plugin whitelist rules in the Plugins Script/File Whitelist Text Area.
    Edit your Whitelist rules to correct the error and click the Save Whitelist Options button and activate the Plugin Firewall again.
    Valid plugin Whitelist rules MUST use ONLY this Format: /plugin-folder-name/plugin-script.js, /plugin-folder-name/(.*).js.
    Plugin paths/scripts are separated by a comma and a single space. Your whitelist rules should be one continuous single line of scripts/paths/rules without any line breaks/new lines.
    BPS will automatically strip out line breaks/new lines. Click the Save Whitelist Options button again.

    #20648

    Tin Hoang
    Participant

    Hi, thank you for your response!

    Followed your instructions. Up until the last step of Plugin Firewall manual setup steps the site is fixed. Once I click “Activate button” to activate the plugin firewall in B-Core Security Modes Activate Plugin Firewall Security Mode. the original site is missed up again. So i ran through the instructions again and just went up to step 3. Please advise.

    Thank you
    Tin

    #20651

    AITpro Admin
    Keymaster

    Go to the B-Core htaccess File Editor tab page, click on the “Your Current Plugins htaccess File tab”, scroll to the bottom of the Plugins htaccess file contents and copy all of the code shown below (Begin Whitelist to the end of the file contents) and paste it in your forum reply.

    # BEGIN WHITELIST: Frontend Loading Website Plugin scripts/files
    SetEnvIf Request_URI "/bulletproof-security/400.php$" whitelist
    SetEnvIf Request_URI "/bulletproof-security/403.php$" whitelist
    SetEnvIf Request_URI "/wp-jquery-lightbox/jquery.lightbox.min.js$" whitelist
    SetEnvIf Request_URI "/nextgen-gallery/products/photocrati_nextgen/modules/ajax/static/persist.js$" whitelist
    SetEnvIf Request_URI "/nextgen-gallery/products/photocrati_nextgen/modules/ajax/static/ajax.js$" whitelist
    SetEnvIf Request_URI "/cforms/js/cforms.js$" whitelist
    SetEnvIf Request_URI "/nextgen-gallery/products/photocrati_nextgen/modules/lightbox/static/lightbox_context.js$" whitelist
    SetEnvIf Request_URI "/wp-jquery-lightbox/jquery.touchwipe.min.js$" whitelist
    SetEnvIf Request_URI "/nextgen-gallery/products/photocrati_nextgen/modules/ajax/static/ngg_store.js$" whitelist
    # END WHITELIST
    #
    # FORBID REMOTE ACCESS TO THESE PLUGIN FILE TYPES FROM ANYONE EXCEPT YOU
    # Whitelist Exceptions: Payment Gateway Provider domain names and/or Whitelisted Plugin scripts/files ONLY
    <FilesMatch "\.(7z|as|bat|bin|cgi|chm|chml|class|cmd|com|command|dat|db|db2|db3|dba|dll|DS_Store|exe|gz|hta|htaccess|htc|htm|html|htx|idc|ini|ins|isp|jar|jav|java|js|jse|jsfl|json|jsp|jsx|lib|lnk|out|php|phps|php5|php4|php3|phtml|phpt|pl|py|pyd|pyc|pyo|rar|shtm|shtml|sql|swf|sys|tar|taz|tgz|tpl|txt|vb|vbe|vbs|war|ws|wsf|xhtml|z|zip)$">
    Order Allow,Deny
    Allow from env=whitelist
    Allow from example.com
    Allow from 127.0.0.1
    # BEGIN PUBLIC IP
    Allow from 127.0.0.1
    # END PUBLIC IP
    # BEGIN ADDITIONAL ALLOW FROM RULES
    Allow from 130.
    # END ADDITIONAL ALLOW FROM RULES
    </FilesMatch>
    #20652

    Tin Hoang
    Participant

    Hello, this is what is in my htaccess File Editor tab page “Your Current Plugins htaccess File” “An htaccess file was not found in your /” I didnt know if you wanted me to copy but i did it anyway, clicked update file, but the changes did not persist.

    Thanks,
    Tin

    #20655

    AITpro Admin
    Keymaster

    Do these Plugin Firewall manual setup steps below first to create the Plugin Firewall htaccess file and then copy the Plugin htaccess file contents. Do NOT do any other steps and do NOT activate the Plugin Firewall.
    [obsolete-removed]

    #20679

    Tin Hoang
    Participant

    Hello,

    followed your instructions:

    [obsolete-removed]

    This is what is currently in my plugins.htaccess

    # BEGIN WHITELIST: Frontend Loading Website Plugin scripts/files
    
    SetEnvIf Request_URI "/bulletproof-security/400.php$" whitelist
    SetEnvIf Request_URI "/bulletproof-security/403.php$" whitelist
    SetEnvIf Request_URI "/contact-form-7/includes/js/jquery.form.min.js$" whitelist
    SetEnvIf Request_URI "/contact-form-7/includes/js/scripts.js$" whitelist
    SetEnvIf Request_URI "/wordfence/js/tourTip.js$" whitelist
    SetEnvIf Request_URI "/wordfence/js/jquery.colorbox-min.js$" whitelist
    SetEnvIf Request_URI "/wordfence/js/jquery.tmpl.min.js$" whitelist
    SetEnvIf Request_URI "/wordfence/js/admin.js$" whitelist
    SetEnvIf Request_URI "/wordfence/js/jquery.dataTables.min.js$" whitelist
    SetEnvIf Request_URI "/marketpress/marketpress-includes/js/ajax-cart.js,
    /instagram-slider-widget/assets/js/jquery.flexslider-min.js$" whitelist
    SetEnvIf Request_URI "/instagram-slider-widget/assets/js/jquery.flexslider-min.js$" whitelist
    # END WHITELIST
    #
    # FORBID REMOTE ACCESS TO THESE PLUGIN FILE TYPES FROM ANYONE EXCEPT YOU
    # Whitelist Exceptions: Payment Gateway Provider domain names and/or Whitelisted Plugin scripts/files ONLY
    <FilesMatch "\.(7z|as|bat|bin|cgi|chm|chml|class|cmd|com|command|dat|db|db2|db3|dba|dll|DS_Store|exe|gz|hta|htaccess|htc|htm|html|htx|idc|ini|ins|isp|jar|jav|jav$
    Order Allow,Deny
    Allow from env=whitelist
    Allow from mysalonpage.com
    Allow from 10.38.37.155
    # BEGIN PUBLIC IP
    Allow from 68.150.248.143
    # END PUBLIC IP
    </FilesMatch>

    thank you,
    Tin

    #20681

    AITpro Admin
    Keymaster

    The cause of the problem is that you do not have a blank space between these 2 whitelist rules below:

    SetEnvIf Request_URI "/marketpress/marketpress-includes/js/ajax-cart.js,
    /instagram-slider-widget/assets/js/jquery.flexslider-min.js$" whitelist

    Do these steps:
    1. Go the Plugin Firewall Plugins Script/File Whitelist Text Area.
    2. Edit the whitelist rules that you see in the text area / text box and add a blank space between these whitelist rules below.

    /marketpress/marketpress-includes/js/ajax-cart.js,[add a blank space here between these whitelist rules]/instagram-slider-widget/assets/js/jquery.flexslider-min.js

    3. Click the Save Whitelist Options button.
    4. Click the Plugin Firewall BulletProof Mode Activate button.

    #20682

    AITpro Admin
    Keymaster

    Actually I just noticed you have a duplicate whitelist rule so just delete the duplicate rule.

    #20683

    Tin Hoang
    Participant

    Hi, I added the space and also removed the duplicate rule. Then activated and the sites and WordPress backend are all funky again. Hmmm. This is weird.

    #20684

    AITpro Admin
    Keymaster

    Did you add the space OR remove the duplicate rule?  You want to one or the other and NOT both.  Plugin Firewall whitelist rules MUST be in this format below.  There should only be 1 blank white space between each rule.  You can always just delete all of the whitelist rules, click the Save Whitelist Options button and then let Plugin Firewall AutoPilot Mode add/recreate the whitelist rules automatically and correctly.

    /plugin-folder-name/plugin-script.js, /plugin-folder-name/plugin-script.js, /plugin-folder-name/plugin-script.js
    #20686

    Tin Hoang
    Participant

    Hi, thank you for your response!

    I delete all of the whitelist rules, click the Save Whitelist Options button and clicked the Plugin Firewall BulletProof Mode Activate button. This time everything was fine.

    Thank you very much for your help!
    Tin

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.