No longer receiving email alerts

Home Forums BulletProof Security Pro No longer receiving email alerts

This topic contains 19 replies, has 2 voices, and was last updated by  AITpro Admin 2 months ago.

Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
  • #34340


    For the last several months I haven’t been receiving email alerts from BPS pro. This includes ARQ alerts, security log files and I believe even notices when updates are available. Also, the security log file is no longer being deleted after reaching the set size limit and I think this is related since this problem appeared at about the same time.

    I haven’t changed anything with my setup during this time and all other wordpress emails from the site seem to working fine. Test emails are sent out using the BPS built-in email test.

    Any ideas on how to resolve this?


    AITpro Admin

    The most likely causes for the email problem are:

    1. Your web host Mail server that handles automated emails is bottlenecked or failing.  ie the sendmail service needs to be stopped and restarted.
    2. Your web host has changed something on your host server. ie email config, crons, php.ini file setting, etc.
    3. A plugin or theme is interfering with emails.

    BPS Pro has an email testing feature on the S-Monitor page.  Try deactivating all of your plugins and use the S-Monitor > Simple Email Tests form.  If a plugin is not causing the problem then you will need to contact your web host support and have them check your host server and Mail server for problems



    I’ve used the email testing feature on the S-monitor page. The test emails are received even with all plugins activated.

    Some additional info that might help is that I’m using the Sendgrid plugin which takes over wp_mail() and sends emails from the site over the sendgrid API. So this makes me think the the web host mail server isn’t the issue since it should be bypassed. Everything was working as expected with this setup until a few months ago.

    Also, all other emails from the site seem to be unaffected except anything from BPS.


    AITpro Admin

    Ok so at least you have ruled out that this is a host Mail server issue.  I checked the SendGrid plugin support area and I see at least 2 plugin support forum posts that were posted 1+ months ago where 2 or more people are stating the same problem – that emails are not being sent.  The last SendGrid plugin update was 2 months ago.  Maybe there is a bug in SendGrid plugin version 1.11.7.  Looking at older plugin support forum posts I also see other forum posts that state the same thing.  It looks like SendGrid has some sort of diagnostic/troubleshooting tools/settings.  So check those things and see if there are any indications/messages stating a problem.


    AITpro Admin

    Another likely possibility is that WP Standard Crons have been disabled by your host or something else.  Most BPS Pro email alerts are sent based on scheduled cron jobs.  Check the BPS Pro > Pro-Tools > Scheduled Crons tool.  Also check the BPS Pro System Info page to see if WP standard crons are disabled or not and check the BPS Pro Dashboard Status Display timestamps/cron frequencies.



    Thanks for your attention to this issue. Everything looks ok with the BPS crons and WP standard crons are not disabled. As far as I can tell no other function of BPS is affected and dashboard alerts appear as expected. I’m really pleased with the performance of BPS pro so not having the email alerts isn’t a big concern.

    I saw those posts in the sendgrid plugin support forum so I also suspect it may be a bug in their last update. I’ve continued to try to troubleshoot and play with the sendgrid settings but without any luck. WordPress and other plugins are able to send mail through the sendgrip API so that’s why I wanted to bring the issue up here in case there was something else to look at from the BPS side of things.


    AITpro Admin

    The S-Monitor > Simple Email Tests form is the only email testing tool in BPS.  The only difference between the S-Monitor > Simple Email Tests form code and any other BPS Pro emailing code is that standard WP Cron code is used to send the emails.  Have you checked your Junk or Spam folder on your computer to see if automated email alerts are being junked or spammed?  Maybe your web host is rejecting/blocking/spamming email alerts?



    I’ve checked and the emails aren’t going to spam. Sendgrid is not showing any bounces/blocks/spam reports.

    Since the security log file also isn’t being emailed and deleted as expected I was thinking maybe this was due to the email function not working succesfully. Or would this be a separate issue?


    AITpro Admin

    Yes, it is very possible that the Security Log file not being zipped and replaced with a new blank Security Log file is a separate problem. A common known problem is that if your Security Log file gets extremely large > over 2MB > in a very short period of time then it may not be successfully zipped and replaced. If that problem does occur the solution is to delete the current Security Log zip file and the next time the Security Log Cron job runs the zip, email and replace should work unless there is some other problem occurring that is preventing the Security Log file from being zipped and attached to the automated email. Since the Security Log cron job zips and attaches that zip file to the Security Log email then if the SendGrid plugin is causing that problem then what would need to be looked at would be if the SendGrid plugin does not correctly handle processing the Security Log zip file email attachment. We will try to test the SendGrid plugin on a Local Development server, but it may not work correctly in our Local Development testing environment.


    AITpro Admin

    We have tried to test the SendGrid plugin in our Local Development environment, but unfortunately it does not work in a Local Development environment and requires a Live hosted website.  An alternative option to workaround the Login Security Log file zip attachment and email problem would be to choose this S-Monitor option > Go to the BPS Pro > S-Monitor page > Email Alerting & Log File Options > Security Log File Email|Delete Log File > select Delete Log File > click the Save Options button.  Using this setting will prevent the Security Log File from getting extremely large in size.



    I still haven’t solved the BPS not sending email problem. As you suggested, I set S-Monitor option > Go to the BPS Pro > S-Monitor page > Email Alerting & Log File Options > Security Log File Email|Delete Log File > select Delete Log File instead of email/delete and the logs are being deleted as expected.

    I though the sendgrid plugin may be the issue but I’ve since tested with the sendgrid plugin deactivated but still nothing from BPS (other emails from wordpress were still sent out as expected via the host server) .

    As I mentioned before, I receive the test emails from the S-Monitor test email function but none of the BPS alert emails or update notifications.


    AITpro Admin

    Since you can send emails using the S-Monitor email test tool then there does not appear to be a Mail server configuration problem or other problem occurring with with your Mail server.  Since log files are being deleted successfully then there is not a problem with WP Standard Cron Jobs.  You stated you have checked your email application and emails are not being Junked or Spammed.  I cannot think of any other cause for this type of problem.  Try these basic things below and if they do not work, you will need to contact your web host and work with them to check your Server Log files for clues to the cause of the problem.

    Manually reinstall BPS Pro (You will not lose your BPS Pro plugin settings) 
    1. Use FTP or your web host control panel file manager and delete the /plugins/bulletproof-security/ folder.
    2. Use the WordPress Plugin Upload Zip installer and reinstall the most current BPS Pro zip file.

    Manually reinstall WordPress (Note: put your website in Maintenance Mode while doing these steps)
    1. Use FTP or your web host control panel file manager and delete the wp-admin and wp-includes WP Core folders.  IMPORTANT NOTE:  Do NOT delete the wp-content folder.
    2. Download the WordPress Zip file and unzip it on your computer:
    3. Use FTP and upload the wp-admin and wp-includes WP Core folders.



    Thanks again for the support. I know this is an odd issue without a clear solution. I’ll continue to update this post with any new details I come across just in case.

    I manually reinstalled BPS pro and the issue still persists. A BPS email was sent out when I deleted the /plugins/bulletproof-security/ folder prior to reinstalling. It was sent using php mail () function (which I believe it is designed to do) and all the parameters were set correctly. My email application did mark the email as spam, but the important thing is that it was sent which doesn’t seem to be the case with the wp_mail emails.

    I’ve tried using a different plugin (Post SMTP) for sending wp_mail through the sendgrid API instead of the SendGrid plugin and again all other wordpress emails go through but not anything from BPS (except the S-monitor test emails).

    Something else I noticed: when I go to the Must-Use plugins page and click on the BPS pro MU tools enable/disable link, an error message pops up saying “wp_mail has been declared by another process or plugin, so you won’t be able to use SendGrid until the conflict is solved”.

    Around the same time the email issues started, I remember seeing this error message when going to either wordpress dashboard > updates or the plugins page (I can’t remember which one) but that error stopped happening after either a wordpress or plugin update.


    AITpro Admin

    Should have read your entire forum reply before adding all this Additional Help Info below. 😉 This SendGrid error below pretty much confirms that SendGrid is causing the wp_mail() function conflict/problem. It’s a shame that I cannot test the SendGrid plugin to figure out the problem since it will not work on a Local Development server. Send this SendGrid error message to the SendGrid plugin author and ask where (file and code line) and why this error would be occurring.

    Something else I noticed: when I go to the Must-Use plugins page and click on the BPS pro MU tools enable/disable link, an error message pops up saying “wp_mail has been declared by another process or plugin, so you won’t be able to use SendGrid until the conflict is solved”.

    Additional Help Info
    You could try using this php.ini directive mail.log code below in your custom php.ini file.  It checks to see if mail is being sent successfully and logs the mail Headers in your BPS Security Log file.  Note: I sent a test email via the BPS Pro S-Monitor simple email test form and you can see that wp_mail() also uses the PHP mail() function.  If something else you have installed is intercepting or interfering with the wp_mail() function then you will not see the additional “mail” Header for WP.  There are 2 Headers in the Security Log entry below since the BPS Pro S-Monitor simple email test form tests both standard mail() and wp_mail() email submissions.

    php.ini directive mail.log code:

    ; The path to a log file that will log all mail() calls. Log entries include
    ; the full path of the script, line number, To address and headers.
    mail.log = /path-to-your-BPS-Security-Log-file/wp-content/bps-backup/logs/http_error_log.txt

    BPS Security Log entry for the mail() and wp_mail() S-Monitor simple email test form:

    [403 GET Request: January 22, 2018 - 11:22 am]
    BPS Pro: 13.4
    WP: 4.9.2
    Event Code: PFWR-PSBR-HPRA
    Host Name:
    REQUEST_URI: /wp-content/plugins/bulletproof-security/admin/test/bps-email-check-wp-mail.php
    HTTP_USER_AGENT: WordPress/4.9.2;
    mail() on [/home/content/xxxxx/html/wp-content/plugins/bulletproof-security/admin/monitor/monitor.php:610]:
    To: --
    Headers: MIME-Version: 1.0
    Content-type: text/html; charset=UTF-8
    mail() on [/home/content/xxxxx/html/wp-includes/class-phpmailer.php:698]:
    To: --
    Headers: Date: Mon, 22 Jan 2018 19:22:44 +0000
    From: WordPress <>
    Message-ID: <>
    X-Mailer: PHPMailer 5.2.22 (
    MIME-Version: 1.0
    Content-Type: text/html; charset=UTF-8


    I should have mentioned that the same error message appears on the Must-Use Plugins page when the SendGrid plugin is deactivated and I use the Post SMTP plugin. Except the message reads: wp_mail has been declared by another process or plugin, so you won’t be able to use Post SMTP until the conflict is solved. 

    This makes me think that the problem may be something other than the sendgrid plugin. Also, when I tested without a mail plugin activated the problem was still there. I still need to attempt the other troubleshooting tips you mentioned (manually reinstall wordpress, php.ini directive)

Viewing 15 posts - 1 through 15 (of 20 total)

You must be logged in to reply to this topic.