EntityRef php error

Home Forums BulletProof Security Pro EntityRef php error

Viewing 15 posts - 1 through 15 (of 29 total)
  • Author
  • #2686

    Can someone please explain where i can find the error being reported in my PHP Error Log.

    [08-Mar-2013 19:07:11 UTC] EntityRef: expecting ‘;’ at line 162, column 141

    When i run the test log this next line appears: [08-Mar-2013 19:46:32 UTC] PHP Warning:  copy() [function.copy]: Filename cannot be empty in /home/beesoninc/beesoninc.com/wp-content/plugins/bulletproof-security/admin/php/php-options.php on line 2590

    AITpro Admin

    I Googled the first error and this is what I found.


    I have no idea where that coding error is occurring since the error does not give you a filename.

    Yes, the PHP Error Log test intentionally generates that php error so that you can see that your php error log is working correctly.  😉

    AITpro Admin

    Taking the most logical approach I would say check the source code of your website by using Google Chrome’s debuggers – Developer Tools and JavaScript Console – or use FireFox’s FireBug and FirePHP Add-ons.


    I’ve had to deactivate the Bulletproof security plugin as none of the contact form 7 forms stopped sending the contact details and it must be due to the PHP error log. Does this PHP error log do anything from preventing form functionality as a security measure?

    I still can’t locate this error when going from page to page using Chrome dev tools.

    AITpro Admin

    The PHP Error log just logs php errors.  It does not do anything else besides just logging php errors.  Most likely the cause of the problem is that the Plugin Firewall is blocking Contact Form 7 js plugin scripts.  I believe there are 2 Contact Form 7 plugin scripts that need to be whitelisted in the Plugin Firewall.

    BPS Pro has built-in troubleshooting tools and features.  You do not need to deactivate or delete BPS Pro for troubleshooting.  If you deactivate BPS Pro then you no longer have troubleshooting tools available to you.

    See this Forum Topic on how to use the BPS Pro troubleshooting tools/features:  http://forum.ait-pro.com/forums/topic/read-me-first-pro/#bps-pro-general-troubleshooting

    AITpro Admin

    Have you tried using the WordPress Debugger to find where this code problem exists?

    Add this WordPress Debug code to your wp-config.php file and see if the code error is displayed to you.  If it is then you can then deactivate your plugins one by one and test to find out which plugin is causing this error.

    * For developers: WordPress debugging mode.
    * Change this to true to enable the display of notices during development.
    * It is strongly recommended that plugin and theme developers use WP_DEBUG
    * in their development environments.
    define(‘WP_DEBUG’, true);
    define(‘WP_DEBUG_LOG’, true);
    define(‘WP_DEBUG_DISPLAY’, true);

    AITpro Admin

    Also the most likely cause for the EntityRef error is that one of your plugins is not using a CDATA section as explained in the StackOverflow link I posted above.


    How do i change the wp-config file if i can’t upload it?

    AITpro Admin

    Why would you be unable to upload the wp-config.php file?  Do you mean that if AutoRestore is On while you are uploading a modified file it will be sent to Quarantine?  You can turn AutoRestore Off when you are uploading modified files to your website, then click the AutoRestore Backup Files button before turning AutoRestore back On.  If you forget to click the Backup Files button then the wp-config.php file will be autorestored and sent to Quarantine.  You would then just use the Quarantine Restore File option to restore the modified wp-config.php file.

    You can also edit your wp-config.php file with BPS Pro by using the P-Security File Manager and File Editor.  You can either turn Off AutoRestore while doing this or you can leave AutoRestore On and then when your modified wp-config.php file is autorestored and sent to Quarantine you would use the Quarantine Restore File option to restore your modified wp-config.php file.  Either way/method is fine to do.

    AutoRestore Help Reference Link:  http://forum.ait-pro.com/forums/topic/read-me-first-pro/#autorestore-quarantine


    I’m checking if it is an error on the account side with Dreamhost i’m getting the following error and sent them a support ticket.

    Could not upload “wp-config.php”.
    Server said: wp-config.php: Permission denied
    Error -160: could not start data transfer

    AITpro Admin

    You need to unlock your wp-config.php file if it is locked.  Go to F-Lock and unlock your wp-config.php file.

    I googled the EntityRef error again and the error has something to do with your XML Feed.


    So this narrows down where and which plugin is having the issue/problem.  In the link above the plugin was the Google Analytics plugin.  Most likely the error has to do with an XML file so you want to check your Feed first.

    And another link relating to an RSS Feed XML EntityRef error.



    The rss Feed xml shouldn’t prevent the forms on the site not to go through though would it?

    AITpro Admin

    No, this would not have anything at all to do with your Contact Form.  It is a different problem with another plugin that you have installed.


    We have forms on most pages. Once submitted they should have been going to an email address. Sometimes they wouldn’t reach there destination but once i had cleared the php error log they worked again. Might have been a coincidence, so i have been trying to find what that error could mean and if it is related to the forms.

    AITpro Admin

    The Contact Form 7 plugin scripts that are being blocked by the Plugin Firewall will be logged in your BPS Security Log file.

    See this Forum Topic:  http://forum.ait-pro.com/forums/topic/security-log-http-error-log-read-me-first/

Viewing 15 posts - 1 through 15 (of 29 total)
  • You must be logged in to reply to this topic.