Plugin Firewall – BPS menu tabs not displaying correctly, visual format is broken, CSS format is broken

Home Forums BulletProof Security Pro Plugin Firewall – BPS menu tabs not displaying correctly, visual format is broken, CSS format is broken

This topic contains 32 replies, has 6 voices, and was last updated by  Immerse 1 year, 4 months ago.

Viewing 15 posts - 1 through 15 (of 33 total)
  • Author
    Posts
  • #6264

    AITpro Admin
    Keymaster

    See the newest/most current list of possible causes and solutions for Plugin Firewall issues/problems here: https://forum.ait-pro.com/forums/topic/plugin-firewall-read-me-first-troubleshooting/#common-pfw-problems

    Email Question:

    Hello I am writing you because I am me insight when I enabled the firewall, I lost the tabs to pages BPS and also the pages of one of my plug-ins. All pages are each other down without layout.
    I send you a screenshot for you to understand my problem.
    Thank you in advance.

    Screenshots

    Plugin Firewall Invalid Whitelist Rules

     

    Plugin Firewall Invalid Whitelist Rules

    #6270

    AITpro Admin
    Keymaster

    OLDER Problem that should no longer occur anymore with the addition of AutoPilot Mode, which should automatically fix this problem:  This problem is caused by having invalid Whitelist rules in your Plugin Firewall .htaccess file.  See the newest/most current list of possible causes and solutions for Plugin Firewall issues/problems here: http://forum.ait-pro.com/forums/topic/plugin-firewall-read-me-first-troubleshooting/#common-pfw-problems

    1.  Check the
    2.  The format for plugin scripts in your Plugin Firewall Whitelist Text area is:

    /plugin-folder-name/plugin-script-name.js, /plugin-folder-name/plugin-script-name.js, /plugin-folder-name/plugin-script-name.js

    Plugin scripts MUST follow this format above and each plugin script MUST be separated by a comma and a single space.
    3.  If you see the /bulletproof-security/admin/js/bulletproof-security-admin-3.js in your Plugin Firewall Whitelist Text area then delete the BPS Pro js script (as of BPS Pro 5.9 this BPS Pro js script is automatically stripped out of the Plugin Firewall Whitelist Text area).
    4.  After correcting/removing any invalid plugin scripts in your Plugin Firewall Whitelist Text Area click the Save Whitelist Options button and activate the Plugin Firewall again.

    #10435

    Don
    Participant

    On every BPS Pro page the “read me” windows are included in the main display, the buttons extend across the width of the window, and the display is generally messed up.  I see no javascript errors.

    I am running Firefox 24, and am not blocking and scripts, etc on this website.

    I could send screen-shot if that would help explain what I am seeing.

    #10436

    Don
    Participant

    Solved:  This problem is caused by the BPS Plugin Firewall.

    #10439

    AITpro Admin
    Keymaster

    See the newest/most current list of possible causes and solutions for Plugin Firewall issues/problems here: http://forum.ait-pro.com/forums/topic/plugin-firewall-read-me-first-troubleshooting/#common-pfw-problems
    Duplicate issue/problem – Topic merged.

    #10440

    AITpro Admin
    Keymaster

    See the newest/most current list of possible causes and solutions for Plugin Firewall issues/problems here: http://forum.ait-pro.com/forums/topic/plugin-firewall-read-me-first-troubleshooting/#common-pfw-problems

    #28084

    stefano
    Participant

    hi
    just after updating to wp 4.2.2 bps pages are all corrupted. I checked the plugin whitelist and everything looks normal. what’s going on? The log says:

    [403 GET Request: 04/02/2016 - 10:41 am]
    Event Code: PFWR-PSBR-HPR
    Solution: http://forum.ait-pro.com/forums/topic/security-log-event-codes/
    REMOTE_ADDR: 80.82.2.43
    Host Name: 80.82.2.43
    SERVER_PROTOCOL: HTTP/1.1
    HTTP_CLIENT_IP:
    HTTP_FORWARDED:
    HTTP_X_FORWARDED_FOR: 10.79.4.200
    HTTP_X_CLUSTER_CLIENT_IP:
    REQUEST_METHOD: GET
    HTTP_REFERER: http://ilcappellopensatore.it/wp-admin/admin.php?page=bulletproof-security/admin/tools/tools.php
    REQUEST_URI: /wp-content/plugins/bulletproof-security/admin/js/bps-ui-dialog.js?ver=4.4.2
    QUERY_STRING:
    HTTP_USER_AGENT: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/48.0.2564.97 Safari/537.36
    
    [403 GET Request: 04/02/2016 - 10:41 am]
    Event Code: PFWR-PSBR-HPR
    Solution: http://forum.ait-pro.com/forums/topic/security-log-event-codes/
    REMOTE_ADDR: 80.82.2.43
    Host Name: 80.82.2.43
    SERVER_PROTOCOL: HTTP/1.1
    HTTP_CLIENT_IP:
    HTTP_FORWARDED:
    HTTP_X_FORWARDED_FOR: 10.79.4.200
    HTTP_X_CLUSTER_CLIENT_IP:
    REQUEST_METHOD: GET
    HTTP_REFERER: http://ilcappellopensatore.it/wp-admin/admin.php?page=bulletproof-security/admin/tools/tools.php
    REQUEST_URI: /wp-content/plugins/bulletproof-security/admin/js/bps-ui-tabs.js?ver=4.4.2
    QUERY_STRING:
    HTTP_USER_AGENT: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/48.0.2564.97 Safari/537.36
    
    [403 GET Request: 04/02/2016 - 10:41 am]
    Event Code: PFWR-PSBR-HPR
    Solution: http://forum.ait-pro.com/forums/topic/security-log-event-codes/
    REMOTE_ADDR: 80.82.2.43
    Host Name: 80.82.2.43
    SERVER_PROTOCOL: HTTP/1.1
    HTTP_CLIENT_IP:
    HTTP_FORWARDED:
    HTTP_X_FORWARDED_FOR: 10.79.4.200
    HTTP_X_CLUSTER_CLIENT_IP:
    REQUEST_METHOD: GET
    HTTP_REFERER: http://ilcappellopensatore.it/wp-admin/admin.php?page=bulletproof-security/admin/tools/tools.php
    REQUEST_URI: /wp-content/plugins/bulletproof-security/admin/js/bps-ui-accordion.js?ver=4.4.2
    QUERY_STRING:
    HTTP_USER_AGENT: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/48.0.2564.97 Safari/537.36
    #28086

    AITpro Admin
    Keymaster

    See the newest/most current list of possible causes and solutions for Plugin Firewall issues/problems here: http://forum.ait-pro.com/forums/topic/plugin-firewall-read-me-first-troubleshooting/#common-pfw-problems

    @ stefano – Do these steps below and let me know if the problem is fixed or not:

    Fix all general Plugin Firewall issues/problems:
    1. Go to the BPS Security Log page and click the Delete Log button to delete your current Security Log file contents.
    2. Go to the Plugin Firewall page.
    3. Click the Plugin Firewall BulletProof Mode Deactivate button.
    4. Delete (or cut if you want to add your existing whitelist rules back into the Plugins Script|File Whitelist Text Area) all of your Plugin Firewall whitelist rules out of the Plugins Script|File Whitelist Text Area.
    5. Click the Save Whitelist Options button.
    6. Click the Plugin Firewall Test Mode button.
    7. Check your site pages by clicking on all main website pages: contact form page, home page, login page, etc.
    8. Recheck the Plugins Script|File Whitelist Text Area (after 1 minute) and you should see new Plugin Firewall whitelist rules have been created.
    9. Change the AutoPilot Mode Cron Check Frequency to 15 minutes or whatever frequency time you would like to use.
    10. Click the Plugin Firewall Activate button.

    #28184

    Steve Smo
    Participant

    I am going to jump in, I am having the same problem.  I went through the steps above and it fixed a few other issues, I had to manually add some stuff the AP cron missed.  The PWF is killing a few JS files for BPS.  I did not know this, but I added them to the whitelist and it fixed the issue but then noticed you cant add BPS files to the whitelist.

    I still have the same issue as the guy above…looks like a visual UI issue or CSS but the same files are being logged in my security log too.  I have tried it all!

    Let me know next steps (I also sent an email), below are clips of the same files that are being 403ed

    <div>REQUEST_METHOD: GET</div>
    <div>HTTP_REFERER: http://www.stoneroadmedia.com/wp-admin/admin.php?page=bulletproof-security/admin/security-log/security-log.php</div>
    <div>REQUEST_URI: /wp-content/plugins/bulletproof-security/admin/js/bps-ui-tabs.js</div>
    <div>QUERY_STRING:</div>
    <div></div>
    <div>
    <div>REQUEST_METHOD: GET</div>
    <div>HTTP_REFERER: http://www.stoneroadmedia.com/wp-admin/admin.php?page=bulletproof-security/admin/security-log/security-log.php</div>
    <div>REQUEST_URI: /wp-content/plugins/bulletproof-security/admin/js/bps-ui-accordion.js</div>
    <div>QUERY_STRING:</div>
    </div>
    <div></div>
    <div>
    <div>REQUEST_METHOD: GET</div>
    <div>HTTP_REFERER: http://www.stoneroadmedia.com/wp-admin/admin.php?page=bulletproof-security/admin/security-log/security-log.php</div>
    <div>REQUEST_URI: /wp-content/plugins/bulletproof-security/admin/js/bps-ui-dialog.js</div>
    <div>QUERY_STRING:</div>
    </div>
    #28185

    stefano
    Participant

    Actually I solved the issue.

    Tips from AITProAdmin and waiting a couple of hours to reset the cache made the trick

    #28187

    Steve Smo
    Participant

    I have tried all of the above and more that I know.  I am not running any caching software in wordpress.  Any other advice.

     

    #28190

    AITpro Admin
    Keymaster

    See the newest/most current list of possible causes and solutions for Plugin Firewall issues/problems here: http://forum.ait-pro.com/forums/topic/plugin-firewall-read-me-first-troubleshooting/#common-pfw-problems

    Go to Setup> UI|UX and try turning on Script|Style Loader Filter (SLF) In BPS Plugin Pages to On. Let me know what happens.

    #28191

    Steve Smo
    Participant

    I was going to turn that on and noticed I had TABS again…I did nothing all day to the this site and it is working now.  It fixed itself?

    Since I like to learn all I can…what do you think fixed it and how?

    Last thing I did about 9 hours ago was add the BPS files to the white list, got the error and removed them…and then it went back to looking bad…and showing the x3 403 errors.

    Thanks
    Steve

    #28205

    AITpro Admin
    Keymaster

    Ok send an Administrator login to the site to:  edward at a-pro dot com.  Thanks

    #30901

    Pako
    Participant

    Hi

    Tried: http://forum.ait-pro.com/forums/topic/plugin-firewall-bps-menu-tabs-not-displaying-correctly-visual-format-is-broken-css-format-is-broken/#post-28086
    And that: http://forum.ait-pro.com/forums/topic/plugin-firewall-bps-menu-tabs-not-displaying-correctly-visual-format-is-broken-css-format-is-broken/#post-28205

    No changes… : BPS UI is totaly broken and security logs full of errors about:

    • /wp-content/plugins/bulletproof-security/admin/js/bps-ui-tabs.js
    • /wp-content/plugins/bulletproof-security/admin/js/bps-ui-dialog.js
    • /wp-content/plugins/bulletproof-security/admin/js/bps-ui-accordion.js

    The only way for me was to deactivate PFW… 🙁

Viewing 15 posts - 1 through 15 (of 33 total)

You must be logged in to reply to this topic.