CloudFlare Security Log errors, Broken BPS Pro pages, menus

Home Forums BulletProof Security Pro CloudFlare Security Log errors, Broken BPS Pro pages, menus

Tagged: 

This topic contains 1 reply, has 2 voices, and was last updated by  AITpro Admin 5 years, 9 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #12342

    Remco
    Participant

    Hi,

    I was installing and configuring Cloudflare on my website. For Cloudflare I had to change my DNS and after the registrar was done I was able to connect W3TC with Cloudflare. Everything seemed to be working.

    Then I got the Security Error, for example:

    >>>>>>>>>>> 403 GET or HEAD Request Error Logged - 10 januari 2014 - 20:54 <<<<<<<<<<<
    REMOTE_ADDR: 173.245.53.235
    Host Name: cf-173-245-53-235.cloudflare.com
    SERVER_PROTOCOL: HTTP/1.1
    HTTP_CLIENT_IP:
    HTTP_FORWARDED:
    HTTP_X_FORWARDED_FOR: 83.85.62.220
    HTTP_X_CLUSTER_CLIENT_IP:
    REQUEST_METHOD: GET
    HTTP_REFERER: http://cyberpark.nl/wp-admin/admin.php?page=bulletproof-security%2Fadmin%2Fsecurity-log%2Fsecurity-log.php&settings-updated=true
    REQUEST_URI: /wp-content/plugins/wordpress-seo/js/wp-seo-admin-global.js
    QUERY_STRING:
    HTTP_USER_AGENT: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0

    Also the BPS Pro layout is broken as described similar elsewere on the site. I checked CSS of JS conflicts but cannot find that easily. I’m thinking how cloudflare could interupt the BPS protocol. Maybe because their server brings the website back with their IP? The ERROR will not go away after clearing the message. It will show a new one immediately.

    The example above comes in these other forms with the following request URI:

    /wp-content/plugins/enhanced-media-library//js/eml-media-uploader.js
    wp-content/plugins/bulletproof-security/admin/js/bulletproof-security-admin-4.js
    /wp-content/plugins/enhanced-media-library//js/eml-media-uploader.js

    I disabled some plugins but no positive results on the broken problem.

    Any thoughts?

    #12343

    AITpro Admin
    Keymaster

    The issue/problem is most likely going to be occurring with the Plugin Firewall if this is in fact an issue between CloudFlare and BPS Pro.  We are aware of some minor issues and problems with CloudFlare. BPS Pro 8.2 (tentative release date is 3 to 6 days) fixes all of those minor issues/problems with CloudFlare.  There is a good chance that the issues are actually between W3TC and CloudFlare.

    We do have a testing site that is using CloudFlare and there are no issues and everything is working perfectly so BPS Pro and CloudFlare do work fine together.  I believe all that was required on that testing site was to delete the Plugin Firewall and resave settings and then activate the Plugin Firewall again.  There is one other very unusual issue/problem with CloudFlare code being injected into the Source Code of the BPS Pro AutoRestore page, but that issue/problem does not happen on the testing site below so on the 1 site where we did see this happening there were probably other CloudFlare settings in use or some other additional factors involved.

    Testing site with BPS Pro and CloudFlare
    http://bulletproof-security-pro.com/bpspro/

    Do Step 3 in the BPS Pro Troubleshooting steps in the link below and then confirm that the issue is with the Plugin Firewall.  We do have a workaround if the issue/problem is with CloudFlare causing Plugin Firewall to malfunction.

    http://forum.ait-pro.com/forums/topic/read-me-first-pro/#bps-pro-general-troubleshooting

    3. On the Security Modes page, click the Plugin Firewall BulletProof Mode Deactivate button.

     

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.