The update cannot be installed because we will be unable to copy some files. This is usually due to inconsistent file permissions.: wp-cron.php

Home Forums BulletProof Security Pro The update cannot be installed because we will be unable to copy some files. This is usually due to inconsistent file permissions.: wp-cron.php

This topic contains 9 replies, has 3 voices, and was last updated by  AW 2 years, 3 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #12417

    AITpro Admin
    Keymaster

    Email Question – General WordPress Question unrelated to BPS Pro

    Hi again.

    I have one issue when upgrading to latest wp on one site and wonder if it’s PBS blocking wp to update? I’ve no problems updating plugins and everything is working just fine.

    Downloading update from https: //wordpress.org/wordpress-3.8-new-bundled.zip…
    Unpacking the update…
    Verifying the unpacked files…
    Preparing to install the latest version…
    The update cannot be installed because we will be unable to copy some files. This is usually due to inconsistent file permissions.: wp-cron.php
    Installation Failed

    I’ve searched this issue online and not found any solution that works, even tried to change permission which is 777 but no success.
    Any ideas what might be the issue and how to solve it?

    #12420

    AITpro Admin
    Keymaster

    The WordPress install error check is telling you specifically which file has the problem:  wp-cron.php.  Check the wp-cron.php file permissions using either FTP or your Web Host Control Panel File Manager.  The wp-cron.php file should have 644 file permissions.  If the wp-cron.php file permissions are not 644 then change the file permissions to 644.

    #12423

    AITpro Admin
    Keymaster

    Email Response:

    Before I contacted you I did change the permission to 644 through FTP, for some reason it is stuck on 777. I just renamed the file and the upgrade went through without any issue, then changed the file name back to its original name and it is working just fine.

    #15079

    Sydney Richards
    Participant

    Hi;

    I have been pulling out what little hair I have left. I cannot update to the latest WP 3.9. I have checked to make sure that the file permissions.: wp-cron.php was set at 644 and it was.

    I have copied the entire file below hoping someone can tell me how to fix this.

    Syd at-  pinnacle1ventures @ gmail.com

    <div class="wrap">
    <h2>Update WordPress</h2>
    Downloading update from <span class="code">https://downloads.wordpress.org/release/wordpress-3.9.zip</span>…
    
    Unpacking the update…
    
    Verifying the unpacked files…
    
    Preparing to install the latest version…
    
    The update cannot be installed because we will be unable to copy some files. This is usually due to inconsistent file permissions.: wp-admin/js/revisions.min.js, wp-admin/js/revisions.js, wp-admin/js/svg-painter.min.js, wp-admin/css/install-rtl.min.css, wp-admin/css/colors/blue/colors-rtl.css, wp-admin/css/colors/blue/colors.scss, wp-admin/css/colors/blue/colors.min.css, wp-admin/css/colors/blue/colors-rtl.min.css, wp-admin/css/colors/blue/colors.css, wp-admin/css/colors/ectoplasm/colors-rtl.css, wp-admin/css/colors/ectoplasm/colors.scss, wp-admin/css/colors/ectoplasm/colors.min.css, wp-admin/css/colors/ectoplasm/colors-rtl.min.css, wp-admin/css/colors/ectoplasm/colors.css, wp-admin/css/colors/sunrise/colors-rtl.css, wp-admin/css/colors/sunrise/colors.scss, wp-admin/css/colors/sunrise/colors.min.css, wp-admin/css/colors/sunrise/colors-rtl.min.css, wp-admin/css/colors/sunrise/colors.css, wp-admin/css/colors/midnight/colors-rtl.css, wp-admin/css/colors/midnight/colors.scss, wp-admin/css/colors/midnight/colors.min.css, wp-admin/css/colors/midnight/colors-rtl.min.css, wp-admin/css/colors/midnight/colors.css, wp-admin/css/colors/light/colors-rtl.css, wp-admin/css/colors/light/colors.scss, wp-admin/css/colors/light/colors.min.css, wp-admin/css/colors/light/colors-rtl.min.css, wp-admin/css/colors/light/colors.css, wp-admin/css/colors/_mixins.scss, wp-admin/css/colors/_admin.scss, wp-admin/css/colors/ocean/colors-rtl.css, wp-admin/css/colors/ocean/colors.scss, wp-admin/css/colors/ocean/colors.min.css, wp-admin/css/colors/ocean/colors-rtl.min.css, wp-admin/css/colors/ocean/colors.css, wp-admin/css/colors/coffee/colors-rtl.css, wp-admin/css/colors/coffee/colors.scss, wp-admin/css/colors/coffee/colors.min.css, wp-admin/css/colors/coffee/colors-rtl.min.css, wp-admin/css/colors/coffee/colors.css, wp-admin/includes/class-wp-upgrader-skins.php, wp-admin/images/w-logo-white.png, wp-admin/images/spinner-2x.gif, wp-admin/images/post-formats.png, wp-admin/images/w-logo-blue.png, wp-admin/images/spinner.gif, wp-includes/js/heartbeat.min.js, wp-includes/js/wp-util.min.js, wp-includes/js/wp-auth-check.min.js, wp-includes/js/wp-backbone.min.js, wp-includes/js/mediaelement/mediaelementplayer.min.css, wp-includes/js/mediaelement/flashmediaelement.swf, wp-includes/js/mediaelement/wp-mediaelement.js, wp-includes/js/mediaelement/mediaelement-and-player.min.js, wp-includes/js/mediaelement/wp-mediaelement.css, wp-includes/js/heartbeat.js, wp-includes/js/wp-backbone.js, wp-includes/css/dashicons.min.css, wp-includes/css/wp-auth-check.min.css, wp-includes/css/wp-pointer-rtl.css, wp-includes/css/editor-rtl.min.css, wp-includes/css/wp-auth-check-rtl.min.css, wp-includes/css/jquery-ui-dialog-rtl.min.css, wp-includes/css/dashicons.css, wp-includes/css/buttons-rtl.min.css, wp-includes/css/wp-pointer-rtl.min.css, wp-includes/css/wp-auth-check-rtl.css, wp-includes/css/jquery-ui-dialog-rtl.css, wp-includes/css/editor-rtl.css, wp-includes/css/buttons-rtl.css, wp-includes/css/wp-auth-check.css, wp-includes/date.php, wp-includes/images/spinner-2x.gif, wp-includes/images/spinner.gif, wp-includes/fonts/dashicons.woff, wp-includes/fonts/dashicons.svg, wp-includes/fonts/dashicons.ttf, wp-includes/fonts/dashicons.eot, wp-includes/revision.php, wp-includes/certificates/ca-bundle.crt
    
    Installation Failed
    #15083

    AITpro Admin
    Keymaster

    The error message says that there is probably a folder or file permission problem with the /wp-admin folder, /wp-includes folder and / or files in these folders.  Check that these folders have 755 folder permissions.  Check that the file permssions for files in these folders is 644 file permissions.

    http://wordpress.org/support/topic/cannot-update-5?replies=3

    #33523

    AW
    Participant

    I have few sites installed with BPS and manage to update to Version 13 ( update via click “update now” on plugins WP )
    However, there’s 1 site just could not update.
    Once when i click the “update now”, then it shows ” Update Failed: Plugin update failed.”
    I dont know whether is becos the wp-cron.php thingy…i checked and it was 644.
    Please advise.
    If you do need my admin for wp, do let me know.
    Thanks.
    Regards,
    Alex

    #33524

    AITpro Admin
    Keymaster

    @ AW – Deactivate all of your other plugins and then try to update BPS Pro.

    #33525

    AW
    Participant

    Hi,

    1. Tried, deactivated all plugins…> click update via plugins,…same result > fail
    2. Tried, deactivated all plugins…> Unlock wp-config and htaccess in F-Lock …. click update via plugins,…same result > fail
    #33526

    AITpro Admin
    Keymaster

    @ AW – Ok then just use the manual BPS Pro upgrade method for this particular website: https://forum.ait-pro.com/forums/topic/bulletproof-security-pro-bps-pro-upgrade-installation-methods/

    #33527

    AW
    Participant

    Awesome !
    Done and thanks!
    Regards,
    Alex

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.