Cannyon Theme Photo Gallery – 403 error, UAEG

Home Forums BulletProof Security Pro Cannyon Theme Photo Gallery – 403 error, UAEG

This topic contains 4 replies, has 2 voices, and was last updated by  Mike 10 months, 1 week ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #33667

    Mike
    Participant

    I am not sure what this is causing this so I am posting to see if anyone has seen this before and perhaps has a solution.

    BPS does not find an .htaccess file on uploads.   Sure enough I do not have one – and I am not sure how to properly create one.  It appears that the directory is protected without this file. So without an htaccess file in uploads – when I enable UAEG my website galleries stop functioning completely.  Page edits, do not work to correct this problem either.

    When reading the instructions it says to copy my entire htaccess file in my uploads directory following the custom code setups.   Since I do not have this file I am not even sure if I create one whether this will resolve my issue.

    The website works fine without UAEG enabled.   What kind of security problems could I have with this disabled – and is this something to worry about?

    I am using the cannyon word press theme on this site.   http://action1restoration.com

    Thanks –

    Best Regards,

    mike@nimaway.com

    #33668

    AITpro Admin
    Keymaster

    Go to your BPS Security Log and copy and paste the Security Log entry that shows what is being blocked.

    Theme name: Cannyon – Premium Multipurpose WordPress Theme.

    #33670

    Mike
    Participant

    This is what I see in the security log

    [403 GET Request: July 16, 2017 - 10:23 am]
    BPS Pro: 13.1
    WP: 4.8
    Event Code: UAEGWR-HPRA
    Solution: https://forum.ait-pro.com/forums/topic/uploads-anti-exploit-guard-uaeg-read-me-first/
    REMOTE_ADDR: 107.77.75.119
    Host Name: 107.77.75.119
    SERVER_PROTOCOL: HTTP/1.1
    HTTP_CLIENT_IP:
    HTTP_FORWARDED:
    HTTP_X_FORWARDED_FOR:
    HTTP_X_CLUSTER_CLIENT_IP:
    REQUEST_METHOD: GET
    HTTP_REFERER: http://www.action1restoration.com/
    REQUEST_URI: /wp-content/uploads/bb-plugin/cache/156-layout.js?ver=04daad436d38bc1713802051b17b2d1f
    QUERY_STRING: ver=04daad436d38bc1713802051b17b2d1f
    HTTP_USER_AGENT: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.66 Safari/537.36
    #33672

    AITpro Admin
    Keymaster

    Your Cannyon theme has the Beaver Builder plugin bundled into the Theme.  See this forum topic for the solution:  https://forum.ait-pro.com/forums/topic/beaver-builder-plugin/#post-32715

    #33673

    Mike
    Participant

    I will give it a try.   Thanks for the response.   BPS shows I have no htaccess file in uploads.  So there is nothing to copy there.  This is the first time I have seen a theme not put one there.  I will do some edits and see if I can get this to work.   Appreciate the help.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.