500 Internal Server Error

Home Forums BulletProof Security Free 500 Internal Server Error


Viewing 15 posts - 16 through 30 (of 47 total)
  • Author
  • #10894
    AITpro Admin

    My guess is that you may have added the Speed Boost Cache to a wp-admin Custom Code text box instead of the correct Root Custom Code text box. Check all of your Custom Code text boxes and remove any custom code that is in the wrong places.  Delete your root and wp-admin .htaccess files if you are currently unable to login to your site and then check your Custom Code text boxes before clicking the Activate buttons again.

    AITpro Admin

    Activity Stream Update copied into this topic

    BuddyPress update posts do not send emails – please post replies in the Forum Topic

    I received this response to my problem: Check all of your Custom Code text boxes and remove any custom code that is in the wrong places. I have compared all of the text on the left part of the screen with the right part of the screen in the ”Custom Text” area. It all matches. I don’t know how else to tell if the custom code is incorrect.

    AITpro Admin

    Remove all custom code from all Custom Code text boxes and save it to a Notepad text file on your computer, click the Save Root Custom Code button, go to the BPS Security Modes page and click the Root Folder BulletProof Mode Activate button.  This will tell you whether or not the problem is with custom code that was added.  Do you see a 500 error?



    I’m experiencing a similar problem. It was working fine, then I moved my website to an Amazon EC2 instance, then I deleted the .htaccess, clicked on “Create secure .htaccess File” and then Activated it. Now I get that Internal Server Error.

    It does work with the a default .htaccess, but if I activate the secure one, I get the 500 error. Do you think that it may be due to something that I didn’t activate in Apache?

    Here’s my server info:

    Host by Address: ip-10-244-17-169.ec2.internal
    DNS Name Server:
    Server Type: Apache/2.4.6 (Ubuntu)
    Operating System: Linux
    Server API: apache2handler – Your Host Server is using DSO
    WP Permalink Structure: /%postname%
    Custom Permalinks: √ Custom Permalinks are in use

    The only custom permalinks that I have is:

    # If you want to allow HEAD Requests use BPS Custom Code and 
    # remove/delete HEAD| from the Request Method filter.
    # The TRACE, DELETE, TRACK and DEBUG Request methods should never be removed.
    RewriteRule ^(.*)$ - [F]

    Let me know if you need any other information.

    AITpro Admin

    Your custom permalink is invalid. Your are missing the trailing slash:  /%postname%/

    This may or not be related, but either way that permalink needs to be fixed.

    There are many different things that can cause a 500 error and they can be completely different things on different Servers.  Try to comment out these 2 things first in your root .htaccess file.

    # If you are getting 500 Errors when activating BPS then comment out Options -Indexes
    # by adding a # sign in front of it. If there is a typo anywhere in this file you will also see 500 errors.
    #Options -Indexes
    # Use index.php as default directory index file
    # index.html will be ignored will not load.
    #DirectoryIndex index.php index.html /index.php

    Check the permission of the root .htaccess file and change it to 644 permissions if it is not 644 permissions.

    Download your root .htaccess file and manually edit it and comment out blocks of code until you find which code is causing the problem.




    Thanks for the response. I’ve resolved that by editing apache2.conf

    <Directory /var/www/>

    The AllowOverride had only FileInfo. I’ve added Options Limit and Indexes.

    It’s all good now =).
    Thank you!


    This morning I saw an error that BPS was not protecting the site and I needed to activate it (it has been running for over a year). When I try to “Activate Website Root Folder .htaccess Security Mode”, I get the 500 error. I then delete the htaccess file from the root folder (via cpanel) in order to login again.

    I have tried the steps in the troubleshooting area, but nothing seems to be working. What info can I send to help work through this?

    AITpro Admin

    @ Darryl – your Post has been merged into this relevant Topic

    Try Deactivating Root Folder BulletProof Mode first to see if your Server still allows .htaccess files.

    Copy any Custom Code out of all of the Custom Code text boxes and save it in a Notepad text file on your computer.  Then delete all code in any Custom Code text boxes, click the Save Root Custom Code button and go to the BPS Security Modes page and click the Root Folder BulletProof Mode Activate button.

    Check the permissions of the root .htaccess file – your particular Server may not allow locking of the root .htaccess file.
    Try commenting out the Options directive in your root .htaccess file.


    Other common causes for 500 errors


    Thank you. I had tried most of these already, but the thing that fixed it was removing the custom code:

    php_value upload_max_filesize 32M
    php_value post_max_size 32M
    php_value max_execution_time 300
    php_value max_input_time 300

    All seems to be well again – thank you!

    AITpro Admin

    We need to add that as a standard check on the main BPS Read Me first Forum Topic and change or add a logical progression of things to check.  What most likely occurred is that your Host changed your Server type or upgraded your Server and the php_value and php_flag directives are not valid/allowed for the new Server type that you are currently using.


    Thanks again – very helpful.


    I am having the same problem, I receive a 500 error after activating root folder BPS.  It does not occur when admin folder is BPS enabled. I have checked  the troublehshooting page, checked hotlink protection (currently disabled / no code shown), commented out #Options -Indexes, as well as commented out #DirectoryIndex index.php index.html /index.php  The server does run CGI, not DSO.

    This problem has only started occurring in the last couple of updates. I have scanned through the htaccess and do not see any typos. the site is at realtyevolved.net. I have also uninstalled, deleted all htaccess/subfolder htaccess files as well for a “clean” reinstall. I resaved permalink structure. No new plugins have been installed since the last several updates either and was working previously.  Any help you can provide would be great.


    AITpro Admin

    Try this next.  Use FTP or your web host control panel file manager and change the file permissions of the root .htaccess file to 644 file permissions.


    Have tried file permissions and does not work. Also went into BPS settings to unlock and check htaccess was writable. Also tried deleting by ftp before creating new secure htaccess.

    Also note when the “failed” secure htaccess BPS mode is enable for the root folder, the WP dashboard reloads in all text (missing graphics, etc). Any further action results in a 500 error within admin panel, whereas the public site is 500 immediately.

    AITpro Admin

    I see that your Host is BlueHost and there was an old issue with the Cloudflare service that is bundled with BlueHost, but I am not sure if that is still an issue or not.  This forum topic is dated:  January 30, 2013 http://forum.ait-pro.com/forums/topic/cloudflare-cloudflare-htaccess-code/#post-1569 so this may not be an issue anymore, but then again it may be the problem.

    Are you using Cloudflare?

Viewing 15 posts - 16 through 30 (of 47 total)
  • You must be logged in to reply to this topic.