500 Internal Server Error

Home Forums BulletProof Security Free 500 Internal Server Error


Viewing 15 posts - 31 through 45 (of 47 total)
  • Author
  • #13570

    Cloudflare is not currently enabled.

    AITpro Admin

    Ok good, one less possible thing to factor into the equation.

    Do these steps and let me know the results:
    Delete the .htaccess file in your website root folder and the .htaccess file in your wp-admin folder.  Can you login to your website?  Is the frontend and backend displaying normally?
    If so, go to BPS Custom Code and cut (not copy) any custom .htaccess code that you have added to any Custom Code text boxes and save it to a Notepad text file on your computer.
    Click the Save Root Custom Code button.
    Go to the BPS Security Modes page and click the Root Folder BulletProof Mode Activate button.

    Is your site still displaying correctly on the frontend and backend?

    AITpro Admin

    Ok I see that your site is up and looking at the Source Code of your website the only unusual thing I see is that you are using a plugin called WordPress Data Guard Lite.   I doubt that copy protection plugin would be a factor, but I will give it a test drive.  And yeah anyone who is savvy can get around copy protection plugins. 😉

    <script type="text/javascript" src="http://realtyevolved.net/wp-content/plugins/wordpress-data-guards/wpdg.js"></script> <script type="text/javascript">
    function disableSelection(target){
    if (typeof target.onselectstart!="undefined")
    target.onselectstart=function(){return false;}
    else if (typeof target.style.MozUserSelect!="undefined")
    target.onmousedown=function(){return false}
    target.style.cursor = "default";
    }</script> <script type="text/javascript">
    $(document).bind("cut copy paste",function(e){
    </script><!-- WordPress Data Guard Lite -->

    Front end and backend admin worked with only deleting the root htaccess.

    I used cut and pasted into notepad++  (I previously used copy when I was troubleshooting).

    I noticed that several characters were inserted into the code in one of the sections that shouldn’t have been there. These characters were only viewable when using the Cut (not copy).

    I removed invalid characters and reinserted custom code via copy and it now seems to be working. Guessing the invalid characters were the reason why the 500 was occurring, but mystified as to why they didn’t show up before when viewing the htaccess directly via ftp, BPS custom code, or BPS file editor(?) I’ll have to add to notes, but the characters were only caught using cut and not copy….

    Otherwise, thanks, all seems to be working now!


    AITpro Admin

    Great Job!

    Yep, if even 1 character is not valid .htaccess code then the sky will fall on your head. 😉  The same is true of PHP and other code.  Just the way it is.  Thanks for confirming that things are working now.

    AITpro Admin

    Oh and one other thing I wanted to point out that I noticed while checking your site out.  You have the Theme My Login plugin installed.  Theme My Login Login Security overrides BPS Login Security, but some BPS Login Security features will still work.  I had been meaning to post this in this Forum so I just created this Forum Topic below.



    Hello everybody,

    I had the same problem with the 500 Internal Server Error, afther push the button of BPS “Root Folder Bullet Proof mode”, but I found my solution. Maybe this will help:

    1. After BPS install the .htaccess, you should open this file with Notepad ++.
    2. Follow the instruction with adding the # in front of  “Options -Indexes” and “DirectoryIndex index.php index.html /index.php”, as example:

    # Options -Indexes
    # DirectoryIndex index.php index.html /index.php

    3. I also delete all my database name in this file and “/”, for example: RewriteBase /mydatabasename/
    will be: RewriteBase /
    and: RewriteCond %{REQUEST_URI} ^/mydatabasename/wp-content/plugins/adminer/ [NC]
    will be: RewriteCond %{REQUEST_URI} ^/wp-content/plugins/adminer/ [NC]
    and so on…

    This will correct the url path directly to my internal pages. Hope this will help. Success!


    I hope this is an easy fix, I shouldn’t even be messing with this stuff and think I screwed up pretty bad…uggg

    So, I needed to increase my upload size so I went the the custom php.ini section and added code to do that.  I came across a way to speed up the site (a problem that has been hurting my google responses) so I added that too. (not sure why the heck I would try two things at once)

    I then saved it, and then activated the root folder bullet proof mode, and boom, internal error 500.  In the end, this is what I added, and there are more details following..

    memory_limit = 200M
    upload_max_filesize = 200M
    post_max_size = 200M
    file_uploads = on
    [standard Speed Boost cache code checked and then deleted]

    I tried to delete the htaccess file, not sure what root means, but it was in the main folder for that website (not the root webpage, but an add on page), located here: public_html/projectstudentsafety.org It started off reading,

    # RewriteRule ^(.*)$ - [F] works in /wp-admin without breaking WordPress
    # RewriteRule . /index.php [L] will break WordPress

    I believe that means it is the admin file, meaning I have no idea where the root one is (when I delete it, it does nothing).  Also I am running a network with a sub domain (Main Domain is a blog, sub domain is bp), but I do not think I set this up on the network (I may be wrong, it was a while ago), but neither are working.

    I am okay with anything that can bring this back as quickly as possible. I am working on breaking a story on my blog and really need it fixed fast.  If there is a way to use the back up (I backed up the htacess right before I did this), or just uninstall, which at this point I am think is the smart move, this is way too high tech for me, I don’t get half the conversations on how to fix these things and dont even know what a root file is lol…

    Please, someone help…

    AITpro Admin

    The simplest thing to do would be to reverse all the changes you made.  If you created a custom php.ini file then rename it to php.ini.BAK for now.  Doing that will load the server’s default php.ini file.  Delete both your root and wp-admin .htaccess files, log into your website, remove any additional custom code that you added (Speed Boost Cache code), click the Save Custom Code button, go to the BPS Security Modes page and click the Root Folder BulletProof Mode Activate button.


    That much I took from reading forums.  I have no idea where the php.ini file is, and I tried to delete the .htacess from the folder root file for the website (I explained all this already, but the root folder had the admin fine, and the admin folder did not have any .htacess file).

    AITpro Admin

    I reread what you posted and you must have used a web host control panel tool to add PHP Configuration settings changes.  In that case the PHP Configuration setting changes you made in your web host control panel are probably fine and not the problem.  Your website root folder is the same folder where your WordPress site is installed and where you will find the wp-config.php file.  Your wp-admin folder is this folder:  /wp-admin/.  The backed up .htaccess files are stored in this folder:  /wp-content/bps-backup/master-backups/.  Download the root.htaccess backup file, upload it to your website root folder/WordPress installation folder and rename it to .htaccess.


    I did it and it did nothing….   can I have my host restore backed up files from 5 days ago without backing up the sql?

    AITpro Admin

    Yes you can do a file restore only and not a database restore.  If you replaced your orginal backed up .htaccess file and the same problem is occurring then the problem must be caused by something else.  Maybe your PHP Configuration setting changes are the problem after all.  Have your host check those settings to see if they are the cause of the problem.

    Or another possibility is that your backed up .htaccess files after the problem code was already in them.  You can try creating a generic WordPress root .htaccess file and uploading it to your website root folder.  See this WordPress Codex page for the correct htaccess code to use for your particular Network/Multisite site type:  http://codex.wordpress.org/htaccess#Multisite

    You would create a plain text file using Notepad, save the file with this name: default.htaccess, upload it to your WordPress installation folder and rename it to .htaccess.


    [Topic has been merged into this relevant Topic]
    Good Day,
    I have WordPress 4.5.2
    I cannot make a htaccess file. It gives me an 500 server error. If I re-name the file and create a new one my site works, but displays the following: –

    BPS Alert! Your site may not be protected by BulletProof Security
    The BPS version: BULLETPROOF .xx.x >>>>>>> SECURE .HTACCESS line of code was not found at the top of your Root htaccess file.
    The BPS version line of code MUST be at the very top of your Root htaccess file.
    Click Here to go to the BPS Setup Wizard page and click the Setup Wizard button to setup the BPS plugin again.
    Important Note: If you manually added other htaccess code above the BPS version line of code in your root htaccess file, you can copy that code to BPS Root Custom Code so that your code is saved in the correct place in the BPS root htaccess file.
    Click Here to go to the BPS Custom Code page, add your Root custom htaccess code in an appropriate Root Custom Code text box and click the Save Root Custom Code button before running the Setup Wizard again.

    If I do this, it gives me the 500 Server error.

    AITpro Admin

    @ Firecorp – Try these 3 things below and let me know if they work.

    Some Web Hosts do not allow you to use the “Options” Directive in .htaccess files.

    500 Internal Server Error After Adding New custom .htaccess Code To BPS Custom Code

    Your Host does not allow locking the root .htaccess file.  Change the root .htaccess file permissions to 644

Viewing 15 posts - 31 through 45 (of 47 total)
  • You must be logged in to reply to this topic.