500 Internal Server Error

Home Forums BulletProof Security Free 500 Internal Server Error

Tagged: 

This topic contains 46 replies, has 11 voices, and was last updated by  AITpro Admin 3 years, 4 months ago.

Viewing 15 posts - 1 through 15 (of 47 total)
  • Author
    Posts
  • #7128

    Will
    Participant

    Hi,

    New at this so let me know what else you need to know to be able to help.  My issue:

    I have BPS (free) installed as a plugin in WordPress (current version) on my site blog.williamlee.com.  With BPS implemented, the website homepage loads fine, but when I click into the Post I get a 500 error.

    I have narrowed it down to this: When BPS installs the .htaccess file in my root directory, I then get a 500 error that reads: “The server encountered an internal error or misconfiguration and was unable to complete your request.  Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.”

    When I load my backed-up copy of the original .htaccess file into the root directory and overwrite the BPS version, my site functions correctly again.

    I followed the troubleshooting notes that I found here on the forum to comment out (by adding a #) both individually and together the Options and DirectoryIndex in the .htaccess file in the root directory, but this didn’t change the error.  Now I’m at a loss.  Please suggest next steps.

    Thanks,

    Will

    #7131

    AITpro Admin
    Keymaster

    Are you clicking the Root folder BulletProof Mode Activate button?

    #7132

    AITpro Admin
    Keymaster

    It looks like you may be doing something with DNS.  Like forwarding or aliasing this domain.  When I look at your source code I see this URL. 02d760e.netsolhost.com/blog/ This might cause BPS to NOT see the correct RewriteBase.  Also the subdomain is this URL is shown as a subdirectory /blog/. Example:  forum.ait-pro.com is the URL in the source code of this site.  This Forum subdomain site has an A record created for it:  forum. The correct RewriteBase would be RewriteBase / and not RewriteBase /blog/ if this site is a true subdomain site that has an A or CNAME record setup correctly for it.

    #7135

    AITpro Admin
    Keymaster

    Also it appears that you have setup a Custom Permalink Structure using:  /%category%/%postname%/ correct?

    #7136

    Will
    Participant

    I’ll answer in sequence:

    1) Yes, I activated BulletProof modes for Root folder and wp-admin folders.
    2) I don’t have enough technical knowledge to answer the 2nd question offhand but will dig into it if you need me to.
    3) The permalink structure selected in my settings is shown by this sample:    http://blog.williamlee.com/sample-post/
    NEW:  Perhaps of interest…. When checking the permalink structure, I saw this at the bottom of the permalink settings page:
    If your .htaccess file were writable (http://codex.wordpress.org/Changing_File_Permissions), we could do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file. Click in the field and press CTRL + a to select all.

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    #7138

    AITpro Admin
    Keymaster

    The Pretty Permalink option you choose is fine, but when I look at your URL’s I see “category” in the URL path.  It should just be domain-name/postname instead of /domain-name/category/postname like I see when I looked at your URL’s.  The only logical guess I have about that is maybe your SEO plugin is overriding the WP Permalink settings. You can disregard the WP message on the Permalinks page.  This means that your root .htaccess file is locked and WP cannot write to it which is fine. When you look at your root .htaccess file what RewriteBase do you see?  It should be RewriteBase /.

    #7139

    Will
    Participant

    1) Regarding the permalink structure, when my site is working properly, this is the URL I see for the post that generates the 500 error once I use BPS: http://blog.williamlee.com/hot-air-balloon-festival-in-new-jersey/ No category showing here…. or is that hidden and what you told me you see is the real one?

    2) The RewriteBase I see in my active, functioning root .htaccess file is RewriteBase /
    FYI, so far I have made no changes, just answered your questions.  Do you feel like you might have identified the problem and a solution?  I don’t want to waste your time if this is a wild goose chase.  Let me know your thoughts on if or how to proceed.  Thanks

    #7141

    AITpro Admin
    Keymaster

    I see what is going on with these:  blog.williamlee.com/category/photography/gear/ they are categories displayed in your menus.  I guess that is not relevant after all.

    My best guesses are that either this is a DNS issue or has something to do with this URL:  02d760e.netsolhost.com/blog/ which may mean that you are using a CDN or some other type of cloud service.  Not really sure at this point.

    Does you current .htaccess file have Network Solutions .htaccess code in it already?  Do you have existing custom .htaccess code that you need to keep and combine into the BPS .htaccess code?  Maybe your Host would be willing to help you out with this?

    #7253

    Ken
    Participant

    Hello, I have a similar problem.  I uploaded BulletProof Security to my site http: //goodhealth.co.nf and followed the instructions I received from a PDF I downloaded. After my second activation of the settings, my dashboard lost its familiar format and I get a 500 error when I try to do anything (thank heavens the dashboard is still in view) and my website is now down and showing the same 500 error.

    I don’t know what to do, because now I have no website…

    #7257

    AITpro Admin
    Keymaster

    FTP to your website and delete the root .htaccess file so that your site comes back up.  Then click the BPS free read me first link below for several possible causes for the issue/problem.

    http://forum.ait-pro.com/forums/topic/read-me-first-free/

     

    #7540

    Wizearch
    Participant

    Hi,

    I had the 500 internal error message, I followed the troubleshooting notes that I found in the read-me-first by adding a # on both the Options and DirectoryIndex in the .htaccess file in the root directory, but the error still shows.  I have deleted the root .htaccess file and manage to bring up the website again, what should I do next?

    Rgds

    #7543

    AITpro Admin
    Keymaster

    A 500 error typically means that you have invalid htaccess code in your .htaccess file or your Server does not allow you to use some of the .htaccess code in BPS .htaccess files or your Server does not allow .htaccess files to be used on your website at all or your Host does not allow you to lock your root .htaccess file.

    Post this information about your website that you will find on the BPS System Info page.

    Host by Address:
    DNS Name Server:
    Server Type: Apache
    Operating System:
    Server API:

    WP Permalink Structure:
    Permalinks Enabled:

    The cPanel Broken HotLink Protection Tool problem
    http://forum.ait-pro.com/forums/topic/read-me-first-pro/#cpanel-hotlink-protection

    Your Host does not allow locking the root .htaccess file.  Change the root .htaccess file permissions to 644.
    http://forum.ait-pro.com/forums/topic/read-me-first-pro/#root-htaccess-file-lock

    #10890

    Kara
    Participant

    Hello, I have a similar problem.  BulletProof Security Pro was running fine until I attempted to use the Custom Code to increase speed.  Now, the only way that I can avoid a 500 Internal Server Error is to delete the .htaccess files on the server and delete BulletProof Security Pro.  I am guessing that I made a change to the Custom Code that BulletProof is “saving” for me.

    How do I return to the default .htaccess in BulletProof Security Pro?  I have overwritten my backup copy in my attempts to reload the program so I don’t believe that that will work.

    #10891

    AITpro Admin
    Keymaster

    A 500 error in this case means that some of the code you added to Custom Code is not valid.  Or it could mean that your Host does not allow something in that code.

    You never need to deactivate or delete the BPS Pro plugin for troubleshooting.  BPS Pro is a very advanced plugin and troubleshooting is built into every single security feature – you can turn everything On or Off when troubleshooting.

    http://forum.ait-pro.com/forums/topic/read-me-first-pro/#bps-pro-general-troubleshooting

    In this particular case do these steps:

    1. Delete your root .htaccess file.

    2. Log into your site.  If BPS Pro is uninstalled then reinstall BPS Pro.  DO NOT use the Setup Wizard until after you go to BPS Pro Custom Code and have deleted the Speed Boost Cache code from BPS Pro Custom Code and clicked the Save Root Custom Code button.

    3. You can now run the Pre-installation Wizard and Setup Wizard again.

    If you would still like to try and use the Speed Boost Cache code again then make sure you are copying it directly from this site and directly into the correct BPS Custom Code text box.  Make sure that you are copying all of the code exactly as it is on this site.  Then click the Save Root Custom Code button, go to the BPS Security Modes page and click the Root Folder BulletProof Mode Activate button.  If your website crashes then you cannot use this code on your Server/website/Host.  Delete the root .htaccess file again, log back into your site and delete the Speed Boost Cache code from BPS Pro Custom Code and click the Save Root Custom Code button again.  You can now go the Security Modes page and activate Root folder BulletProof Mode again.

    #10893

    AITpro Admin
    Keymaster

    Activity Stream Update copied into this topic

    As an update, I reinstalled BPS Pro and everything went fine until I clicked on BulletProof mode for ”Activate Website wp-admin Folder htaccess Security Mode.” I then got a 500 Internal Server error.

    I then had to delete BPS Pro and the .htaccess files to continue.

Viewing 15 posts - 1 through 15 (of 47 total)

You must be logged in to reply to this topic.