500 server error

Home Forums BulletProof Security Pro 500 server error

Tagged: 

Viewing 15 posts - 16 through 30 (of 40 total)
  • Author
    Posts
  • #18715
    AITpro Admin
    Keymaster

    Yeah a second pair of eyeballs are great for catching silly typos. ūüėČ ¬†I do it all the time so thank god someone else is checking my “fat finger” typing. ha ha ha.

    #18718
    AITpro Admin
    Keymaster

    A last question (a bit off topic): Why do i have no problems with the additional rules in the past? And do i have to clean the hyper cache after i save some changes in BPS-Pro?

    Just noticed that you added some more info to your previous reply.

    I guess the additional rules were saved in your Plugin Firewall options, but probably had not been created in the Master File or the actual Plugin Firewall htaccess file by clicking the Save Whitelist Options¬†button. ¬†If they did actually exist in your Plugin Firewall htaccess file then you would have seen errors since that is not valid htaccess code. ¬†Without using “Allow from” in front of either domain names or IP addresses it is gibberish to your Apache Server and will either crash the server or cause other whacky problems since that is not valid htaccess code.

    Hyper Cache or any other Caching plugin should NOT be caching your WordPress Dashboard / wp-admin area.  So the answer is no.

    Also htaccess files are server configuration files so they are processed first by your server before any other code on your website and htaccess files are not publicly displayed like HTML or PHP files so they do not get cached.

    #18759
    Kouichi Sugawara
    Participant

    Hi AITpro

    BPS PRO Activate Problem

    1. Due to HTTP open Error  Problem,  so I Removed BPS-PRO by FTP.
    2. Correct Error on wp-config.php.
    3. Import Backup database due to not fixed on step-2.
    4. Fixed Problem.
    5. Then upload  BPS-PRO again.
    6. On Activation error as follows:

    Warning: require_once(/var/www/html/plugin-admindocs.com/wp-content/plugins/bulletproof-security/admin/includes/admin.php): failed to open stream: No such file or directory in /var/www/html/plugin-admindocs.com/wp-content/plugins/bulletproof-security/bulletproof-security.php on line 109 
    Fatal error: require_once(): Failed opening required /var/www/html/plugin-admindocs.com/wp-content/plugins/bulletproof-security/admin/includes/admin.php (include_path='.:/usr/share/pear:/usr/share/php') in /var/www/html/plugin-admindocs.com/wp-content/plugins/bulletproof-security/bulletproof-security.php on line 109

    7. Tried to remove Folder bps-backup, but remained.

    Please advise.

    #18761
    AITpro Admin
    Keymaster

    Delete the /bulletproof-security/ plugin folder and then reinstall the BPS Pro zip file:  bulletproof-security.zip using the WordPress Upload Zip installer.  This will reinstall the BPS Pro plugin files and will not change any of your BPS Pro plugin settings.

    #19050
    jenni101
    Participant

    [Topic merged into this relevant Topic]

    I tested the new BPS Pro update on my small site (sits as an addon domain in a subfolder), going through the steps and all seemed good.

    So i decided to do the same for my main root install site, but after i clicked the Activate Bullet Proof Mode the whole layout of the BPS console broke and when I try to activate the wp-admin Bullet proof mode it returns an internal 500 server error page – in fact it now does this on EVERYTHING i click on, both in my root installed site and also now in my site in it’s subfolder in the admin sections AND for every website page for the front-end too.

    Don’t know what to do as can’t find it in the forum – should I just re-name the BPS plugins folder in cPanel, then uninstall it in my admin section? But then which BRP Pro should I reinstall? Urgent help much appreciated!

    Update:
    I renamed the BPS plugin folder, but this had no effect on anything; so I went to plan B and deleted the main site root and wp-admin .htaccess files completely. This means I can now access my admin areas on my main root installed site AND my addon domain site (In subfolder, even though it still has it’s updated BPS plugin activated). But of course hte main site BPS is no longer active/recognised.

    So what the next thing I should do now?
    Cheers.

    #19055
    AITpro Admin
    Keymaster

    The 2 sites should not be affecting each other.  If they are then something is wrong with how they are setup.  Uninstall BPS Pro and reinstall BPS Pro by using the WordPress Upload Zip installer and run the Setup Wizard.

    #19057
    jenni101
    Participant

    I can’t track down your detailed instructions for correctly uninstalling BPS pro – can you popst the link please as I want to do it correctly before I reinstall by the zip upload method? Or is it OK to just click the ‘delete’ link for the plugin, even though I’ve renamed the plugin folder so I can access my site again?

    #19058
    AITpro Admin
    Keymaster

    That’s because there are no detailed instructions for uninstalling or installing BPS Pro. ¬†Uninstall BPS Pro on the WordPress Plugins page just like any other plugin. ¬†Then use the WordPress Upload zip installer to install the bulletproof-security.zip file. ¬†See the BPS Pro Installation, Activation and Setup Wizard video tutorial: ¬†http://forum.ait-pro.com/video-tutorials/#setup-wizard¬† Installation, activation and setup should take about 5 minutes. ¬†Or you can just delete the /bulletproof-security/ plugin folder and do the WordPress Upload Zip installation and run the Setup Wizard.

    #19062
    AITpro Admin
    Keymaster

    Uninstallation and installation should be very simple and quick, but it sounds like something is seriously messed up with this website so if you would like for me to look at this website and tell you what is wrong with the website then send me an Administrator login to this website.

    We don’t offer website repair or any other services besides BPS Pro support so I will only fix things that are not related to BPS Pro ONLY if they are a quick fix that I can do in a couple of minutes.  If the problem is a much bigger problem then I can at least tell you what needs to be fixed, but will not actually fix the problem if it is not directly related to BPS Pro.

    #19087
    jenni101
    Participant

    Well, I thought I should work through it all sytematically first, as it was all absolutely fine before the update. So what I’ve since done is this:

    1. renamed bps plugin folder, deleted main htaccess file in site root and in wp-admin
    2. logged in and renamed bps plugin folder to original
    3. deleted plugin via wp plugin section
    4. downloaded new bps zip file and uploaded it via wp plugin upload.
    5. went through the bps setup wizard
    6. added a few extra bits of custom code, that I’d had before in custom code section (like speed boost, brute force login (2nd code block), block spammers and stop bots finding author names)
    7. created secure htaccess
    8. create bulletproof mode for root folder and wp-admin folder.

    I did this FIRST on my addon domain first, which sits in a subfolder of my main site. This first site was fine, BUT it then caused all pages on my main site to show as 404 errors (all except for the index.php – very weird!). I thought this was because i still had to setup a new htaccess file in my main site, as it had been deleted to get the site working again, so I went ahead and setup BPS pro exactly as above for my main root installed site, with the addition of Rewrite rules to allow my addon domain site and¬† my image library software, in a subfolder. This is the same that I’d had before the update and it was all working fine then.

    However,  when I got to #8 (see above) it did exactly the same as it did when I first updated it РI clicked the create bulletproof mode for root folder and then the whole BPS layout broke, and my whole site now returns a 500 internal server error again.

    So now I’ve deleted bps on both wp sites, as just deactivating it didn’t fix the problem. Unfortunately it just seems to be getting worse, as even though I’ve deleted the htaccess files, renamed the bps folder, then deleted the plugin via the plugin manager, there still remains the bps-backups folder on the server (for both sites) and both wp sites ONLY show the index.php page, and ALL other pages return a 404 error – all except my non-wp app my image library, which is working just fine! Is it because they now don’t have any /htaccess files?

    I would really appreciate it if you could have a quick look and will email you login details as you suggested. It’s probably (hopefully) something really obvious to you…

    Many thanks.

    #19088
    AITpro Admin
    Keymaster

    Yep sure no problem. ¬†So if I understand you correctly then the website installed of the root in your hosting account folder is the only site with a problem. The other site or sites are fine correct? ¬†Create a temporary Administrator login to the site installed in your root hosting account that has the problem. ¬†Send the login info to edward at ait-pro dot com. ¬†I believe this is a job for Super Ed. ¬†ūüėČ

    #25899
    Hannah
    Participant

    Hi, I promised to buy BPS Pro the weekend of 10/10, but better late than never, I just purchased BPS Pro and followed the instructions up to running the pre-installation wizard. As soon as I started this wizard, the admin age I was on came up garbled and there was a message saying I had entered an invalid activation key and to go back and re-enter the key, then went down with a 500 ISE error, so am unable to get into admin to do this.¬† I renamed the BPS plugin folder via ftp but the error persists.¬† I did have BPS free installed and running fine on this site prior to installing, I checked Wordfence and confirmed that the BPS IP was not being blocked, and I checked http://www.ait-pro.com/pd/ and see the activation key. The front-facing site appears to be fine, which is a relief. I chose this particular site to install Pro first because it’s been under a pretty bad brute force attack, but the fact that it’s gone down is something of a problem because it’s a priority client. And because I happen to have guests at the moment (*sigh). Thankfully the front-facing site appears to be fine, which is a relief, but if you could tell me how to bring admin back up so I can complete the installation before things get hectic here, that would be awesome. Couple more bits of info: I’ve tried to access the BPS security log, but it won’t let me see it either via ftp or the file manager on the server. I don’t see my IP on the server access log and can’t seem to find a server error log on the hosting account either. the public-facing site has just gone down with a 500 ISE, too, so now it’s become an emergency. Thanks!

    #25904
    AITpro Admin
    Keymaster

    Sounds like a problem with some invalid htaccess code in the root htaccess file.  Use FTP or your web host control panel file manager and copy your root htaccess file and send it to me and then delete it from your website.  Let me know if you can get back into your site.

    #25906
    Hannah
    Participant

    Oops, replied by email and not here. Wow, There is content in it as it shows it’s 15.7 K, but when I attempt to view it, the root htaccess file is blank. I deleted it. I’m unpacking the latest backups so I can get the root htaccess code for you. be right back.

    #25907
    Hannah
    Participant

    This is from 9/21/15, but I don’t think anything would have changed since then. The Allow From IP address had become out of date as we had a blackout at my place recently and the router assigned me a new IP. Maybe that’s what freaked it out?:

    [code copied and deleted]

Viewing 15 posts - 16 through 30 (of 40 total)
  • You must be logged in to reply to this topic.