Pre-installation Wizard, Setup Wizard does not complete, hangs, memory issue

Home Forums BulletProof Security Pro Pre-installation Wizard, Setup Wizard does not complete, hangs, memory issue

This topic contains 55 replies, has 11 voices, and was last updated by  jenni101 1 year, 7 months ago.

Viewing 15 posts - 31 through 45 (of 56 total)
  • Author
    Posts
  • #29031

    AITpro Admin
    Keymaster

    List of common known issues that will cause the Setup Wizard to hang:  http://forum.ait-pro.com/forums/topic/pre-installation-wizard-setup-wizard-does-not-complete-hangs-memory-issue/page/4/#post-31341

    @ dtyler1 – Go to the Setup Wizard Options tab page > cURL Scan Option: Turn On|Off cURL Scan > select Turn Off cURL Scan > click the Save cURL|DB Monitor Options button > run the Pre-Installation Wizard again > run the Setup Wizard again.

    #29032

    dtyler1
    Participant

    Completed steps and it still hangs.

    #29033

    AITpro Admin
    Keymaster

    Ok send an Administrator login to this website to:  info at ait-pro dot com so I can figure out the problem.

    #29034

    AITpro Admin
    Keymaster

    List of common known issues that will cause the Setup Wizard to hang:  http://forum.ait-pro.com/forums/topic/pre-installation-wizard-setup-wizard-does-not-complete-hangs-memory-issue/page/4/#post-31341

    Ok I finally got the Setup Wizard to complete by creating an AutoRestore wp-content folder exclude rule for your Theme:  Total Theme.  The Total Theme has 756 files and has several very large zip files bundled with it and several other very large files.  It is perfectly safe to exclude theme files from being checked by ARQ.  The Setup Wizard still takes longer than it should and that might be because of the HTTPS/SSL issue/problem that is still occurring on your website.  Previously I added the correct HTTPS/SSL htaccess code that works every time on sites/hosts/servers all over the world. Why it does not work on your server I have no idea.  Anyway I did not add that HTTPS/SSL htaccess code again, but you still have the original problem on your website where visiting the HTTP URL does not redirect to the HTTPS URL.  non-www does redirect to www correctly, but it is HTTP www and not HTTPS www, which is what it should be.  You should contact your host to ask them to assist you for that problem.

    #29037

    dtyler1
    Participant

    I appreciate your efforts. Help me understand why the BPS Pro installation cancels the redirect to the https URL? Does BPS Pro ignore this in the original root .htaccess. Before BPS Pro was installed it redirected all traffic to https://.  If it is a hosting/server issue, any clues to what needs to be done?

    #29039

    AITpro Admin
    Keymaster

    Normally you would use this BPS HTTPS/SSL rewriting htaccess code: http://forum.ait-pro.com/forums/topic/wordpress-ssl-htaccess-code-rewrite-ssl-rewritecond-server_port/#post-7233  to fix the problem that is occurring on your site. Example:  many folks want to know how to get their site redirecting correctly from HTTP to HTTPS as you can see in the forum link above.  They use the BPS HTTPS/SSL rewriting htaccess code in the link above and that fixes the problem.  So BPS does not or would not cause this problem and would instead fix this type of problem.  My guess would be the issue may have something to do with a setting in your web host control panel, but trying to guess what that is would not really be helpful so contact your web host support and ask them why this problem is occurring on your website/server.

    #30063

    Pako
    Participant

    [Topic has been merged into this relevant Topic]
    Hi
    I have been waiting about 15mn with ” Processing…” install so I decided to click on the top button “refresh”.
    I do not know if the installation process is ok.
    My Security Log entry is ful of error…
    All the readme windows are full displayed…
    I have to mention that this site is protected by Incapsula > maybe I have to do something about that ?
    Thanks

    #30065

    AITpro Admin
    Keymaster

    List of common known issues that will cause the Setup Wizard to hang:  http://forum.ait-pro.com/forums/topic/pre-installation-wizard-setup-wizard-does-not-complete-hangs-memory-issue/page/4/#post-31341

    @ Pako – Turn off the Setup Wizard Options cURL Scan option…

    cURL Scan Option: Turn On/Off cURL Scan: You can use the cURL Scan Option below to turn Off cURL scans when running the Wizards. If the Pre-Installation Wizard is crashing/not completing then select & save the Turn Off cURL Scan option and run the Pre-Installation Wizard again. The cURL Scan Option is set to On by default. The Plugin Firewall will need to be setup manually if the Wizards are unable to complete this automatically.

    #30066

    Pako
    Participant

    I have found in another post that thoses Ips should be whitlisted to use Incapsula services:

    199.83.[0-9]{1,3}.[0-9]{1,3}, 198.143.[0-9]{1,3}.[0-9]{1,3}, 149.126.[0-9]{1,3}.[0-9]{1,3}, 103.28.[0-9]{1,3}.[0-9]{1,3}, 45.64.[0-9]{1,3}.[0-9]{1,3}, 185.11.[0-9]{1,3}.[0-9]{1,3}, 192.230.[0-9]{1,3}.[0-9]{1,3}, 2620:28:400[:\\d\\w]+, 2a02:e98[:\\d\\w]+

    That’s what I have done and the readme windows display now good. But is it possible to whitelist those Ips before Wizard intall?
    regard to your answer do I have to re-run the setup?

    #30067

    AITpro Admin
    Keymaster

    List of common known issues that will cause the Setup Wizard to hang:  http://forum.ait-pro.com/forums/topic/pre-installation-wizard-setup-wizard-does-not-complete-hangs-memory-issue/page/4/#post-31341

    Yes, you could do these steps in this order to add the Incapsula IP addresses first before running the Wizards. Great Job on figuring this solution out yourself!

    1. Install BPS Pro.
    2. Activate BPS Pro on your website.
    3. Instead of running the Wizards at this point, do the steps here: http://forum.ait-pro.com/forums/topic/incapsula-cdn-401-error-authorization-required/#post-26856
    4. Then run the Wizards.

    #30068

    AITpro Admin
    Keymaster

    @ Pako – The Wizards are designed to resave your custom settings or save default settings if no settings have been selected/chosen for any/all BPS Pro features or options.  You can re-run the Wizards at any time and your custom settings will not be changed.

    #30069

    Pako
    Participant

    Thanks mister AIT Pro 😉

    But do I have to re-run the setup wizard with cURL Scan Option set to off?

    Thanks

    #30071

    AITpro Admin
    Keymaster

    List of common known issues that will cause the Setup Wizard to hang:  http://forum.ait-pro.com/forums/topic/pre-installation-wizard-setup-wizard-does-not-complete-hangs-memory-issue/page/4/#post-31341

    Nope you don’t have to re-run the Wizards with the cURL Scan option Off, but since you are obviously a very savvy/technically skilled person then here is an overview of the history of cURL scanning in the Wizard for the Plugin Firewall to get Plugin Firewall whitelist rules.  The Setup Wizard cURL Scanner was originally created to get plugin script whitelist rules for the Plugin Firewall when running the Wizards.  Later on we created the Plugin Firewall AutoPilot Mode feature, which creates Plugin Firewall whitelist rules in real-time.  So basically the cURL Scan in the Wizard is no longer needed/necessary and will probably be phased out at some point.  There is one case where the cURL scanner causes the Wizard to hang and that is if someone has a Dedicated or VPS server.  The problem has to do with how the Setup Wizard cURL scanner gets URI’s from the Database.  So typically if someone does not have a Dedicated or VPS server then the cURL scanner does not hang, but it is also an obsolete option thing that is pending a final decision on whether or not to delete it or modify it.

    #31161

    Zsolt Edelényi
    Participant

    [Topic has been merged into this relevant Topic]
    I used BPS for years, never experienced such a thing: After pre-installation completed without error, I run setup wizard. It started, but  never ended for minutes. The last line is the following:

    bulletproof_security_options_flock_FL_alerts DB Option created or updated Successfully!
    I switched off the other plugins, and also deleted and reinstalled the BPS pro. Always the same.
    Once: wp-admin disappeared. I had to deactivate BPS from the phpmyadmin. After everything worked well.
    Please help me out. This is bug or other? I use v 12.4

    #31165

    AITpro Admin
    Keymaster

    List of common known issues that will cause the Setup Wizard to hang:  http://forum.ait-pro.com/forums/topic/pre-installation-wizard-setup-wizard-does-not-complete-hangs-memory-issue/page/4/#post-31341

    Check the BPS Pro System Info page and post your PHP Actual Configuration Memory Limit: and PHP Memory Usage:  information.  If you are using a file backup plugin then make sure that you have created an AutoRestore wp-content folder exclude rule so that you are not backing up extremely large zip backup files to AutoRestore backup.  Also check to make sure that you are excluding any other wp-content or other folders that contain extremely large zip or other file types.  Also see this reply in this forum topic for another possible cause of the problem:  http://forum.ait-pro.com/forums/topic/pre-installation-wizard-setup-wizard-does-not-complete-hangs-memory-issue/page/3/#post-29034

Viewing 15 posts - 31 through 45 (of 56 total)

You must be logged in to reply to this topic.