Pre-installation Wizard, Setup Wizard does not complete, hangs, memory issue

Home Forums BulletProof Security Pro Pre-installation Wizard, Setup Wizard does not complete, hangs, memory issue

This topic contains 55 replies, has 11 voices, and was last updated by  jenni101 1 year, 7 months ago.

Viewing 15 posts - 16 through 30 (of 56 total)
  • Author
    Posts
  • #18841

    AITpro Admin
    Keymaster

    List of common known issues that will cause the Setup Wizard to hang:  http://forum.ait-pro.com/forums/topic/pre-installation-wizard-setup-wizard-does-not-complete-hangs-memory-issue/page/4/#post-31341

    @ Jan Wessels – Reboot your Server, set the cURL Scan Option to Off and run the Pre-Installation Wizard again.  The cURL Scan option was created specifically for this issue/problem and will prevent the same problem from occurring again.  You will need to setup the Plugin Firewall manually.  Click the Plugin Firewall Read Me help button for manual setup steps.

    In BPS Pro 9.8 the Plugin Firewall will have a new feature called AutoPilot Mode that will automatically add Plugin Firewall whitelist rules in real-time.  ETA on release of 9.8 is 11-5 to 11-12.

    #18843

    Jan Wessels
    Participant

    Hi,

    Thanks for your feedback on this!

    Good news that the whitelist will be updated in real-time in the 9.8 version.

    #19890

    Paul
    Participant

    [Topic has been merged into this relevant Topic]
    I had a strange issue regarding 404
    I installed BPS Pro, run pre check and got the red indicators for Firewall. Trying to access that page from the links by the red information i got a 404 not found.
    I could not find a way to access this, so i went back tried run installer and within 1 second it showed as installed (um normally longer)
    So i then manually checked everything and it all seemed ok, i then edited the firewall plugin htaccess saved and activated plugin htaccess.
    Did a system status check and all is shown as protected.
    So not sure why the 404 apart from all i can think of is in the custom code wp-admin i had the code to turn on wp-admin password protect directory. I have now removed that everything seems

    #19894

    AITpro Admin
    Keymaster

    “…got the red indicators for Firewall…”

    Was there an error message? If so, what was the error message?

    #19895

    Paul
    Participant

    It was just telling me that the whitelist rules were wrong, i.e it had filled with junk as per earlier postings, but the link to goto the firewall page provided in pre check, was a 404.

    I currently have issue with this other site, basically my contact form that i have checked and is set correctly, was fine earlier, now instead of directing to a thanks page /thanks/ now directs to /form/#FSContact1 sends no mail and in status bar of chrome it shows 1st December 0000 archive

    http://www.thamesvalleydiscos.co.uk/form/

    hit submit with no info filled does not ask for any information that is required. Same form on other site i did earlier appears ok.

    #19898

    AITpro Admin
    Keymaster

    List of common known issues that will cause the Setup Wizard to hang:  http://forum.ait-pro.com/forums/topic/pre-installation-wizard-setup-wizard-does-not-complete-hangs-memory-issue/page/4/#post-31341

    Oh ok I will double check the link and make sure it is valid.

    Your other unrelated question was split into a new Forum Topic here:  http://forum.ait-pro.com/forums/topic/fast-secure-contact-form-not-redirecting-to-thank-you-page/

    #20201

    Riccardo
    Participant

    [Topic has been merged into this relevant Topic]

    Hi!

    I got the “Internal Server Error” after clicking on the button “Run pre-installation Wizard Checks” in BPS Pro. On the same server, there are other sites where the wizard ran without problems, only this site is giving that error, so I don’t think is a server issue. What should I do to solve the problem? Thanks!
    The error log of the website shows this when the problem occurs:

    [Tue Dec 23 09:50:28 2014] [warn] [client 88.44.124.74] mod_fcgid: read data timeout in 45 seconds, referer: http://www.portedelpassato.com/wp-admin/admin.php?page=bulletproof-security/admin/wizard/wizard.php
    [Tue Dec 23 09:50:28 2014] [warn] [client 88.44.124.74] (110)Connection timed out: mod_fcgid: ap_pass_brigade failed in handle_request_ipc function, referer: http://www.portedelpassato.com/wp-admin/admin.php?page=bulletproof-security/admin/wizard/wizard.php
    
    #20210

    AITpro Admin
    Keymaster

    List of common known issues that will cause the Setup Wizard to hang:  http://forum.ait-pro.com/forums/topic/pre-installation-wizard-setup-wizard-does-not-complete-hangs-memory-issue/page/4/#post-31341

    @ Riccardo – Set the cURL Scan Option to Off and run the Pre-Installation Wizard and Setup Wizard

    #20216

    Riccardo
    Participant

    Thanks a lot! I didn’t notice the note on the Setup Page about turning cURL scanning off…

    #20219

    AITpro Admin
    Keymaster

    Yep, that needs to be changed from just displaying a static plain text help message to creating an error check that displays a solution like – “X caused Y so do Z….”.  This is on the task list and will be added in a future BPS Pro version.

    #28494

    Alison
    Participant

    [Topic has been merged into this relevant Topic]
    Hi,
    whenever I use the pre-set up wizard, followed by the set up wizard, I automatically get a 500 error page on my website. The only way I can get back in again is to restore my htaccess file by FTP, and deactivate BulletProof Pro. Any idea what could be causing this? Thanks, Alison.

    #28497

    AITpro Admin
    Keymaster

    List of common known issues that will cause the Setup Wizard to hang:  http://forum.ait-pro.com/forums/topic/pre-installation-wizard-setup-wizard-does-not-complete-hangs-memory-issue/page/4/#post-31341

    @ Alison – It sounds like you have some pre-existing htaccess code that needs to be added to BPS Custom Code before running the Wizards.  We would be glad to take care of this for you and setup BPS Pro on your site.  If you would like for us to setup BPS Pro on your site then send a WordPress Administrator login to this site to:  info at ait-pro dot com.  If instead you want to figure this out on your own then either post your current root htaccess file in your forum reply or send your current root htaccess file to:  info at ait-pro dot com.  Also go to the Setup Wizard Options tab page and turn off this option: cURL Scan Option: Turn On/Off cURL Scan.  I do not think the cURL scanner is involved in the problem, but the newer Plugin Firewall AutoPilot Mode automatically creates Plugin Firewall whitelist rules in real-time so the cURL scan during running the Wizard is not really necessary any longer.

    #28504

    Alison
    Participant

    Thank you, I will send WP and FTP login details to you now, at the moment the website has a 403 error message and cannot be accessed at all by staff or parents. 🙁

    #28506

    AITpro Admin
    Keymaster

    List of common known issues that will cause the Setup Wizard to hang:  http://forum.ait-pro.com/forums/topic/pre-installation-wizard-setup-wizard-does-not-complete-hangs-memory-issue/page/4/#post-31341

    Logged into the site.  Several non-BPS Pro problems were found and fixed.  BPS Pro is setup and working on your website, but your web host has a lot of restrictions in place so your web host server is blocking several things in BPS Pro from working.  I sent you a list of things that were fixed and things to check with your web host about.

    #29028

    dtyler1
    Participant

    [Topic has been merged into this relevant Topic]
    I followed the instructions in other threads to deactivate all other plugins but it’s still hanging. There is enough enough memory available. No problem with pre-installation wizard. Seems like BPS Pro is installed, but I can get a confirmation or a chance to look that the  files successfully installed.

Viewing 15 posts - 16 through 30 (of 56 total)

You must be logged in to reply to this topic.